Τώρα είναι Παρ 28 Φεβ 2020 09:08 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 16 Μάιος 2003 03:59 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Αν κάποιος θέλει να ασχοληθεί με ταξινομήσεις αλφαριθμητικών πινάκων (χαρακτήρων), πρέπει να έχει και έναν τρόπο να παράγει τυχαία δεδομένα.
Παλαιότερα έδωσα μια γεννήτρια ψευδοτυχαίων ακεραίων.
Τωρα να και μία για αλφαριθμητικά!
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΥΧΑΙΟΙ_ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  Α, Ν, Κ , Ι
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔ_Χ[10]
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑ ΝΟΥΜΕΡΟ ΜΕΤΑΞΥ 2000 ΚΑΙ 10000'
  ΔΙΑΒΑΣΕ Κ
  ΚΑΛΕΣΕ ΕΚΚ_ΤΥΧΑΙΩΝ(Κ)
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ ΤΥΧ_ΧΑΡ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΕΚΚ_ΤΥΧΑΙΩΝ(Ο)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ο
ΑΡΧΗ
  Α <-- 12123+Ο
  ΚΩΔ_Χ[1] <-- 'Α'
  ΚΩΔ_Χ[2] <-- 'Β'
  ΚΩΔ_Χ[3] <-- 'Γ'
  ΚΩΔ_Χ[4] <-- 'Δ'
  ΚΩΔ_Χ[5] <-- 'Ε'
  ΚΩΔ_Χ[6] <-- 'Ζ'
  ΚΩΔ_Χ[7] <-- 'Η'
  ΚΩΔ_Χ[8] <-- 'Θ'
  ΚΩΔ_Χ[9] <-- 'Ι'
  ΚΩΔ_Χ[10] <-- 'Κ'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
ΣΥΝΑΡΤΗΣΗ ΤΥΧΑΙΑ_Τ(ΑΠ, ΕΩΣ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΠ, ΕΩΣ
ΑΡΧΗ
  Ν <-- N + Α DIV 123
  Α <-- Ν + Α MOD 113031
  Ν <-- (Ν MOD 100)*100+(N DIV 100) MOD 100
  ΑΝ ΑΠ<>ΕΩΣ ΤΟΤΕ
    ΤΥΧΑΙΑ_Τ <-- (Ν MOD (ΕΩΣ-ΑΠ+1))+ΑΠ
  ΑΛΛΙΩΣ
    ΤΥΧΑΙΑ_Τ <-- ΑΠ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΤΥΧ_ΧΑΡ:ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΜΗΚ, Χ
  ΧΑΡΑΚΤΗΡΕΣ: ΤΧ
ΑΡΧΗ
  ΤΧ <-- ''
  ΜΗΚ <-- ΤΥΧΑΙΑ_Τ(4,14)
  ΓΙΑ Χ ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚ
    ΤΧ <-- ΤΧ+ΚΩΔ_Χ[ΤΥΧΑΙΑ_Τ(1,10)]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΥΧ_ΧΑΡ <-- ΤΧ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters