Τώρα είναι Τετ 22 Οκτ 2014 10:57 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 18 Ιαν 2009 05:26 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 32
Τοποθεσία: Αθήνα
:lol: ΕΝΑ ΣΥΜΠΑΘΗΤΙΚΟ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΑΝΕΠΤΥΞΑ ΓΙΑ ΤΟΝ ΑΔΕΡΦΟ ΜΟΥ , ΚΑΠΟΙΟΙ ΜΠΟΡΕΙ ΝΑ ΤΟ ΒΡΟΥΝ ΧΡΗΣΙΜΟ ΑΝ ΕΧΟΥΝ ΜΙΚΡΑ ΑΔΕΡΦΙΑ. ΚΑΛΗ ΕΞΑΣΚΗΣΗ.... :wink:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΆΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ_ΟΛ , Ο , Σ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ , Π , ΑΠ1
ΑΡΧΗ
  ΓΡΑΨΕ ' ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΕΞΑΣΚΗΣΗΣ ΤΟΥ ΜΥΑΛΟΥ , ΠΡΟΣΦΕΡΕΙ ΣΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΔΥΝΑΤΟΤΗΤΑ ΝΑ'
  ΓΡΑΨΕ ' ΕΞΕΤΑΣΕΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ ΣΤΙΣ ΔΙΑΦΟΡΕΣ ΠΡΑΞΕΙΣ .'
  ΓΡΑΨΕ ' ΑΦΙΕΡΩΜΕΝΟ ΣΤΟΝ ΑΔΕΡΦΟ ΜΟΥ!'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  Σ_ΟΛ <-- 0
  Ο <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ' ΜΕ ΤΙ ΘΑ ΗΘΕΛΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ???'
    ΓΡΑΨΕ ' 1.ΑΦΑΙΡΕΣΗ'
    ΓΡΑΨΕ ' 2.ΔΙΑΙΡΕΣΗ'
    ΓΡΑΨΕ ' 3.ΠΟΛΑΠΛΑΣΙΑΣΜΟ'
    ΓΡΑΨΕ ' 4.ΠΡΟΣΘΕΣΗ'
    ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΓΡΑΨΕ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ'
    ΔΙΑΒΑΣΕ ΑΠ
    ΟΣΟ ΑΠ <>'ΑΦΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΔΙΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΚΑΙ ΑΠ<>'ΠΡΟΣΘΕΣΗ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΜΙΑ ΑΠΟ ΤΙΣ ΕΠΙΛΟΓΕΣ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ = 'ΠΡΟΣΘΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΑΦΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΦΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ ='ΔΙΑΙΡΕΣΗ' ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ΜΕ ΚΑΤΙ ΑΛΛΟ?'
    ΔΙΑΒΑΣΕ ΑΠ1
    ΟΣΟ ΑΠ1 <> 'ΟΧΙ' ΚΑΙ ΑΠ1 <> 'ΝΑΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΝΑΙ Ή ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ1 = 'ΟΧΙ'
  ΠΟΣ <-- (Σ_ΟΛ / Ο)*100
  ΓΡΑΨΕ ' ΑΠΑΝΤΗΣΕΣ ΣΕ',Ο,'ΕΡΩΤΗΣΕΙΣ ΚΑΙ ΕΙΧΕΣ ΣΩΣΤΕΣ ΤΙΣ',Σ_ΟΛ
  ΓΡΑΨΕ ' ΠΑΙΡΝΕΙΣ',ΠΟΣ,'ΣΤΑ 100'
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άλεξ



ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    Γ <-- Χ + Υ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ Χ,'+',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      Γράψε' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'+',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(10)  !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΜΗΔΕΝ ΕΙΝΑΙ ΠΟΛΥ ΑΠΛΟΣ!
    Υ <-- ΤΥΧΑΙΟΣ(100)
    Γ <-- Χ * Υ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ Χ,'*',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'*',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΟΣΟ Χ - Υ < 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ - Υ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ Χ,'-',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'-',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Ι , Κ , Σ , Α
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΟΣΟ Χ MOD Υ <> 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΕΝΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ / Υ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ Χ,'/',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'/',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΟΠΩΣ ΠΑΝΤΑ , ΔΕΚΤΕΣ ΟΛΕΣ ΟΙ ΠΑΡΑΤΗΡΗΣΕΙΣ ΚΑΙ ΔΙΟΡΘΩΣΕΙΣ... :D

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 27 Φεβ 2009 07:25 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 27 Φεβ 2009 07:22 pm
Δημοσιεύσεις: 1
Μία ερώτηση να κάνω σε εμένα το τυχαίος μου το βγάζει λάθως μήπως υπάρχει κανένα λάθως;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 28 Φεβ 2009 12:29 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 32
Τοποθεσία: Αθήνα
ΤΟ ΘΕΜΑ ΕΙΝΑΙ ΟΤΙ ΤΑ ΠΡΟΓΡΑΜΜΑΤΑ ΠΟΥ ΒΡΙΣΚΟΝΤΑΙ ΣΕ ΑΥΤΟΝ ΤΟΝ ΤΟΜΕΑ ΑΠΑΙΤΟΥΝ ΤΗΝ ΕΚΔΟΣΗ ΤΟΥ ΜΕΤΑΓΛΩΤΙΣΤΗ ΠΟΥ ΕΙΝΑΙ Η 8.5 ΜΕ ΕΚΕΙΝΗ ΘΑ ΜΠΟΡΕΣΕΙΣ ΝΑ ΛΕΙΤΟΥΡΓΗΣΕΙΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Μαρ 2009 09:38 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Ωραίος, μερικές βελτιώσεις

1) Επιλογή Εξοδος στο μενου
2) Αφου ειναι για παιδακια λιγο ευκολοτερους πολλαπλασιασμους(δεν εβαλα διαιρεσεις) πχ οχι 9*89 αλλα 9*90
(βαθμοι δυσκολιας θα ηταν καλυτερο)
3) Αφου ειναι για παιδιά, λίγο ποιο φιλικό, πχ να γράφει + για προσθεση αντι για την λεξη κτλ
4) αν για απαντηση βαλω γραμμα θα κολλησει , αλλα δεν ξερω αν διορθωνεται αυτο στην γλωσσομαθεια :roll:

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Μαρ 2009 11:26 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 32
Τοποθεσία: Αθήνα
Ορίστε και ένα λίγο βελτιωμένο πρόγραμμα αν και όπως είπα στον φίλο dark lord , θα το βελτιώσω ακόμη περισσότερο το καλοκαίρι που θα έχω χρόνο να ασχοληθώ 8)
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΆΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ_ΟΛ , Ο , Σ , Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ , Π , ΑΠ1
  ΛΟΓΙΚΕΣ: ΕΓΚ
ΑΡΧΗ
  ΓΡΑΨΕ ' ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΕΞΑΣΚΗΣΗΣ ΤΟΥ ΜΥΑΛΟΥ , ΠΡΟΣΦΕΡΕΙ ΣΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΔΥΝΑΤΟΤΗΤΑ ΝΑ'
  ΓΡΑΨΕ ' ΕΞΕΤΑΣΕΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ ΣΤΙΣ ΔΙΑΦΟΡΕΣ ΠΡΑΞΕΙΣ .'
  ΓΡΑΨΕ ' ΑΦΙΕΡΩΜΕΝΟ ΣΤΟΝ ΑΔΕΡΦΟ ΜΟΥ!'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  Σ_ΟΛ <-- 0
  Ο <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ' ΜΕ ΤΙ ΘΑ ΗΘΕΛΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ???'
    ΓΡΑΨΕ ' 1.ΑΦΑΙΡΕΣΗ(-)'
    ΓΡΑΨΕ ' 2.ΔΙΑΙΡΕΣΗ(:)'
    ΓΡΑΨΕ ' 3.ΠΟΛΑΠΛΑΣΙΑΣΜΟ(*)'
    ΓΡΑΨΕ ' 4.ΠΡΟΣΘΕΣΗ(+)'
    ΓΡΑΨΕ ' 5.ΕΞΟΔΟΣ(ΕΧΙΤ)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ ' ΠΟΙΑ ΕΙΝΑΙ Η ΑΠΑΝΤΗΣΗ ΣΟΥ?'
    ΔΙΑΒΑΣΕ ΑΠ
    ΑΝ ΑΠ = 'ΕΞΟΔΟΣ' Η ΑΠ = '5' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΕΞΟΔΟ'
    ΤΕΛΟΣ_ΑΝ
    ΕΓΚ <-- ΑΛΗΘΗΣ
    ΑΝ ΑΠ<>'1' ΚΑΙ ΑΠ<>'2' ΚΑΙ ΑΠ<>'3' ΚΑΙ ΑΠ<>'4' ΚΑΙ ΑΠ<>'5' ΤΟΤΕ
      ΕΓΚ <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΟΣΟ ΑΠ <>'ΑΦΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΔΙΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΚΑΙ ΑΠ<>'ΠΡΟΣΘΕΣΗ' ΚΑΙ ΑΠ<>'ΕΞΟΔΟΣ' ΚΑΙ ΕΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΑΝΗΚΕ ΣΤΙΣ ΕΠΙΛΟΓΕΣ'
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ ΤΗΝ ΑΠΑΝΤΗΣΗ ΣΟΥ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ = 'ΠΡΟΣΘΕΣΗ' Η ΑΠ = '4'  ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΡΟΣΘΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' Η ΑΠ = '3' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΟΛΑΠΛΑΣΙΑΣΜΟ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΑΦΑΙΡΕΣΗ' Η ΑΠ = '1' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΑΦΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΑΦΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ ='ΔΙΑΙΡΕΣΗ' Η ΑΠ = '2' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΔΙΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΔΙΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ΜΕ ΚΑΤΙ ΑΛΛΟ?'
    ΔΙΑΒΑΣΕ ΑΠ1
    ΟΣΟ ΑΠ1 <> 'ΟΧΙ' ΚΑΙ ΑΠ1 <> 'ΝΑΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΝΑΙ Ή ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ1 = 'ΟΧΙ' Η ΑΠ = '5' Η ΑΠ = 'ΕΞΟΔΟΣ'
  ΑΝ Ο <> 0 ΤΟΤΕ
    ΠΟΣ <-- (Σ_ΟΛ / Ο)*100
    ΓΡΑΨΕ ' ΑΠΑΝΤΗΣΕΣ ΣΕ',Ο,'ΕΡΩΤΗΣΕΙΣ ΚΑΙ ΕΙΧΕΣ ΣΩΣΤΕΣ ΤΙΣ',Σ_ΟΛ
    ΓΡΑΨΕ ' ΠΑΙΡΝΕΙΣ',ΠΟΣ,'ΣΤΑ 100'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άλεξ



ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    Γ <-- Χ + Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΣΥΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'+',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      Γράψε' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'+',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(10)  !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΜΗΔΕΝ ΕΙΝΑΙ ΠΟΛΥ ΑΠΛΟΣ!
    Υ <-- ΤΥΧΑΙΟΣ(100)
    Γ <-- Χ * Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΕΠΙ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'*',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'*',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΟΣΟ Χ - Υ < 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ - Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΜΕΙΟΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'-',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'-',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Ι , Κ , Σ , Α
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΟΣΟ Χ MOD Υ <> 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΕΝΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ / Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΔΙΑ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'/',Υ,'='
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'/',Υ,'='
      ΔΙΑΒΑΣΕ Α
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Περιμένω όμως και άλλες προτάσεις για βελτιώσεις.. :lol:

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Μαρ 2009 11:45 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
dark lord έγραψε:
4) αν για απαντηση βαλω γραμμα θα κολλησει , αλλα δεν ξερω αν διορθωνεται αυτο στην γλωσσομαθεια :roll:


Το παρακάτω το 1o είναι για την εισαγωγή πραγματικών, μετά ακολουθεί για ακεραίους και τελευταίο το πρόγραμμα με τις αλλαγές για να μην κολλάει όταν πατάς χαρακτήρες.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΙΣΑΓΩΓΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Δ
ΑΡΧΗ
  Δ <-- ΕΙΣ(1)
  ΓΡΑΨΕ Δ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΣΥΝΑΡΤΗΣΗ ΕΙΣ(ΠΡΟΣ) :ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΙ
  ΑΚΕΡΑΙΕΣ: Α, ΑΡΨΗΦ, ΠΡΟΣ, Χ, Υ
  ΛΟΓΙΚΕΣ: ΣΦΑ
ΑΡΧΗ
  ΣΦΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΦΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΑΡΙΘΜΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΣΦΑ <-- ΨΕΥΔΗΣ
    Χ <-- 0
    Υ <-- 0
    ΑΡΨΗΦ <-- -1
    ΔΙΑΒΑΣΕ ΕΙ
    ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΑΝ ΑΡΨΗΦ >=0 ΤΟΤΕ
        ΑΡΨΗΦ <-- ΑΡΨΗΦ + 1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Α= 1 ΤΟΤΕ
        ΑΝ ΕΙ[Α]='+' ΤΟΤΕ
          ΠΡΟΣ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='-' ΤΟΤΕ
          ΠΡΟΣ <-- -1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- 2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- 3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- 4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- 5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- 6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- 7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- 8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- 9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- 0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- (Χ*10)+1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- (Χ*10)+2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- (Χ*10)+3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- (Χ*10)+4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- (Χ*10)+5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- (Χ*10)+6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- (Χ*10)+7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- (Χ*10)+8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- (Χ*10)+9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- (Χ*10)+0
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='.' ΤΟΤΕ
          ΑΝ Υ <> 0 ΤΟΤΕ
            ΣΦΑ <-- ΑΛΗΘΕΣ
            Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
          ΑΛΛΙΩΣ
            Υ <-- Χ
            Χ <-- 0
            ΑΡΨΗΦ <-- 0
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΦΑ = ΨΕΥΔΗΣ
  ΑΝ ΑΡΨΗΦ >= 0 ΤΟΤΕ
    ΕΙΣ <-- (Υ + ( Χ / (10^ΑΡΨΗΦ) ))*ΠΡΟΣ
  ΑΛΛΙΩΣ
    ΕΙΣ <-- Χ*ΠΡΟΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΕΙΣΑΓΩΓΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Δ
ΑΡΧΗ
  Δ <-- ΕΙΣ(1)
  ΓΡΑΨΕ Δ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΣΥΝΑΡΤΗΣΗ ΕΙΣ(ΠΡΟΣ) :ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΙ
  ΑΚΕΡΑΙΕΣ: Α, ΠΡΟΣ, Χ
  ΛΟΓΙΚΕΣ: ΣΦΑ
ΑΡΧΗ
  ΣΦΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΦΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ ΑΡΙΘΜΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΣΦΑ <-- ΨΕΥΔΗΣ
    Χ <-- 0
    ΔΙΑΒΑΣΕ ΕΙ
    ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΑΝ Α= 1 ΤΟΤΕ
        ΑΝ ΕΙ[Α]='+' ΤΟΤΕ
          ΠΡΟΣ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='-' ΤΟΤΕ
          ΠΡΟΣ <-- -1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- 2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- 3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- 4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- 5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- 6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- 7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- 8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- 9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- 0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- (Χ*10)+1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- (Χ*10)+2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- (Χ*10)+3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- (Χ*10)+4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- (Χ*10)+5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- (Χ*10)+6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- (Χ*10)+7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- (Χ*10)+8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- (Χ*10)+9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- (Χ*10)+0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΦΑ = ΨΕΥΔΗΣ
  ΕΙΣ <-- Χ*ΠΡΟΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ  


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΆΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ_ΟΛ , Ο , Σ , Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ , Π , ΑΠ1
  ΛΟΓΙΚΕΣ: ΕΓΚ
ΑΡΧΗ
  ΓΡΑΨΕ ' ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΕΞΑΣΚΗΣΗΣ ΤΟΥ ΜΥΑΛΟΥ , ΠΡΟΣΦΕΡΕΙ ΣΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΔΥΝΑΤΟΤΗΤΑ ΝΑ'
  ΓΡΑΨΕ ' ΕΞΕΤΑΣΕΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ ΣΤΙΣ ΔΙΑΦΟΡΕΣ ΠΡΑΞΕΙΣ .'
  ΓΡΑΨΕ ' ΑΦΙΕΡΩΜΕΝΟ ΣΤΟΝ ΑΔΕΡΦΟ ΜΟΥ!'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  Σ_ΟΛ <-- 0
  Ο <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ' ΜΕ ΤΙ ΘΑ ΗΘΕΛΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ???'
    ΓΡΑΨΕ ' 1.ΑΦΑΙΡΕΣΗ(-)'
    ΓΡΑΨΕ ' 2.ΔΙΑΙΡΕΣΗ(:)'
    ΓΡΑΨΕ ' 3.ΠΟΛΑΠΛΑΣΙΑΣΜΟ(*)'
    ΓΡΑΨΕ ' 4.ΠΡΟΣΘΕΣΗ(+)'
    ΓΡΑΨΕ ' 5.ΕΞΟΔΟΣ(ΕΧΙΤ)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ ' ΠΟΙΑ ΕΙΝΑΙ Η ΑΠΑΝΤΗΣΗ ΣΟΥ?'
    ΔΙΑΒΑΣΕ ΑΠ
    ΑΝ ΑΠ = 'ΕΞΟΔΟΣ' Η ΑΠ = '5' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΕΞΟΔΟ'
    ΤΕΛΟΣ_ΑΝ
    ΕΓΚ <-- ΑΛΗΘΗΣ
    ΑΝ ΑΠ<>'1' ΚΑΙ ΑΠ<>'2' ΚΑΙ ΑΠ<>'3' ΚΑΙ ΑΠ<>'4' ΚΑΙ ΑΠ<>'5' ΤΟΤΕ
      ΕΓΚ <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΟΣΟ ΑΠ <>'ΑΦΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΔΙΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΚΑΙ ΑΠ<>'ΠΡΟΣΘΕΣΗ' ΚΑΙ ΑΠ<>'ΕΞΟΔΟΣ' ΚΑΙ ΕΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΑΝΗΚΕ ΣΤΙΣ ΕΠΙΛΟΓΕΣ'
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ ΤΗΝ ΑΠΑΝΤΗΣΗ ΣΟΥ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ = 'ΠΡΟΣΘΕΣΗ' Η ΑΠ = '4'  ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΡΟΣΘΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' Η ΑΠ = '3' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΟΛΑΠΛΑΣΙΑΣΜΟ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΑΦΑΙΡΕΣΗ' Η ΑΠ = '1' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΑΦΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΑΦΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ ='ΔΙΑΙΡΕΣΗ' Η ΑΠ = '2' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΔΙΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΔΙΑΙΡΕΣΗ(Σ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ΜΕ ΚΑΤΙ ΑΛΛΟ?'
    ΔΙΑΒΑΣΕ ΑΠ1
    ΟΣΟ ΑΠ1 <> 'ΟΧΙ' ΚΑΙ ΑΠ1 <> 'ΝΑΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΝΑΙ Ή ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ1 = 'ΟΧΙ' Η ΑΠ = '5' Η ΑΠ = 'ΕΞΟΔΟΣ'
  ΑΝ Ο <> 0 ΤΟΤΕ
    ΠΟΣ <-- (Σ_ΟΛ / Ο)*100
    ΓΡΑΨΕ ' ΑΠΑΝΤΗΣΕΣ ΣΕ',Ο,'ΕΡΩΤΗΣΕΙΣ ΚΑΙ ΕΙΧΕΣ ΣΩΣΤΕΣ ΤΙΣ',Σ_ΟΛ
    ΓΡΑΨΕ ' ΠΑΙΡΝΕΙΣ',ΠΟΣ,'ΣΤΑ 100'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άλεξ



ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    Γ <-- Χ + Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΣΥΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'+',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      Γράψε' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'+',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(10)  !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΜΗΔΕΝ ΕΙΝΑΙ ΠΟΛΥ ΑΠΛΟΣ!
    Υ <-- ΤΥΧΑΙΟΣ(100)
    Γ <-- Χ * Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΕΠΙ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'*',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'*',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΟΣΟ Χ - Υ < 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ - Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΜΕΙΟΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'-',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'-',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΕΣΗ(Σ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Ι , Κ , Σ , Α
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΟΣΟ Χ MOD Υ <> 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΕΝΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ / Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΔΙΑ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'/',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'/',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΣΥΝΑΡΤΗΣΗ ΕΙΣ(ΠΡΟΣ) :ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΙ
  ΑΚΕΡΑΙΕΣ: Α, ΠΡΟΣ, Χ
  ΛΟΓΙΚΕΣ: ΣΦΑ
ΑΡΧΗ
  ΣΦΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΦΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ ΑΡΙΘΜΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΣΦΑ <-- ΨΕΥΔΗΣ
    Χ <-- 0
    ΔΙΑΒΑΣΕ ΕΙ
    ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΑΝ Α= 1 ΤΟΤΕ
        ΑΝ ΕΙ[Α]='+' ΤΟΤΕ
          ΠΡΟΣ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='-' ΤΟΤΕ
          ΠΡΟΣ <-- -1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- 2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- 3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- 4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- 5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- 6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- 7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- 8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- 9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- 0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- (Χ*10)+1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- (Χ*10)+2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- (Χ*10)+3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- (Χ*10)+4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- (Χ*10)+5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- (Χ*10)+6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- (Χ*10)+7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- (Χ*10)+8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- (Χ*10)+9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- (Χ*10)+0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΦΑ = ΨΕΥΔΗΣ
  ΕΙΣ <-- Χ*ΠΡΟΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 08 Μαρ 2009 01:35 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Πολύ ωραια λύση η συνάρτηση EIΣ για να ελέγχει αν ειναι αριθμοί ή οχι... :mrgreen:

Μια προσθήκη που θα μπορούσε να μπει ειναι να αποθηκέυει στατιστικά σε ένα αρχείο.

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 08 Μαρ 2009 09:23 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Συμπλήρωνα το πρόγραμμα για το θέμα με την καταγραφή στατιστικών που πρότεινε ο dark lord και παρακάτω είναι το σημείο στο οποίο σταμάτησα γιατί όταν πάω να κάνω έλεγχο για σφάλματα μου βγάζει όταν τελειώνει : γραμμή 355 – σφάλμα στην πρόταση. Ξέρει κανείς τι εννοεί ? γιατί δεν βρίσκω κάποιο σφάλμα στην γραμμή αυτή ( είναι η γραμμή : ΓΡΑΨΕ ' (θα διαγραφούνε τα δεδομένα των προηγούμενων προσπαθειών όλων των χρηστών).').
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΆΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ_ΟΛ , Ο , Σ , Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ , Π , ΑΠ1, ΠΡΟΦ!
  ΛΟΓΙΚΕΣ: ΕΓΚ
ΑΡΧΗ
  ΓΡΑΨΕ ' ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΕΞΑΣΚΗΣΗΣ ΤΟΥ ΜΥΑΛΟΥ , ΠΡΟΣΦΕΡΕΙ ΣΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΔΥΝΑΤΟΤΗΤΑ ΝΑ'
  ΓΡΑΨΕ ' ΕΞΕΤΑΣΕΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ ΣΤΙΣ ΔΙΑΦΟΡΕΣ ΠΡΑΞΕΙΣ .'
  ΓΡΑΨΕ ' ΑΦΙΕΡΩΜΕΝΟ ΣΤΟΝ ΑΔΕΡΦΟ ΜΟΥ!'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  Σ_ΟΛ <-- 0
  Ο <-- 0
  ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΓΡΑΨΤΕ ΤΟ ΟΝΟΜΑ ΣΑΣ'    !
  ΔΙΑΒΑΣΕ ΠΡΟΦ                            !
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ' ΜΕ ΤΙ ΘΑ ΗΘΕΛΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ???'
    ΓΡΑΨΕ ' 1.ΑΦΑΙΡΕΣΗ(-)'
    ΓΡΑΨΕ ' 2.ΔΙΑΙΡΕΣΗ(:)'
    ΓΡΑΨΕ ' 3.ΠΟΛΑΠΛΑΣΙΑΣΜΟ(*)'
    ΓΡΑΨΕ ' 4.ΠΡΟΣΘΕΣΗ(+)'
    ΓΡΑΨΕ ' 5.ΕΞΟΔΟΣ(ΕΧΙΤ)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ ' ΠΟΙΑ ΕΙΝΑΙ Η ΑΠΑΝΤΗΣΗ ΣΟΥ?'
    ΔΙΑΒΑΣΕ ΑΠ
    ΑΝ ΑΠ = 'ΕΞΟΔΟΣ' Η ΑΠ = '5' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΕΞΟΔΟ'
    ΤΕΛΟΣ_ΑΝ
    ΕΓΚ <-- ΑΛΗΘΗΣ
    ΑΝ ΑΠ<>'1' ΚΑΙ ΑΠ<>'2' ΚΑΙ ΑΠ<>'3' ΚΑΙ ΑΠ<>'4' ΚΑΙ ΑΠ<>'5' ΤΟΤΕ
      ΕΓΚ <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΟΣΟ ΑΠ <>'ΑΦΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΔΙΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΚΑΙ ΑΠ<>'ΠΡΟΣΘΕΣΗ' ΚΑΙ ΑΠ<>'ΕΞΟΔΟΣ' ΚΑΙ ΕΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΑΝΗΚΕ ΣΤΙΣ ΕΠΙΛΟΓΕΣ'
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ ΤΗΝ ΑΠΑΝΤΗΣΗ ΣΟΥ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ = 'ΠΡΟΣΘΕΣΗ' Η ΑΠ = '4'  ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΡΟΣΘΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' Η ΑΠ = '3' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΟΛΑΠΛΑΣΙΑΣΜΟ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΑΦΑΙΡΕΣΗ' Η ΑΠ = '1' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΑΦΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΑΦΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ ='ΔΙΑΙΡΕΣΗ' Η ΑΠ = '2' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΔΙΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΔΙΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ΜΕ ΚΑΤΙ ΑΛΛΟ?'
    ΔΙΑΒΑΣΕ ΑΠ1
    ΟΣΟ ΑΠ1 <> 'ΟΧΙ' ΚΑΙ ΑΠ1 <> 'ΝΑΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΝΑΙ Ή ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ1 = 'ΟΧΙ' Η ΑΠ = '5' Η ΑΠ = 'ΕΞΟΔΟΣ'
  ΑΝ Ο <> 0 ΤΟΤΕ
    ΠΟΣ <-- (Σ_ΟΛ / Ο)*100
    ΓΡΑΨΕ ' ΑΠΑΝΤΗΣΕΣ ΣΕ',Ο,'ΕΡΩΤΗΣΕΙΣ ΚΑΙ ΕΙΧΕΣ ΣΩΣΤΕΣ ΤΙΣ',Σ_ΟΛ
    ΓΡΑΨΕ ' ΠΑΙΡΝΕΙΣ',ΠΟΣ,'ΣΤΑ 100'
    ΓΡΑΨΕ ΚΑΤ_ΣΤΑΤ(0, ΠΡΟΦ, 0)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άλεξ


ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    Γ <-- Χ + Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΣΥΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'+',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      Γράψε' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'+',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  ΓΡΑΨΕ ΚΑΤ_ΣΤΑΤ(1, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(10)  !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΜΗΔΕΝ ΕΙΝΑΙ ΠΟΛΥ ΑΠΛΟΣ!
    Υ <-- ΤΥΧΑΙΟΣ(100)
    Γ <-- Χ * Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΕΠΙ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'*',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'*',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  ΓΡΑΨΕ ΚΑΤ_ΣΤΑΤ(2, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΟΣΟ Χ - Υ < 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ - Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΜΕΙΟΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'-',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'-',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  ΓΡΑΨΕ ΚΑΤ_ΣΤΑΤ(3, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΟΣΟ Χ MOD Υ <> 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΕΝΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ / Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΔΙΑ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'/',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'/',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  ΓΡΑΨΕ ΚΑΤ_ΣΤΑΤ(4, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΣΥΝΑΡΤΗΣΗ ΕΙΣ(ΠΡΟΣ) :ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΙ
  ΑΚΕΡΑΙΕΣ: Α, ΠΡΟΣ, Χ
  ΛΟΓΙΚΕΣ: ΣΦΑ
ΑΡΧΗ
  ΠΡΟΣ <-- 1
  ΣΦΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΦΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ ΑΡΙΘΜΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΣΦΑ <-- ΨΕΥΔΗΣ
    Χ <-- 0
    ΔΙΑΒΑΣΕ ΕΙ
    ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΑΝ Α= 1 ΤΟΤΕ
        ΑΝ ΕΙ[Α]='+' ΤΟΤΕ
          ΠΡΟΣ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='-' ΤΟΤΕ
          ΠΡΟΣ <-- -1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- 1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- 2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- 3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- 4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- 5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- 6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- 7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- 8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- 9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- 0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
          Χ <-- (Χ*10)+1
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
          Χ <-- (Χ*10)+2
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
          Χ <-- (Χ*10)+3
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
          Χ <-- (Χ*10)+4
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
          Χ <-- (Χ*10)+5
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
          Χ <-- (Χ*10)+6
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
          Χ <-- (Χ*10)+7
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
          Χ <-- (Χ*10)+8
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
          Χ <-- (Χ*10)+9
        ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
          Χ <-- (Χ*10)+0
        ΑΛΛΙΩΣ
          ΣΦΑ <-- ΑΛΗΘΕΣ
          Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΦΑ = ΨΕΥΔΗΣ
  ΕΙΣ <-- Χ*ΠΡΟΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΚΑΤ_ΣΤΑΤ(ΚΑΤ, ΠΡΟΦ, ΒΑΘΜ) :ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΑΤ, ΒΑΘΜ, ΕΠΙΛ, ΣΒ, ΧΣ, ΥΣ
  ΑΚΕΡΑΙΕΣ: Ι
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ, ΚΣ
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: ΚΑΤΗΓ, ΒΑΘΜΟΣ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: ΠΡΟΦΙΛ
ΑΡΧΗ
  ΣΒ <-- 0
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, 'KAT_STAT_PROF.txt'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, 'KAT_STAT_KATHG.txt'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, 'KAT_STAT_BA8MOS.txt'
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_PROF.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_KATHG.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_BA8MOS.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)<>ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ) Ή ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ)<>ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΣ) ΤΟΤΕ
    ΓΡΑΨΕ 'Τα αρχεία για την καταγραφή στατιστικών δεδομένων δεν έχουν ίσες γραμμές όπως θα έπρεπε.'
    ΓΡΑΨΕ 'Τα στατιστικά αυτής της προσπάθειας δεν θα αποθηκευτούν αν δεν αδειάσουν τα αρχεία.'
    ΓΡΑΨΕ 'Παρακαλώ επιλέξτε ένα από τα παρακάτω γράφοντας τον αριθμό πριν από την επιλογή.'
    ΓΡΑΨΕ '1.Να αδειάσουν τα αρχεία και να γίνει αποθήκευση των δεδομένων αυτής της προσπάθειας,'
    ΓΡΑΨΕ '         (θα διαγραφούνε τα δεδομένα των προηγούμενων προσπαθειών όλων των χρηστών).'
    ΓΡΑΨΕ '2.Να μην γίνει αποθήκευση των δεδομένων, και να συνεχιστεί το πρόγραμμα.'
    ΓΡΑΨΕ '3.Να μην γίνει αποθήκευση των δεδομένων, και να τερματιστεί το πρόγραμμα.'
    ΕΠΙΛ <-- ΕΙΣ(1)
    ΑΝ ΕΠΙΛ <> 1 ΚΑΙ ΕΠΙΛ <> 2 ΚΑΙ ΕΠΙΛ <> 3 ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Πρέπει να επιλέξετε ένα από τα παραπάνω.'
        ΕΠΙΛ <-- ΕΙΣ(1)
      ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛ=1 Ή ΕΠΙΛ=2 Ή ΕΠΙΛ=3
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΕΠΙΛ=1 ΤΟΤΕ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
    ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛ=2 ΤΟΤΕ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΕΞΟΔΟΣ
    ΑΛΛΙΩΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ <> 0 ΤΟΤΕ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΠΡΟΦ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΚΑΤ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΣ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΒΑΘΜ
    ΓΙΑ ΙΣ ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΙΣ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΚΣ
      ΑΝ ΚΣ = ΠΡΟΦ ΤΟΤΕ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΙΣ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΧΣ
        ΑΝ ΧΣ=ΚΑΤ ΤΟΤΕ
          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΙΣ
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΧΣ
          ΣΒ <-- ΣΒ+ΧΣ
          ΥΣ <-- ΥΣ + 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Ο μέσος όρος σωστών που έχετε σε αυτή την κατηγορία είναι:', ΣΒ/ΥΣ
    ΚΑΤ_ΣΤΑΤ <-- '/10'
  ΑΛΛΙΩΣ
    ΓΙΑ ΙΣ ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΙΣ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΚΣ
      ΑΝ ΚΣ = ΠΡΟΦ ΤΟΤΕ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΙΣ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΧΣ
        ΣΒ <-- ΣΒ+ΧΣ
        ΥΣ <-- ΥΣ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Ο μέσος όρος σωστών που έχετε σε όλες τις κατηγορίες είναι:', (ΣΒ/ΥΣ)*10
    ΚΑΤ_ΣΤΑΤ <-- '/100'
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΕΞΑΣΚΗΣΗ ΜΥΑΛΟΥ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 11 Μαρ 2009 05:30 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
Τελικά μετά από μερικές δοκιμές βρήκα ότι ήταν 2 τα συντακτικά λάθη αλλά κανένα στην γραμμή που έλεγε η γλωσσομάθεια. 1ον στις γραμμές :
ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΙΣ
ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜ, ΧΣ
έπρεπε να είναι ΒΑΘΜΟΣ αντί για ΒΑΘΜ.
2ον τα ΙΣ και τα Ι τα έκανα ΙΣΚ.
Όταν διόρθωσα το 1ο και έκανα το 2ο το σφάλμα εξαφανίστηκε.
Παρακάτω είναι το πρόγραμμα με τις 2 παραπάνω αλλαγές συν μερικές ακόμα για την αποθήκευση στατιστικών. Επίσης μίκρυνα λίγο την συνάρτηση ΕΙΣ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΆΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ_ΟΛ , Ο , Σ , Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ , Π , ΑΠ1, ΠΡΟΦ!
  ΛΟΓΙΚΕΣ: ΕΓΚ
ΑΡΧΗ
  ΓΡΑΨΕ ' ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΕΞΑΣΚΗΣΗΣ ΤΟΥ ΜΥΑΛΟΥ , ΠΡΟΣΦΕΡΕΙ ΣΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΔΥΝΑΤΟΤΗΤΑ ΝΑ'
  ΓΡΑΨΕ ' ΕΞΕΤΑΣΕΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ ΣΤΙΣ ΔΙΑΦΟΡΕΣ ΠΡΑΞΕΙΣ .'
  ΓΡΑΨΕ ' ΑΦΙΕΡΩΜΕΝΟ ΣΤΟΝ ΑΔΕΡΦΟ ΜΟΥ!'
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ
  Σ_ΟΛ <-- 0
  Ο <-- 0
  ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΓΡΑΨΤΕ ΤΟ ΟΝΟΜΑ ΣΑΣ'
  ΔΙΑΒΑΣΕ ΠΡΟΦ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ' ΜΕ ΤΙ ΘΑ ΗΘΕΛΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ???'
    ΓΡΑΨΕ ' 1.ΑΦΑΙΡΕΣΗ(-)'
    ΓΡΑΨΕ ' 2.ΔΙΑΙΡΕΣΗ(:)'
    ΓΡΑΨΕ ' 3.ΠΟΛΑΠΛΑΣΙΑΣΜΟ(*)'
    ΓΡΑΨΕ ' 4.ΠΡΟΣΘΕΣΗ(+)'
    ΓΡΑΨΕ ' 5.ΕΞΟΔΟΣ(ΕΧΙΤ)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ ' ΠΟΙΑ ΕΙΝΑΙ Η ΑΠΑΝΤΗΣΗ ΣΟΥ?'
    ΔΙΑΒΑΣΕ ΑΠ
    ΑΝ ΑΠ = 'ΕΞΟΔΟΣ' Η ΑΠ = '5' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΕΞΟΔΟ'
    ΤΕΛΟΣ_ΑΝ
    ΕΓΚ <-- ΑΛΗΘΗΣ
    ΑΝ ΑΠ<>'1' ΚΑΙ ΑΠ<>'2' ΚΑΙ ΑΠ<>'3' ΚΑΙ ΑΠ<>'4' ΚΑΙ ΑΠ<>'5' ΤΟΤΕ
      ΕΓΚ <-- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΟΣΟ ΑΠ <>'ΑΦΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΔΙΑΙΡΕΣΗ' ΚΑΙ ΑΠ<>'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' ΚΑΙ ΑΠ<>'ΠΡΟΣΘΕΣΗ' ΚΑΙ ΑΠ<>'ΕΞΟΔΟΣ' ΚΑΙ ΕΓΚ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΑΝΗΚΕ ΣΤΙΣ ΕΠΙΛΟΓΕΣ'
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΞΑΝΑΔΩΣΕ ΤΗΝ ΑΠΑΝΤΗΣΗ ΣΟΥ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ = 'ΠΡΟΣΘΕΣΗ' Η ΑΠ = '4'  ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΡΟΣΘΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΡΟΣΘΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΠΟΛΑΠΛΑΣΙΑΣΜΟ' Η ΑΠ = '3' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΠΟΛΑΠΛΑΣΙΑΣΜΟ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ = 'ΑΦΑΙΡΕΣΗ' Η ΑΠ = '1' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΑΦΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΑΦΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΑΛΛΙΩΣ_ΑΝ ΑΠ ='ΔΙΑΙΡΕΣΗ' Η ΑΠ = '2' ΤΟΤΕ
      ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΔΙΑΙΡΕΣΗ , ΠΕΡΙΜΕΝΕ ΛΙΓΑΚΙ'
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 70000000
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΚΑΛΕΣΕ ΔΙΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
      Σ_ΟΛ <-- Σ_ΟΛ + Σ
      Ο <-- Ο +10
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΘΕΣ ΝΑ ΑΣΧΟΛΗΘΕΙΣ ΜΕ ΚΑΤΙ ΑΛΛΟ?'
    ΔΙΑΒΑΣΕ ΑΠ1
    ΟΣΟ ΑΠ1 <> 'ΟΧΙ' ΚΑΙ ΑΠ1 <> 'ΝΑΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ ' ΔΕΝ ΕΓΡΑΨΕΣ ΣΕ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ Ή Η ΑΠΑΝΤΗΣΗ ΣΟΥ ΔΕΝ ΗΤΑΝ ΝΑΙ Ή ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ1 = 'ΟΧΙ' Η ΑΠ = '5' Η ΑΠ = 'ΕΞΟΔΟΣ'
  ΑΝ Ο <> 0 ΤΟΤΕ
    ΠΟΣ <-- (Σ_ΟΛ / Ο)*100
    ΓΡΑΨΕ ' ΑΠΑΝΤΗΣΕΣ ΣΕ',Ο,'ΕΡΩΤΗΣΕΙΣ ΚΑΙ ΕΙΧΕΣ ΣΩΣΤΕΣ ΤΙΣ',Σ_ΟΛ
    ΓΡΑΨΕ ' ΠΑΙΡΝΕΙΣ',ΠΟΣ,'ΣΤΑ 100'
    Ι <-- 0
    ΚΑΛΕΣΕ ΚΑΤ_ΣΤΑΤ(Ι, ΠΡΟΦ, Ι)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ' ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΧΡΗΣΙΜΟΠΟΙΗΣΕΣ ΤΟ ΠΡΟΓΡΑΜΜΑ.'
  ΓΡΑΨΕ '                                  MADE BY YURIS'
  ΓΡΑΨΕ '                                         3η ΛΥΚΕΙΟΥ - 2ο ΛΥΚΕΙΟ ΣΠΑΡΤΗΣ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Άλεξ


ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΣΘΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    Γ <-- Χ + Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΣΥΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'+',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      Γράψε' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'+',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  Ι <-- 1
  ΚΑΛΕΣΕ ΚΑΤ_ΣΤΑΤ(Ι, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΟΛΑΠΛΑΣΙΑΣΜΟΣ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(10)  !ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ ΜΕ ΜΗΔΕΝ ΕΙΝΑΙ ΠΟΛΥ ΑΠΛΟΣ!
    Υ <-- ΤΥΧΑΙΟΣ(100)
    Γ <-- Χ * Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΕΠΙ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'*',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'*',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  Ι <-- 2
  ΚΑΛΕΣΕ ΚΑΤ_ΣΤΑΤ(Ι, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΑΦΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Γ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΟΣΟ Χ - Υ < 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(1000)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ - Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΜΕΙΟΝ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'-',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'-',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  Ι <-- 3
  ΚΑΛΕΣΕ ΚΑΤ_ΣΤΑΤ(Ι, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΙΡΕΣΗ(Σ, ΠΡΟΦ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ , Υ , Ι , Κ , Σ , Α
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ
  ΠΡΑΓΜΑΤΙΚΕΣ: Γ
ΑΡΧΗ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    Χ <-- ΤΥΧΑΙΟΣ(1000)
    Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΟΣΟ Χ MOD Υ <> 0 ΕΠΑΝΑΛΑΒΕ
      Χ <-- ΤΥΧΑΙΟΣ(1000)
      Υ <-- ΤΥΧΑΙΟΣ(500)+1!ΔΕΝ ΕΝΝΟΕΙΤΑΙ ΔΙΑΙΡΕΣΗ ΜΕ ΤΟ ΜΗΔΕΝ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Γ <-- Χ / Υ
    ΓΡΑΨΕ ' ΠΟΣΟ ΚΑΝΕΙ',Χ,'ΔΙΑ',Υ,'?'
    ΓΡΑΨΕ_ Χ,'/',Υ,'='
    Α <-- ΕΙΣ(1)
    ΑΝ Α=Γ ΤΟΤΕ
      ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
      Σ <-- Σ+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! ΕΧΕΙΣ ΑΛΛΗ ΜΙΑ ΕΥΚΑΙΡΙΑ'
      ΓΡΑΨΕ_ Χ,'/',Υ,'='
      Α <-- ΕΙΣ(1)
      ΑΝ Α=Γ ΤΟΤΕ
        ΓΡΑΨΕ' ΦΙΛΑΡΑΚΟ ΜΠΡΑΒΟ ΣΟΥ'
        Σ <-- Σ+1
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ' ΠΡΟΣΕΧΕ ΦΙΛΑΡΑΚΟ , ΕΚΑΝΕΣ ΛΑΘΟΣ!!! Η ΣΩΣΤΗ ΑΠΑΝΤΗΣΗ ΕΙΝΑΙ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ι <> 10 ΤΟΤΕ
      ΓΡΑΨΕ' ΕΠΟΜΕΝΟ ΤΩΡΑ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ' ΟΙ ΣΩΣΤΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΟΥ ΕΙΝΑΙ',Σ,'ΣΤΙΣ 10'
  Ι <-- 4
  ΚΑΛΕΣΕ ΚΑΤ_ΣΤΑΤ(Ι, ΠΡΟΦ, Σ)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΕΙΣ(ΠΡΟΣ) :ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΙ
  ΑΚΕΡΑΙΕΣ: Α, ΠΡΟΣ, Χ
  ΛΟΓΙΚΕΣ: ΣΦΑ
ΑΡΧΗ
  ΠΡΟΣ <-- 1
  ΣΦΑ <-- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΣΦΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ ΑΡΙΘΜΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΣΦΑ <-- ΨΕΥΔΗΣ
    Χ <-- 0
    ΔΙΑΒΑΣΕ ΕΙ
    ΓΙΑ Α ΑΠΟ 1 ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΑΝ ΕΙ[Α]='1' ΤΟΤΕ
        Χ <-- (Χ*10)+1
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='2' ΤΟΤΕ
        Χ <-- (Χ*10)+2
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='3' ΤΟΤΕ
        Χ <-- (Χ*10)+3
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='4' ΤΟΤΕ
        Χ <-- (Χ*10)+4
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='5' ΤΟΤΕ
        Χ <-- (Χ*10)+5
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='6' ΤΟΤΕ
        Χ <-- (Χ*10)+6
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='7' ΤΟΤΕ
        Χ <-- (Χ*10)+7
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='8' ΤΟΤΕ
        Χ <-- (Χ*10)+8
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='9' ΤΟΤΕ
        Χ <-- (Χ*10)+9
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='0' ΤΟΤΕ
        Χ <-- (Χ*10)+0
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='+' ΚΑΙ Α = 1 ΤΟΤΕ
        ΠΡΟΣ <-- 1
      ΑΛΛΙΩΣ_ΑΝ ΕΙ[Α]='-' ΚΑΙ Α = 1 ΤΟΤΕ
        ΠΡΟΣ <-- -1
      ΑΛΛΙΩΣ
        ΣΦΑ <-- ΑΛΗΘΕΣ
        Α <-- ΜΗΚΟΣ_ΧΑΡ(ΕΙ)
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΦΑ = ΨΕΥΔΗΣ
  ΕΙΣ <-- Χ*ΠΡΟΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΔΙΑΔΙΚΑΣΙΑ ΚΑΤ_ΣΤΑΤ(ΚΑΤ, ΠΡΟΦ, ΒΑΘΜ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΑΤ, ΒΑΘΜ, ΕΠΙΛ, ΣΒ, ΧΣ, ΥΣ
  ΑΚΕΡΑΙΕΣ: ΙΣΚ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΦ, ΚΣ
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: ΚΑΤΗΓ, ΒΑΘΜΟΣ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: ΠΡΟΦΙΛ
ΑΡΧΗ
  ΣΒ <-- 0
  ΥΣ <-- 0
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, 'KAT_STAT_PROF.txt'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, 'KAT_STAT_KATHG.txt'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, 'KAT_STAT_BA8MOS.txt'
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_PROF.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
    ΓΡΑΨΕ '1'
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_KATHG.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
    ΓΡΑΨΕ '2'
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΟΧΙ(ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('KAT_STAT_BA8MOS.txt')) ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
    ΓΡΑΨΕ '3'
  ΑΛΛΙΩΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)<>ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ) Ή ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ)<>ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΣ) ΤΟΤΕ
    ΓΡΑΨΕ 'Τα αρχεία για την καταγραφή στατιστικών δεδομένων δεν έχουν ίσες γραμμές όπως θα έπρεπε.'
    ΓΡΑΨΕ 'Τα στατιστικά αυτής της προσπάθειας δεν θα αποθηκευτούν αν δεν αδειάσουν τα αρχεία.'
    ΓΡΑΨΕ 'Παρακαλώ επιλέξτε ένα από τα παρακάτω γράφοντας τον αριθμό πριν από την επιλογή.'
    ΓΡΑΨΕ '1.Να αδειάσουν τα αρχεία και να γίνει αποθήκευση των δεδομένων αυτής της προσπάθειας,'
    ΓΡΑΨΕ '         (θα διαγραφούνε τα δεδομένα των προηγούμενων προσπαθειών όλων των χρηστών).'
    ΓΡΑΨΕ '2.Να μην γίνει αποθήκευση των δεδομένων, και να συνεχιστεί το πρόγραμμα.'
    ΓΡΑΨΕ '3.Να μην γίνει αποθήκευση των δεδομένων, και να τερματιστεί το πρόγραμμα.'
    ΕΠΙΛ <-- ΕΙΣ(1)
    ΑΝ ΕΠΙΛ <> 1 ΚΑΙ ΕΠΙΛ <> 2 ΚΑΙ ΕΠΙΛ <> 3 ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'Πρέπει να επιλέξετε ένα από τα παραπάνω.'
        ΕΠΙΛ <-- ΕΙΣ(1)
      ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛ=1 Ή ΕΠΙΛ=2 Ή ΕΠΙΛ=3
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΕΠΙΛ=1 ΤΟΤΕ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
    ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛ=2 ΤΟΤΕ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΕΞΟΔΟΣ
    ΑΛΛΙΩΣ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
      ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ <> 0 ΤΟΤΕ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΠΡΟΦ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤΗΓ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΚΑΤ
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΒΑΘΜΟΣ)+1
    ΓΡΑΨΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΒΑΘΜ
    ΓΙΑ ΙΣΚ ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΙΣΚ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΚΣ
      ΑΝ ΚΣ = ΠΡΟΦ ΤΟΤΕ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΙΣΚ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ, ΧΣ
        ΑΝ ΧΣ=ΚΑΤ ΤΟΤΕ
          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΙΣΚ
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΧΣ
          ΣΒ <-- ΣΒ+ΧΣ
          ΥΣ <-- ΥΣ + 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Ο μέσος όρος σωστών που έχετε σε αυτή την κατηγορία είναι:', ΣΒ/ΥΣ, '/10'
  ΑΛΛΙΩΣ
    ΓΙΑ ΙΣΚ ΑΠΟ 1 ΜΕΧΡΙ ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΠΡΟΦΙΛ)
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΙΣΚ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ, ΚΣ
      ΑΝ ΚΣ = ΠΡΟΦ ΤΟΤΕ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΙΣΚ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ, ΧΣ
        ΣΒ <-- ΣΒ+ΧΣ
        ΥΣ <-- ΥΣ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Ο μέσος όρος σωστών που έχετε σε όλες τις κατηγορίες είναι:', (ΣΒ/ΥΣ)*10, '/100'
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΠΡΟΦΙΛ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤΗΓ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΒΑΘΜΟΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές: