Τώρα είναι Πέμ 04 Ιουν 2020 01:09 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Κεφαλαια <--> Μικρα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 22 Αύγ 2008 06:44 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Ενα απλο προγραμμα που μετατρεπει τα κεφαλαια σε μικρα και το αντιστροφο
(ΜΟΝΟ ΕΛΛΗΝΙΚΑ)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΙΚ_ΚΕΦ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ1,Χ,ΕΠ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δωσε μια λεξη/φραση **ΜΟΝΟ ΕΛΛΗΝΙΚΑ** ("ΤΕΛΟΣ" για εξοδο)'
    ΔΙΑΒΑΣΕ Χ1
    ΑΝ Χ1<>'ΤΕΛΟΣ' ΤΟΤΕ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'Μετατροπη της λεξης/φρασης "',Χ1,'" σε:'
      ΓΡΑΨΕ '1.Κεφαλαια'
      ΓΡΑΨΕ '2.Μικρα'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΕΠ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠ='1' Η ΕΠ='2'
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      Χ <-- Μ_Κ(Χ1,ΕΠ)
      ΓΡΑΨΕ 'Πριν την μετατροπη:',Χ1  
      ΓΡΑΨΕ 'Μετα την μετατροπη:'
      ΓΡΑΨΕ '<Enter>  για συνεχεια'
      ΔΙΑΒΑΣΕ Χ1
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ1='ΤΕΛΟΣ'
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



ΣΥΝΑΡΤΗΣΗ Μ_Κ(Χ,ΕΠ):ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,ΕΠ
  ΑΚΕΡΑΙΕΣ:ΜΑΧ,Κ
ΑΡΧΗ
  ΜΑΧ <-- ΜΗΚΟΣ_ΧΑΡ(Χ)
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΜΑΧ
    ΑΝ ΕΠ='1' ΤΟΤΕ
      ΑΝ Χ[Κ]='α' ΤΟΤΕ
        Χ[Κ] <-- 'Α'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='β' ΤΟΤΕ
        Χ[Κ] <-- 'Β'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='γ' ΤΟΤΕ
        Χ[Κ] <-- 'Γ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='δ' ΤΟΤΕ
        Χ[Κ] <-- 'Δ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ε' ΤΟΤΕ
        Χ[Κ] <-- 'Ε'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ζ' ΤΟΤΕ
        Χ[Κ] <-- 'Ζ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='η' ΤΟΤΕ
        Χ[Κ] <-- 'Η'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='θ' ΤΟΤΕ
        Χ[Κ] <-- 'Θ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ι' ΤΟΤΕ
        Χ[Κ] <-- 'Ι'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='κ' ΤΟΤΕ
        Χ[Κ] <-- 'Κ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='λ' ΤΟΤΕ
        Χ[Κ] <-- 'Λ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='μ' ΤΟΤΕ
        Χ[Κ] <-- 'Μ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ν' ΤΟΤΕ
        Χ[Κ] <-- 'Ν'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ξ' ΤΟΤΕ
        Χ[Κ] <-- 'Ξ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ο' ΤΟΤΕ
        Χ[Κ] <-- 'Ο'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='π' ΤΟΤΕ
        Χ[Κ] <-- 'Π'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ρ' ΤΟΤΕ
        Χ[Κ] <-- 'Ρ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='σ' Η Χ[Κ]='ς' ΤΟΤΕ
        Χ[Κ] <-- 'Σ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='τ' ΤΟΤΕ
        Χ[Κ] <-- 'Τ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='υ' ΤΟΤΕ
        Χ[Κ] <-- 'Υ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='φ' ΤΟΤΕ
        Χ[Κ] <-- 'Φ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='χ' ΤΟΤΕ
        Χ[Κ] <-- 'Χ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ψ' ΤΟΤΕ
        Χ[Κ] <-- 'Ψ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ω' ΤΟΤΕ
        Χ[Κ] <-- 'Ω'
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ Χ[Κ]='Α' ΤΟΤΕ
        Χ[Κ] <-- 'α'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Β' ΤΟΤΕ
        Χ[Κ] <-- 'β'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Γ' ΤΟΤΕ
        Χ[Κ] <-- 'γ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Δ' ΤΟΤΕ
        Χ[Κ] <-- 'δ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ε' ΤΟΤΕ
        Χ[Κ] <-- 'ε'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ζ' ΤΟΤΕ
        Χ[Κ] <-- 'ζ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Η' ΤΟΤΕ
        Χ[Κ] <-- 'η'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Θ' ΤΟΤΕ
        Χ[Κ] <-- 'θ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ι' ΤΟΤΕ
        Χ[Κ] <-- 'ι'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Κ' ΤΟΤΕ
        Χ[Κ] <-- 'κ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Λ' ΤΟΤΕ
        Χ[Κ] <-- 'λ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Μ' ΤΟΤΕ
        Χ[Κ] <-- 'μ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ν' ΤΟΤΕ
        Χ[Κ] <-- 'ν'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ξ' ΤΟΤΕ
        Χ[Κ] <-- 'ξ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ο' ΤΟΤΕ
        Χ[Κ] <-- 'ο'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Π' ΤΟΤΕ
        Χ[Κ] <-- 'π'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ρ' ΤΟΤΕ
        Χ[Κ] <-- 'ρ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Σ' ΤΟΤΕ
        ΑΝ Κ=ΜΑΧ Η Χ[Κ+1]=' ' ΤΟΤΕ
          Χ[Κ] <-- 'ς'
        ΑΛΛΙΩΣ
          Χ[Κ] <-- 'σ'
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Τ' ΤΟΤΕ
        Χ[Κ] <-- 'τ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Υ' ΤΟΤΕ
        Χ[Κ] <-- 'υ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Φ' ΤΟΤΕ
        Χ[Κ] <-- 'φ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Χ' ΤΟΤΕ
        Χ[Κ] <-- 'χ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ψ' ΤΟΤΕ
        Χ[Κ] <-- 'ψ'
      ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ω' ΤΟΤΕ
        Χ[Κ] <-- 'ω'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Μ_Κ <--  Χ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters