Τώρα είναι Πέμ 27 Φεβ 2020 08:42 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ψηφια αριθμων ΟΛΕ !!
ΔημοσίευσηΔημοσιεύτηκε: Τρί 29 Ιούλ 2008 04:40 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Δεν μου βγαινει καλυτερο :(

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΨΗΦΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Α[50],Ψ,Ι,Π,ΑΡ,ΜΗΔΕΝΙΚΑ,ΦΟΡΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ
  ΧΑΡΑΚΤΗΡΕΣ:ΑΠ
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΦΟΡΕΣ <-- 0
    ΜΗΔΕΝΙΚΑ <-- 0
    Π <-- 0
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΓΡΑΨΕ 'Δωσε εναν οποιονδηποτε αριθμο'
    ΔΙΑΒΑΣΕ Χ
    ΑΝ Χ<0 ΤΟΤΕ
      Χ <-- -Χ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΑΚ_Μ(Χ)<>Χ ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Χ<=1 ΤΟΤΕ
          ΜΗΔΕΝΙΚΑ <-- ΜΗΔΕΝΙΚΑ +1
          Α[ΜΗΔΕΝΙΚΑ] <-- 0
          Π <-- 0
        ΤΕΛΟΣ_ΑΝ
        ΦΟΡΕΣ <-- ΦΟΡΕΣ+1
        Π <-- Π+1
        Χ <-- Χ*10
      ΜΕΧΡΙΣ_ΟΤΟΥ ΑΚ_Μ(Χ)=Χ
    ΤΕΛΟΣ_ΑΝ                                      
    ΑΡ <-- ΑΚ_Μ(Χ)
    Ψ <-- ΕΥΡΕΣΗ_ΑΡΙΘΜΟΥ_ΨΗΦΙΩΝ(ΑΡ)
    ΚΑΛΕΣΕ ΕΥΡΕΣΗ_ΚΑΘΕ_ΨΗΦΙΟΥ(ΑΡ,Ψ,Α,ΜΗΔΕΝΙΚΑ)
    ΓΡΑΨΕ'================================='
    ΓΡΑΨΕ 'Ο αριθμος που εδωσες εχει'+ΜΗΔΕΝΙΚΑ,'ψηφια'
    ΓΡΑΨΕ'================================='
    ΓΡΑΨΕ 'Ακεραιο Μερος'
    ΑΝ ΜΗΔΕΝΙΚΑ<>0 ΤΟΤΕ
      Π <-- Π-1
    ΤΕΛΟΣ_ΑΝ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ψ-Π
      ΓΡΑΨΕ Ι,'-->:', Α[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ'================================='
    ΑΝ ΦΟΡΕΣ<>0 ΤΟΤΕ
      ΓΡΑΨΕ'================================='
      ΓΡΑΨΕ 'Πραγματικο Μερος'
      ΓΙΑ Ι ΑΠΟ Ψ-Π+1 ΜΕΧΡΙ Ψ+ΜΗΔΕΝΙΚΑ
        ΓΡΑΨΕ Ι,'-->:', Α[Ι]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ'================================='
    ΤΕΛΟΣ_ΑΝ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εκτελεση Ξανα ? (ΝΑΙ/ΟΧΙ)'
      ΔΙΑΒΑΣΕ ΑΠ
    ΜΕΧΡΙΣ_ΟΤΟΥ   ΑΠ='ΟΧΙ' Η ΑΠ='OXI' Η ΑΠ='ΝΑΙ' Η ΑΠ='NAI'
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ='ΟΧΙ' Η ΑΠ='OXI'
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ ΕΥΡΕΣΗ_ΑΡΙΘΜΟΥ_ΨΗΦΙΩΝ(ΑΡ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΑΡ,Κ,Ι,Ψ
ΑΡΧΗ
  Κ <-- 1
  Ι <-- 1
  Ψ <-- 0
  ΟΣΟ Κ<> 0 ΕΠΑΝΑΛΑΒΕ
    Ψ <-- 1+Ψ
    Ι <-- Ι*10
    Κ <-- ΑΚ_Μ(ΑΡ/Ι)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΕΥΡΕΣΗ_ΑΡΙΘΜΟΥ_ΨΗΦΙΩΝ <-- Ψ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΔΙΑΔΙΚΑΣΙΑ ΕΥΡΕΣΗ_ΚΑΘΕ_ΨΗΦΙΟΥ(ΑΡ,Ψ,Α,ΜΗΔΕΝΙΚΑ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΑΡ,Ψ,Α[50],Κ,ΜΗΔΕΝΙΚΑ
ΑΡΧΗ
  Κ <-- ΜΗΔΕΝΙΚΑ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ψ
    Κ <-- Κ+1
    Α[Κ] <-- ΑΚ_Μ(ΑΡ/(10^(Ψ-Ι)))
    ΑΡ <-- ΑΚ_Μ(ΑΡ - Α[Κ]*10^(Ψ-Ι))
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΣΥΝΑΡΤΗΣΗ ΑΚ_Μ(Χ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ
  ΑΚΕΡΑΙΕΣ:Ι
ΑΡΧΗ
  Ι <-- 0
  ΑΝ Χ>=0 ΤΟΤΕ
    ΟΣΟ Χ>=1 ΕΠΑΝΑΛΑΒΕ
      Ι <-- Ι+1
      Χ <-- Χ-1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΛΛΙΩΣ
    ΟΣΟ Χ<=-1 ΕΠΑΝΑΛΑΒΕ
      Ι <-- Ι-1
      Χ <-- Χ+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΚ_Μ <-- Ι
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters