Τώρα είναι Πέμ 09 Ιούλ 2020 01:24 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προγραμμα λεξαριθμων
ΔημοσίευσηΔημοσιεύτηκε: Τρί 29 Ιούλ 2008 04:35 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Οποιαδηποτε παρατηρηση ευπροσδεκτη :roll:
+ Νεα λειτουργεια: Επιλεκτικη προβολη
+ Νεα λειτουργεια: Αποδεκτη εισοδος και τα μικρα γραμματα (Ελληνικα)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΛΕΞΑΡΙΘΜΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ
  ΑΚΕΡΑΙΕΣ:Α,Β,Ι,Κ
  ΛΟΓΙΚΕΣ:ΛΑΘΟΣ,ΑΛΛΑΓΗ,ΥΠ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: ΚΑΤ
ΑΡΧΗ
  ΑΛΛΑΓΗ <-- ΨΕΥΔΗΣ
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ΚΑΤ,'C:\NumW.gm'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\NumW.gm')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΑΤ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤ
  ΤΕΛΟΣ_ΑΝ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΑΤ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤ)
    ΓΡΑΨΕ 'Ως τωρα:',Ι,'καταχωρημενες λεξεις/φρασεις'
    ΓΡΑΨΕ '<Enter> για μενου'
    ΑΝ  Ι=0 ΤΟΤΕ
      ΓΡΑΨΕ '**************************************************************'
      ΓΡΑΨΕ '!!Το μηνυμα θα σταματησει να εμφανιζεται οταν δωθει εγκυρη'
      ΓΡΑΨΕ 'εισοδος!!'
      ΓΡΑΨΕ '**************************************************************'
      ΓΡΑΨΕ 'Το πρόγραμμα δεχεται σαν εισοδο λεξεις η φρασεις.'
      ΓΡΑΨΕ 'Εμφανιζει σε ποιον αριθμο αντιστοιχουν.'
      ΓΡΑΨΕ 'Θα πρεπει να αποτελουνται μονο απο ΕΛΛΗΝΙΚΑ γραμματα.'
      ΓΡΑΨΕ 'Αποδεκτος χαρακτήρας ειναι και το <κενο>'
      ΓΡΑΨΕ 'Σε αντιθετη περίπτωση θα εμφανιζεται καταλληλο μηνυμα.'
      ΓΡΑΨΕ 'Μετα από καθε εξοδο θα γινεται ταξινομηση των λεξεων/φρασεων'
      ΓΡΑΨΕ '**************************************************************'
      ΓΡΑΨΕ '!!Για να γινεται ταξινομηση θα πρεπει η έξοδος να γινεται μεσω'
      ΓΡΑΨΕ 'του προγραμματος και να εχει δωθει καποια καινουρια λεξη/φραση!!'
      ΓΡΑΨΕ '**************************************************************'
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ_ 'Αντιστοιχιση του:'
    ΔΙΑΒΑΣΕ Χ
    Χ <-- Μ_Κ(Χ)
    ΚΑΛΕΣΕ ΛΕΞΑ(Χ,ΛΑΘΟΣ,Α)
    ΑΝ ΛΑΘΟΣ=ΨΕΥΔΗΣ ΤΟΤΕ
      ΥΠ <-- ΥΠΑΡΧΕΙ(Χ)
      ΑΝ ΥΠ=ΨΕΥΔΗΣ ΤΟΤΕ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤ)+1
        ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
        ΑΛΛΑΓΗ <-- ΑΛΗΘΗΣ                      
        ΓΡΑΨΕ 'Νεα λεξη/φραση !'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ ' '
      ΓΡΑΨΕ '=======>--'
      ΓΡΑΨΕ 'Η παραπανω λεξη/φραση αντιστοιχει στον αριθμο:'
      ΓΡΑΨΕ '=======>--'
      ΓΡΑΨΕ_ 'Ομοιες λεξεις/φρασεις:'
      ΚΑΛΕΣΕ ΟΜΟΙΕΣ(Α,Χ)
    ΑΛΛΙΩΣ
      ΑΝ Χ<>'' ΤΟΤΕ
        ΓΡΑΨΕ '!Λανθασμενη εισοδος δεδομενων!'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' '
    ΓΡΑΨΕ '**********************************'
    ΓΡΑΨΕ '<Enter>. Εκτελεση ξανα'
    ΓΡΑΨΕ '2. Προβολη καταχωρημενων λεξεων/φρασεων'
    ΓΡΑΨΕ '3. Εξοδος'
    ΓΡΑΨΕ '4. Αναζητηση αριθμου'
    ΓΡΑΨΕ '5. Αναζητηση λεξης/φρασης'
    ΓΡΑΨΕ '6. Διαγραφη λεξης/φρασης'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ Χ
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ='2' Η X='3' Η X='' Η Χ='4'  Η Χ='5'  Η Χ='6'
    ΑΝ Χ='2' ΤΟΤΕ
      ΚΑΛΕΣΕ ΠΡΟΒΟΛΗ
    ΑΛΛΙΩΣ_ΑΝ Χ='4' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΝ_ΑΡ
    ΑΛΛΙΩΣ_ΑΝ Χ='6' ΤΟΤΕ
      ΚΑΛΕΣΕ ΔΙΑΓ
    ΑΛΛΙΩΣ_ΑΝ Χ='5' ΤΟΤΕ
      ΚΑΛΕΣΕ ΑΝ_ΛΕΞ
    ΤΕΛΟΣ_ΑΝ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ Χ='3'
  ΑΝ ΑΛΛΑΓΗ=ΑΛΗΘΗΣ ΤΟΤΕ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΓΡΑΨΕ 'Γινεται ταξινομηση'
    ΓΡΑΨΕ 'Ισως χαθουν δεδομενα εαν διακοπει'
    ΚΑΛΕΣΕ ΤΑΞΙΝ
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΑΤ
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΟΜΟΙΕΣ(Α,Χ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Α,ΜΑΧ,Φ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,Π
ΑΡΧΗ
  Φ <-- 0
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΑΧ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Π
    ΑΝ  ΣΥΝΤΟΜΗ(Π)=Α ΚΑΙ Χ<>Π ΤΟΤΕ
      Φ <-- Φ+1
      ΑΝ Φ<>1 ΤΟΤΕ
        ΓΡΑΨΕ_ ', '+Π
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ_ Π
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Φ=0 ΤΟΤΕ
    ΓΡΑΨΕ_ 'Δεν υπαρχει καμια ομοια καταχωρημενη ως τωρα'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '=======>--'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



ΣΥΝΑΡΤΗΣΗ ΥΠΑΡΧΕΙ(Χ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΜΑΧ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,Π
  ΛΟΓΙΚΕΣ:Λ
ΑΡΧΗ
  Λ <-- ΨΕΥΔΗΣ
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΑΝ ΜΑΧ>=1 ΤΟΤΕ
    Ι <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Ι <-- Ι+1
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Π
      ΑΝ Π=Χ ΤΟΤΕ
        Λ <-- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ Η Λ=ΑΛΗΘΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΥΠΑΡΧΕΙ <-- Λ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΣΥΝΑΡΤΗΣΗ ΣΥΝΤΟΜΗ(Π):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Α,Β,Κ
  ΧΑΡΑΚΤΗΡΕΣ:Π
ΑΡΧΗ
  Ι <-- ΜΗΚΟΣ_ΧΑΡ(Π)
  Α <-- 0
  Κ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Κ <-- Κ+1
    Β <-- ΑΡΙΘ(Π,Κ)
    Α <-- Α+Β
  ΜΕΧΡΙΣ_ΟΤΟΥ Κ=Ι
  ΣΥΝΤΟΜΗ <-- Α
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΔΙΑΔΙΚΑΣΙΑ ΛΕΞΑ(Χ,ΛΑΘΟΣ,Α)
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΕΣ:ΛΑΘΟΣ
  ΑΚΕΡΑΙΕΣ:Ι,Α,Β,Κ
  ΧΑΡΑΚΤΗΡΕΣ:Χ
ΑΡΧΗ
  ΛΑΘΟΣ <-- ΨΕΥΔΗΣ
  Ι <-- ΜΗΚΟΣ_ΧΑΡ(Χ)
  Α <-- 0
  Κ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Κ <-- Κ+1
    Β <-- ΑΡΙΘ(Χ,Κ)
    Α <-- Α+Β
    ΑΝ Β=-1 ΤΟΤΕ
      ΛΑΘΟΣ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ Κ=Ι Η ΛΑΘΟΣ=ΑΛΗΘΗΣ
  ΑΝ Α=0 ΤΟΤΕ
    ΛΑΘΟΣ <-- ΑΛΗΘΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΣΥΝΑΡΤΗΣΗ ΑΡΙΘ(Χ,Κ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ
  ΑΚΕΡΑΙΕΣ:Π,Κ
ΑΡΧΗ
  ΑΝ Χ[Κ]='Α' ΤΟΤΕ
    Π <-- 1
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Β' ΤΟΤΕ
    Π <-- 2
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Γ' ΤΟΤΕ
    Π <-- 3
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Δ' ΤΟΤΕ
    Π <-- 4
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ε' ΤΟΤΕ
    Π <-- 5
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ζ' ΤΟΤΕ
    Π <-- 7
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Η' ΤΟΤΕ
    Π <-- 8
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Θ' ΤΟΤΕ
    Π <-- 9
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ι' ΤΟΤΕ
    Π <-- 10
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Κ' ΤΟΤΕ
    Π <-- 20
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Λ' ΤΟΤΕ
    Π <-- 30
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Μ' ΤΟΤΕ
    Π <-- 40
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ν' ΤΟΤΕ
    Π <-- 50
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ξ' ΤΟΤΕ
    Π <-- 60
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ο' ΤΟΤΕ
    Π <-- 70
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Π' ΤΟΤΕ
    Π <-- 80
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ρ' ΤΟΤΕ
    Π <-- 100
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Σ' ΤΟΤΕ
    Π <-- 200
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Τ' ΤΟΤΕ
    Π <-- 300
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Υ' ΤΟΤΕ
    Π <-- 400
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Φ' ΤΟΤΕ
    Π <-- 500
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Χ' ΤΟΤΕ
    Π <-- 600
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ψ' ΤΟΤΕ
    Π <-- 700
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='Ω' ΤΟΤΕ
    Π <-- 800
  ΑΛΛΙΩΣ_ΑΝ Χ[Κ]=' ' ΤΟΤΕ
    Π <-- 0
  ΑΛΛΙΩΣ
    Π <-- -1
  ΤΕΛΟΣ_ΑΝ
  ΑΡΙΘ <-- Π
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΒΟΛΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΜΑΧ,Μ,Α,ΣΕΙΡΑ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,ΑΡΧ,ΕΠ
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΑΝ ΜΑΧ>=1 ΤΟΤΕ
    ΓΡΑΨΕ '1.Προβολη ολων'
    ΓΡΑΨΕ '2.Επιλεκτικη προβολη'
    ΓΡΑΨΕ '3.Εξοδος'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ Χ
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ='1' Η Χ='2' Η Χ='3'
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΑΝ Χ='1' ΤΟΤΕ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
      Ι <-- 0
      Μ <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Ι <-- Ι+1
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
        Α <-- ΣΥΝΤΟΜΗ(Χ)
        ΓΡΑΨΕ Ι,'.',Χ,'--->'
        Μ <-- Μ+1
        ΑΝ Μ=21 ΤΟΤΕ
          ΓΡΑΨΕ '=========================='
          ΓΡΑΨΕ '<Enter>. Συνεχεια προβολης'
          ΓΡΑΨΕ '3. Τερματισμος προβολης'
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΔΙΑΒΑΣΕ Χ
          ΜΕΧΡΙΣ_ΟΤΟΥ Χ='' Η Χ='3'
          ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
          Μ <-- 0
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ Η Χ='3'
    ΑΛΛΙΩΣ_ΑΝ Χ='2' ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ_ 'Προβολη λεξεων/φρασεων που αρχιζουν από (γραμμα):'
        ΔΙΑΒΑΣΕ ΑΡΧ
        ΑΡΧ <-- Μ_Κ(ΑΡΧ)
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΜΗΚΟΣ_ΧΑΡ(ΑΡΧ)=1 ΚΑΙ ΑΡΙΘ(ΑΡΧ,1)>=0
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
      Ι <-- 0
      Μ <-- 0
      ΣΕΙΡΑ <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Ι <-- Ι+1
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
        ΑΝ ΑΡΧ=Χ[1] ΤΟΤΕ
          ΣΕΙΡΑ <-- ΣΕΙΡΑ+1
          Α <-- ΣΥΝΤΟΜΗ(Χ)
          ΓΡΑΨΕ ΣΕΙΡΑ,'.',Χ,'--->'
          Μ <-- Μ+1
        ΤΕΛΟΣ_ΑΝ
        ΑΝ Μ=21 ΤΟΤΕ
          ΓΡΑΨΕ '=========================='
          ΓΡΑΨΕ '<Enter>. Συνεχεια προβολης'
          ΓΡΑΨΕ '3. Τερματισμος προβολης'
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΔΙΑΒΑΣΕ ΕΠ
          ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠ='' Η ΕΠ='3' Η Χ[1]>ΑΡΧ
          ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
          Μ <-- 0
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ Η ΕΠ='3' Η Χ[1]>ΑΡΧ
      ΑΝ ΣΕΙΡΑ=0 ΤΟΤΕ
        ΓΡΑΨΕ 'Καμια λεξη/φραση δεν αρχιζει απο:',ΑΡΧ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ '============================================'
    ΓΡΑΨΕ 'Η εμφανιση ολοκληρωθηκε,<Enter> για συνεχεια'
    ΔΙΑΒΑΣΕ Χ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν υπαρχουν καταχωρημενες λεξεις/φρασεις'
    ΓΡΑΨΕ '<Enter> για συνεχεια'
    ΔΙΑΒΑΣΕ Χ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ




ΔΙΑΔΙΚΑΣΙΑ ΑΝ_ΑΡ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Μ,Ι,ΜΑΧ,Α,Φ,ΣΕΙΡΑ,Μ2
  ΧΑΡΑΚΤΗΡΕΣ:Χ,ΛΕΙ
  ΛΟΓΙΚΕΣ:ΥΠ
ΑΡΧΗ
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΑΤ)
  ΑΝ ΜΑΧ>=1 ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ '1. Ευρεση ='
      ΓΡΑΨΕ '2. Ευρεση >='
      ΓΡΑΨΕ '3. Ευρεση <='
      ΓΡΑΨΕ '4. Ευρεση >= και <='
      ΓΡΑΨΕ '5. Εξοδος'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΛΕΙ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΛΕΙ='1' Η ΛΕΙ='2' Η ΛΕΙ='3' Η ΛΕΙ='4' Η ΛΕΙ='5'
      ΑΝ ΛΕΙ<>'5' ΤΟΤΕ
        ΓΡΑΨΕ_ 'Αριθμος:'
        ΔΙΑΒΑΣΕ Μ
        ΑΝ  ΛΕΙ='4' ΤΟΤΕ
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ_ 'Αριθμος 2 (>=',Μ,'):'
            ΔΙΑΒΑΣΕ Μ2
          ΜΕΧΡΙΣ_ΟΤΟΥ Μ2>=Μ
        ΤΕΛΟΣ_ΑΝ
        ΣΕΙΡΑ <-- 0
        ΥΠ <-- ΨΕΥΔΗΣ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
        ΓΡΑΨΕ 'Οι παρακατω λεξεις/φρασεις ικανοποιουν τα κρητηρια'
        Ι <-- 0
        Φ <-- 0
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          Ι <-- Ι+1
          ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
          Α <-- ΣΥΝΤΟΜΗ(Χ)
          ΑΝ ΛΕΙ='1' ΤΟΤΕ
            ΑΝ Α=Μ ΤΟΤΕ
              ΥΠ <-- ΑΛΗΘΗΣ
              ΣΕΙΡΑ <-- ΣΕΙΡΑ+1
              Φ <-- Φ+1
              ΓΡΑΨΕ ΣΕΙΡΑ,'.', Χ
            ΤΕΛΟΣ_ΑΝ
          ΑΛΛΙΩΣ_ΑΝ ΛΕΙ='2' ΤΟΤΕ
            ΑΝ Α>=Μ ΤΟΤΕ
              ΥΠ <-- ΑΛΗΘΗΣ
              Φ <-- Φ+1
              ΣΕΙΡΑ <-- ΣΕΙΡΑ+1
              ΓΡΑΨΕ ΣΕΙΡΑ,'.',Χ,'-->'
            ΤΕΛΟΣ_ΑΝ
          ΑΛΛΙΩΣ_ΑΝ ΛΕΙ='3' ΤΟΤΕ
            ΑΝ Α<=Μ ΤΟΤΕ
              ΥΠ <-- ΑΛΗΘΗΣ
              Φ <-- Φ+1
              ΣΕΙΡΑ <-- ΣΕΙΡΑ+1
              ΓΡΑΨΕ ΣΕΙΡΑ,'.',Χ,'-->'
            ΤΕΛΟΣ_ΑΝ
          ΑΛΛΙΩΣ_ΑΝ ΛΕΙ='4' ΤΟΤΕ
            ΑΝ Α>=Μ ΚΑΙ Α<=Μ2 ΤΟΤΕ
              ΥΠ <-- ΑΛΗΘΗΣ
              Φ <-- Φ+1
              ΣΕΙΡΑ <-- ΣΕΙΡΑ+1
              ΓΡΑΨΕ ΣΕΙΡΑ,'.',Χ,'-->'
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
          ΑΝ Φ=19 ΤΟΤΕ
            Φ <-- 0
            ΓΡΑΨΕ '=========================='
            ΓΡΑΨΕ '<Enter>. Συνεχεια αναζητησης'
            ΓΡΑΨΕ '3. Τερματισμος αναζητησης'
            ΔΙΑΒΑΣΕ Χ
            ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
          ΤΕΛΟΣ_ΑΝ
        ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ Η Χ='3'
        ΑΝ ΥΠ=ΨΕΥΔΗΣ ΤΟΤΕ
          ΓΡΑΨΕ 'Καμια λεξη/φραση δεν ικανοποιει τα κρητηρια'
        ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ '========================'
        ΓΡΑΨΕ 'Η αναζητηση ολοκληρωθηκε'
        ΓΡΑΨΕ '<Enter>. για επαναληψη'
        ΓΡΑΨΕ '3. Επιστροφη στην κανονικη λειτουργεια'
        ΔΙΑΒΑΣΕ Χ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ='3' Η ΛΕΙ='5'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΔΙΑΓ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΜΑΧ,Θ
  ΧΑΡΑΚΤΗΡΕΣ:Χ
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΑΝ ΜΑΧ>=1 ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'Δωσε αριθμο καταχωρησης (μεγιστο',ΜΑΧ,'):'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ Θ
      ΜΕΧΡΙΣ_ΟΤΟΥ Θ>=1 ΚΑΙ Θ<=ΜΑΧ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Θ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
      ΓΡΑΨΕ 'Διαγραφη του: "',Χ,'" ?'
      ΓΡΑΨΕ '=======>--'
      ΓΡΑΨΕ '1.Οχι/Εξοδος'
      ΓΡΑΨΕ '2.Επιλογη αλλης'
      ΓΡΑΨΕ '6.Ναι'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ Χ
      ΜΕΧΡΙΣ_ΟΤΟΥ Χ='1' Η Χ='2' Η Χ='6'
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ='1' Η Χ='6'
    ΑΝ Χ='6' ΤΟΤΕ
      ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΜΑΧ-Θ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Θ+Ι
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Θ+Ι-1
        ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,ΜΑΧ
      ΑΠΟΚΟΨΕ_ΑΡΧΕΙΟ ΚΑΤ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΜΑΧ,Ι,Κ
  ΧΑΡΑΚΤΗΡΕΣ:Χ1,Χ2,Π
  ΛΟΓΙΚΕΣ:ΕΞΩ
ΑΡΧΗ
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΑΝ ΜΑΧ>=2 ΤΟΤΕ
    ΠΗΓΑΙΝΕ_ΧΥ 1,5
    ΓΡΑΨΕ 'Ολοκληρωθηκε:'
    Ι <-- 1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΕΞΩ <-- ΑΛΗΘΗΣ
      Κ <-- ΜΑΧ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Κ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ2
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Κ-1
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ1
        ΑΝ Χ2<Χ1 ΤΟΤΕ
          ΕΞΩ <-- ΨΕΥΔΗΣ
          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Κ
          ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ1
          ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,Κ-1
          ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΑΤ,Χ2
        ΤΕΛΟΣ_ΑΝ
        Κ <-- Κ-1
      ΜΕΧΡΙΣ_ΟΤΟΥ Κ=1
      ΠΗΓΑΙΝΕ_ΧΥ 14,5
      ΓΡΑΨΕ (Ι/ΜΑΧ)*100,'%'
      Ι <-- Ι+1
    ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ  Η ΕΞΩ=ΑΛΗΘΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



ΔΙΑΔΙΚΑΣΙΑ ΑΝ_ΛΕΞ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Θ,ΜΑΧ
  ΧΑΡΑΚΤΗΡΕΣ:ΑΡΧ,ΕΠ,Π
ΑΡΧΗ
  ΜΑΧ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ (ΚΑΤ)
  ΑΝ ΜΑΧ>=1 ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ_ 'Αναζητηση της λεξης/φρασης:'
      ΔΙΑΒΑΣΕ Π
      Π <-- Μ_Κ(Π)
      Ι <-- 0
      Θ <-- 0
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΑΤ,1
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Ι <-- Ι+1
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ ΚΑΤ,ΑΡΧ
        ΑΝ ΑΡΧ=Π ΤΟΤΕ
          Θ <-- Ι
        ΤΕΛΟΣ_ΑΝ
      ΜΕΧΡΙΣ_ΟΤΟΥ Ι=ΜΑΧ Η Θ<>0
      ΓΡΑΨΕ '=======>--'
      ΑΝ Θ<>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η λεξη/φραση βρισκεται στην θεση:'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Δεν βρεθηκε'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ '=======>--'
      ΓΡΑΨΕ '1.Εξοδος'
      ΓΡΑΨΕ '<Enter>. Εκτελεση ξανα'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΔΙΑΒΑΣΕ ΕΠ
      ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠ='1' Η ΕΠ=''
    ΜΕΧΡΙΣ_ΟΤΟΥ  ΕΠ='1'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



ΣΥΝΑΡΤΗΣΗ Μ_Κ(Χ):ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,ΕΠ
  ΑΚΕΡΑΙΕΣ:ΜΑΧ,Κ
ΑΡΧΗ
  ΜΑΧ <-- ΜΗΚΟΣ_ΧΑΡ(Χ)
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ ΜΑΧ
    ΑΝ Χ[Κ]='α' ΤΟΤΕ
      Χ[Κ] <-- 'Α'                                                        
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='β' ΤΟΤΕ
      Χ[Κ] <-- 'Β'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='γ' ΤΟΤΕ
      Χ[Κ] <-- 'Γ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='δ' ΤΟΤΕ
      Χ[Κ] <-- 'Δ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ε' ΤΟΤΕ
      Χ[Κ] <-- 'Ε'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ζ' ΤΟΤΕ
      Χ[Κ] <-- 'Ζ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='η' ΤΟΤΕ
      Χ[Κ] <-- 'Η'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='θ' ΤΟΤΕ
      Χ[Κ] <-- 'Θ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ι' ΤΟΤΕ
      Χ[Κ] <-- 'Ι'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='κ' ΤΟΤΕ
      Χ[Κ] <-- 'Κ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='λ' ΤΟΤΕ
      Χ[Κ] <-- 'Λ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='μ' ΤΟΤΕ
      Χ[Κ] <-- 'Μ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ν' ΤΟΤΕ
      Χ[Κ] <-- 'Ν'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ξ' ΤΟΤΕ
      Χ[Κ] <-- 'Ξ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ο' ΤΟΤΕ
      Χ[Κ] <-- 'Ο'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='π' ΤΟΤΕ
      Χ[Κ] <-- 'Π'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ρ' ΤΟΤΕ
      Χ[Κ] <-- 'Ρ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='σ' Η Χ[Κ]='ς' ΤΟΤΕ
      Χ[Κ] <-- 'Σ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='τ' ΤΟΤΕ
      Χ[Κ] <-- 'Τ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='υ' ΤΟΤΕ
      Χ[Κ] <-- 'Υ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='φ' ΤΟΤΕ
      Χ[Κ] <-- 'Φ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='χ' ΤΟΤΕ
      Χ[Κ] <-- 'Χ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ψ' ΤΟΤΕ
      Χ[Κ] <-- 'Ψ'
    ΑΛΛΙΩΣ_ΑΝ Χ[Κ]='ω' ΤΟΤΕ
      Χ[Κ] <-- 'Ω'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Μ_Κ <--  Χ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters