Τώρα είναι Παρ 28 Φεβ 2020 09:49 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 13 Μάιος 2003 04:07 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Με το παρακάτω πρόγραμμα βρήκα (τυχαία) το bug της ΠΑΡΕΜΒΟΛΗΣ. Δοκιμάστε στην γραμμή 16 το -2 να γίνει -1. Θα δείτε την διαφορά;

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΡΟΜΒΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I
ΑΡΧΗ
  ! ΜΕ ΑΥΤΟ ΤΟ ΠΡΟΓΡΑΜΜΑ ΕΦΤΙΑΞΑ ΕΝΑ BUG ΤΗΣ ΣΥΝΑΡΤΗΣΗΣ ΠΑΡΕΜΒΟΛΗ (ΔΕΣ ΤΟ -2)
  ΓΡΑΨΕ_ ΠΑΡΕΜΒΟΛΗ(ΠΑΡΕΜΒΟΛΗ(ΜΟΤΙΒΟ('_',80),'ΡΟΜΒΟΣ ΜΕ ΑΞΟΝΕΣ',1),'[BUGMAN]',73)
  ΓΡΑΨΕ ΠΑΡΕΜΒΟΛΗ('','*',30)
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
    ΓΡΑΨΕ ΠΑΡΕΜΒΟΛΗ(ΠΑΡΕΜΒΟΛΗ('',ΠΑΡΕΜΒΟΛΗ('*','*',I*2+1),30-Ι),'*',30)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ΠΑΡΕΜΒΟΛΗ(ΠΑΡΕΜΒΟΛΗ(' ',ΜΟΤΙΒΟ('* ',10)+'*',20),'*',30)
  ΓΙΑ Ι ΑΠΟ 9 ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΓΡΑΨΕ ΠΑΡΕΜΒΟΛΗ(ΠΑΡΕΜΒΟΛΗ('',ΠΑΡΕΜΒΟΛΗ('*','*',I*2+1),30-Ι),'*',30)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ_ ΠΑΡΕΜΒΟΛΗ('','*',30)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΠΑΡΕΜΒΟΛΗ(Χ,Ψ,Ι):ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Χ, ΑΧ, Ψ
  ΑΚΕΡΑΙΕΣ: Ι, Κ
ΑΡΧΗ
  ΑΝ Ψ='' ΤΟΤΕ
    Ψ <-- ' '
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Χ='' ΤΟΤΕ
    Χ <-- ' '
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΜΗΚΟΣ_ΧΑΡ(Χ)< (Ι+ΜΗΚΟΣ_ΧΑΡ(Ψ)+1) ΤΟΤΕ
    ΓΙΑ Κ ΑΠΟ ΜΗΚΟΣ_ΧΑΡ(Χ) ΜΕΧΡΙ Ι+ΜΗΚΟΣ_ΧΑΡ(Ψ)-2
      Χ <-- Χ+' '
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΧ <-- Χ
  ΓΙΑ Κ ΑΠΟ Ι ΜΕΧΡΙ ΜΗΚΟΣ_ΧΑΡ(ΑΧ)
    ΑΝ (Κ-Ι)<ΜΗΚΟΣ_ΧΑΡ(Ψ) ΤΟΤΕ
      Χ[Κ] <-- Ψ[Κ-Ι+1]
    ΑΛΛΙΩΣ
      Χ[Κ] <-- ΑΧ[Κ]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΠΑΡΕΜΒΟΛΗ <-- Χ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΜΟΤΙΒΟ(Χ,Ι):ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Υ
  ΧΑΡΑΚΤΗΡΕΣ: Χ, Μ
ΑΡΧΗ
  Μ <-- ''
  Υ <-- Ι*ΜΗΚΟΣ_ΧΑΡ(Χ)
  ΑΝ (Υ>0) ΚΑΙ (Υ<255) ΤΟΤΕ
    ΓΙΑ Ι ΑΠΟ Ι ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
      Μ <-- Μ+Χ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΛΛΙΩΣ_ΑΝ Υ<=0 ΤΟΤΕ
    Μ <-- ''
  ΑΛΛΙΩΣ
    Μ <-- '?'
  ΤΕΛΟΣ_ΑΝ
  ΜΟΤΙΒΟ <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters