Τώρα είναι Παρ 28 Φεβ 2020 09:12 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 11 Μάιος 2003 10:41 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! Το πρόγραμμα αποθηκεύει λέξεις (ή φράσεις) σε ένα αρχείο στο δίσκο.


ΠΡΟΓΡΑΜΜΑ Επίδειξη_βασικών_λειτουργιών_αρχείων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επιλ, Ι, Ν
  ΧΑΡΑΚΤΗΡΕΣ: λ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: αρχ

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ αρχ, 'C:\TEST'

  ΓΡΑΨΕ 'ΕΠΙΛΟΓΕΣ:'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '1. Δημιουργία του αρχείου από την αρχή'
  ΓΡΑΨΕ '   (αν το αρχείο υπάρχει θα διαγραφούν όλα τα περιεχόμενά του)'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '2. Πρόσθεση δεδομένων σε αρχείο που υπάρχει ήδη'
  ΓΡΑΨΕ '   (αν το αρχείο δεν υπάρχει θα δημιουργηθεί σφάλμα χρόνου εκτέλεσης)'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '3. Διαγραφή του αρχείου από το δίσκο'
  ΓΡΑΨΕ '   (αν το αρχείο δεν υπάρχει θα δημιουργηθεί σφάλμα χρόνου εκτέλεσης)'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '4. Έξοδος από το πρόγραμμα'
  ΓΡΑΨΕ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ_ 'ΕΠΙΛΟΓΗ; '
    ΔΙΑΒΑΣΕ επιλ
  ΜΕΧΡΙΣ_ΟΤΟΥ (επιλ>0) ΚΑΙ (επιλ<5)

  ΕΠΙΛΕΞΕ επιλ
    ΠΕΡΙΠΤΩΣΗ 1
      ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ αρχ
    ΠΕΡΙΠΤΩΣΗ 2
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ αρχ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ αρχ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(αρχ)+1
    ΠΕΡΙΠΤΩΣΗ 3
      ΔΙΑΓΡΑΨΕ_ΑΡΧΕΙΟ αρχ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'Το αρχείο διαγράφτηκε από το δίσκο.'
      ΤΕΡΜΑΤΙΣΜΟΣ
    ΠΕΡΙΠΤΩΣΗ 4
      ΤΕΡΜΑΤΙΣΜΟΣ
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ_ 'Πόσες λέξεις θέλεις να αποθηκεύσεις στο αρχείο (1 έως 5);'
    ΔΙΑΒΑΣΕ Ν
  ΜΕΧΡΙΣ_ΟΤΟΥ (Ν>0) ΚΑΙ (Ν<6)

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ_ 'Δώσε την ', Ι, 'η λέξη: '
    ΔΙΑΒΑΣΕ λ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ αρχ, λ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΡΑΨΕ 'Τα περιεχόμενα του αρχείου είναι τώρα τα εξής...'
  ΓΡΑΨΕ
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ αρχ, 1
  Ι <-- 1
  ΟΣΟ ΟΧΙ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(αρχ) ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ αρχ, λ
    ΓΡΑΨΕ Ι, 'η εγγραφή: ', λ   
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ αρχ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Επίδειξη_βασικών_λειτουργιών_αρχείων

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters