Τώρα είναι Πέμ 27 Φεβ 2020 09:03 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: βοήθεια με το ημερολόγιο
ΔημοσίευσηΔημοσιεύτηκε: Τετ 21 Μάιος 2008 02:36 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ημερολόγιο
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: α,β,γ
  ΑΚΕΡΑΙΕΣ: επιλ

  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: γραπτα,κωδικός,ονομα

ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ γραπτα,('C:\ΓΡΑΠΤΑ.GM')
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ κωδικος,('C:\ΚΩΔΙΚ.GM')
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ ονομα,('C:\ONOM.GM')
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\ΓΡΑΠΤΑ.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΓΡΑΠΤΑ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΓΡΑΠΤΑ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\ΚΩΔΙΚ.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\ΟΝΟΜ.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ
  ΤΕΛΟΣ_ΑΝ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΛΕΣΕ ΜΕΝΟΥ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ_ 'Επιλογή (1-5); '
      ΔΙΑΒΑΣΕ  επιλ
    ΜΕΧΡΙΣ_ΟΤΟΥ (επιλ>0) ΚΑΙ (επιλ<6)
    ΕΠΙΛΕΞΕ επιλ
      ΠΕΡΙΠΤΩΣΗ 1
        ΚΑΛΕΣΕ στοιχεία_παικτη
      ΠΕΡΙΠΤΩΣΗ 2
        ΚΑΛΕΣΕ ασφάλεια
      ΠΕΡΙΠΤΩΣΗ 3
        ΚΑΛΕΣΕ ΓΡΑΨΙΜΟ
      ΠΕΡΙΠΤΩΣΗ 4
        ΚΑΛΕΣΕ εξοδο
      ΠΕΡΙΠΤΩΣΗ 5
        ΚΑΛΕΣΕ διαγραφη

        ΤΕΡΜΑΤΙΣΜΟΣ

    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ επιλ=5




ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!!!................................................................................

ΔΙΑΔΙΚΑΣΙΑ ΚΑΘΥΣΤΕΡΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!.................................................................................
ΔΙΑΔΙΚΑΣΙΑ ΜΕΝΟΥ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επιλ


ΑΡΧΗ



  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΡΑΨΕ  'Καλώς ήρθατε στο πρώτο ηλεκτρονικό '
  ΓΡΑΨΕ  '             ημερολόγιο από τον.............'
  ΓΡΑΨΕ  '            ___  _____                        '
  ΓΡΑΨΕ  '  |        |    |     /    \    /  PROGRAMMER @@  '
  ΓΡΑΨΕ  '  |        |__|    /       \  /        MAKHS @@  '
  ΓΡΑΨΕ  '  |        |   |   /         \/                   '
  ΓΡΑΨΕ  '  |____ /     \ /____   ||                   '

  ΓΡΑΨΕ  'Όπως είδατε αυτό είναι ένα ηλεκτρονικό ημερολόγιο που μπορείς να γράφεις,'
  ΓΡΑΨΕ  'ό,τι θες και με τον δικό σου κωδικό χωρίς οι άλλοι να τα διαβάζουν και'
  ΓΡΑΨΕ  'κάλλιστα να τα αποθηκεύεις με την ημερομινία τους και να τα διαβάζεις όταν θες.'
  ΓΡΑΨΕ  'Βέβαια για τώρα μπορείς να γράφεις με λίγους χαρακτήρες αλλά να προσθέτεις'
  ΓΡΑΨΕ  'σκέψεις ή ότι άλλο θες!!!'


  ΓΡΑΨΕ '1 Θέλεις να γράψεις τα στοιχεία σου;'
  ΓΡΑΨΕ '2 Θέλεις να δώσεις τον προσωπικό σου κωδικό ή και να τον αλλάξεις;'
  ΓΡΑΨΕ '3 Θέλεις να αρχίσεις το γράψιμο ;'
  ΓΡΑΨΕ '4 Θέλεις να κλεισεις το πρόγγραμμα;'
  ΓΡΑΨΕ '5 Θέλεις να διαγράψεις κάτι;'




ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!...............................................................................

ΔΙΑΔΙΚΑΣΙΑ στοιχεία_παικτη


ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ο,φ,ηλ,τ

ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΓΡΑΨΕ 'Δώσε το όνομα σου:'
  ΔΙΑΒΑΣΕ ο
  ΓΡΑΨΕ 'Δώσε την ηλικία σου:'
  ΔΙΑΒΑΣΕ ηλ
  ΓΡΑΨΕ'Δώσε το φύλο σου:'
  ΔΙΑΒΑΣΕ φ

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΟΝΟΜΑ)+3
  ΓΡΑΨΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ, ο
  ΓΡΑΨΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ,ηλ
  ΓΡΑΨΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ,φ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΟΝΟΜΑ

  ΓΡΑΨΕ 'Τα στοιχεία αποθηκεύτηκαν. Πατήστε <ENTER> για να συνεχίσετε...'
  ΔΙΑΒΑΣΕ τ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!.................................................................................

διαδικασία ασφάλεια


ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: εγγ,μεγ,επιλ
  ΧΑΡΑΚΤΗΡΕΣ: κ,τ,α,ζ

ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

    ΓΡΑΨΕ'Αν θες να βάλεις τον κωδικό σου πάτα 1 ή αν θες να τον αλλάξεις 2 αρκη να έχεις ίδη.'
    ΓΡΑΨΕ_ 'Επιλογή (1-2); '
    ΔΙΑΒΑΣΕ  επιλ
  ΜΕΧΡΙΣ_ΟΤΟΥ (επιλ>0) ΚΑΙ (επιλ<3)
  ΕΠΙΛΕΞΕ επιλ
    ΠΕΡΙΠΤΩΣΗ 1
      ΓΡΑΨΕ 'Πρόσθεσε τον κωδικό που θες και στη συνέχεια πάτα το [ENTER].'
      ΔΙΑΒΑΣΕ  κ
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΩΔΙΚΟΣ)+1
      ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ, κ
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'Τα στοιχεία αποθηκεύτηκαν. Πατήστε <ENTER> για να συνεχίσετε...'
      ΔΙΑΒΑΣΕ τ


    ΠΕΡΙΠΤΩΣΗ 2
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
λοιπόν κάπου εδώ θέλω να ζητάει τον παλιό και αν είναι σωστός τότε να συνεχίζει
με τον καινούργιο κωδικό
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
      μεγ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(ΚΩΔΙΚΟΣ)
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
      ΑΝ μεγ=0 τότε
        ΓΡΑΨΕ 'ΔΕΝ ΥΠΑΡΧΕΙ ΚΩΔΙΚΟΣ'
        ΕΞΟΔΟΣ
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ,ο προηγούμενος κωδικός θα διαγραφεί'

        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ_ 'Παλιός κωδικός (', μεγ, '); '
          ΔΙΑΒΑΣΕ εγγ
        ΜΕΧΡΙΣ_ΟΤΟΥ (εγγ>0) ΚΑΙ (εγγ<=μεγ)

        ΓΡΑΨΕ_ 'Λοιπόν ποιός είναι ο καινούργιος κωδικός; '
        ΔΙΑΒΑΣΕ α

        ΑΝΟΙΞΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ,εγγ
        ΓΡΑΨΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ, α
        ΚΛΕΙΣΕ_ΑΡΧΕΙΟ ΚΩΔΙΚΟΣ
        ΓΡΑΨΕ 'Τα στοιχεία άλλαξαν. Πατήστε [ENTER] για να συνεχίσετε...'
        ΔΙΑΒΑΣΕ τ
       ΤΕΛΟΣ_ΑΝ

      ΤΕΡΜΑΤΙΣΜΟΣ
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!......................................................................

ΔΙΑΔΙΚΑΣΙΑ ΓΡΑΨΙΜΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: γ,τ,ημε,κο
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: ΚΩΔΙΚΟΣ
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΡΑΨΕ 'Ηρθε η ώρα για να γράψεις αλλα πρώτα πρεπει να κάνεις κάτι πραγματακιά:'
  ΓΡΑΨΕ 'Δώδε τον κωδικό σου:'
  !!!!!!!!!!!!!!!!!!!!!!!!!
ούτε εδώ μπορώ να τον επιβεβαιώσω
  !!!!!!!!!!!!!!!!!!!!!!!!!!
 
  ΓΡΑΨΕ'Γειά δώσε την ημερομινία:'
  ΔΙΑΒΑΣΕ ημε
  ΓΡΑΨΕ'Τώρα γράψε ό,τι θες αλλά οι χαρακτήρες είναι περιορισμένοι και στη συνέχεια [ENTER]αφου τελιώσεις.'
  ΔΙΑΒΑΣΕ γ

 ΑΝΟΙΞΕ_ΑΡΧΕΙΟ γραπτά
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ ΟΝΟΜ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(γραπτά)+2
  ΓΡΑΨΕ_ΑΡΧΕΙΟ γραπτα,ημε,γ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ γραπτα
  ΓΡΑΨΕ

  ΓΡΑΨΕ'ΠΑΤΑ [enter] ΓΙΑ ΕΞΟΔΟ'

  ΔΙΑΒΑΣΕ τ
  ΤΕΡΜΑΤΙΣΜΟΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!....................................................................

ΔΙΑΔΙΚΑΣΙΑ εξοδο
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: τ
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΓΡΑΨΕ  '  Γεία σου και σε περιμένω και αύριο.'
  ΓΡΑΨΕ  '            ___  _____                        '
  ΓΡΑΨΕ  '  |        |   |        / \    /  PROGRAMMER @@  '
  ΓΡΑΨΕ  '  |        |__|       /   \  /        MAKHS @@  '
  ΓΡΑΨΕ  '  |        |    |     /     \/                   '
  ΓΡΑΨΕ  '  |____ /      \   /___ ||                   '

  κάλεσε ΚΑΘΥΣΤΕΡΗΣΗ
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


 !!!....................................................................
διαδικασία διαγραφή
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: τ,αρχ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: γραπτα

ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ γραπτα
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ γραπτα
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Πώς εμφανίζω τα αρχεία τα <αλλάζω>
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
     ΚΛΕΙΣΕ_ΑΡΧΕΙΟ γραπτα
  ΤΕΡΜΑΤΙΣΜΟΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!!!.................................................................



ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
σίγουρα έχω λάθη αλλά άμα δεν βρώ τα παραπάνω πώς θα τα διωρθώσω
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters