Τώρα είναι Σάβ 29 Φεβ 2020 12:13 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: LITTLE CALCULATOR
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 27 Απρ 2008 04:01 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 11:05 am
Δημοσιεύσεις: 21
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΕΤΑΒΛΗΤΕΣ

  ΠΡΑΓΜΑΤΙΚΕΣ: β,γ



ΑΡΧΗ


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ 'Καλωσήρθατε στον mini calculator του lazy programmer[Μάκης].'

    ΓΡΑΨΕ 'Για να μην πολυλογούμε τι πράξη θέλετε να κάνετε;'


    ΓΡΑΨΕ '[1] Πρόσθεση,[2] Αφαίρεσή,[3] Πολλαπλασιασμό,[4] Διαίρεση,[5] Ρίζα:'


    ΓΡΑΨΕ 'Λοιπόν...'

    ΔΙΑΒΑΣΕ Ζ



    ΑΝ Ζ=1 ΤΟΤΕ
      ΓΡΑΨΕ 'Δώσε τον πρώτο αριθμό:'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'Δώσε και τον άλλο αριθμό:'
      ΔΙΑΒΑΣΕ γ

      δ1 <-- (β+γ)

      ΓΡΑΨΕ   '  Λοιπόν  ' ,β, '  +  ' ,γ, '  = ' ,δ1, '.'


    ΤΕΛΟΣ_ΑΝ



    αν Ζ=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Δώσε τον Αφαιρετέο:'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'Δώσε και τον Αφαιρέτη:'
      ΔΙΑΒΑΣΕ γ

      δ1 <-- (β-γ)

      ΓΡΑΨΕ 'Λοιπόν',β,'-',γ,'=',δ1,'.'
    τέλος_αν



    αν Ζ=3 ΤΟΤΕ
      ΓΡΑΨΕ 'Δώσε τον Πολ/σταίο:'
      ΔΙΑΒΑΣΕ β
      ΓΡΑΨΕ 'Δώσε και τον Πολ/στη:'
      ΔΙΑΒΑΣΕ γ

      δ1 <-- (β*γ)

      ΓΡΑΨΕ  'Λοιπόν',β,'*',γ,'=',δ1,'.'
    τέλος_αν



    αν Ζ=4 ΤΟΤΕ

      ΓΡΑΨΕ 'Δώσε τον Διαιρετέο:'
      ΔΙΑΒΑΣΕ β

      ΓΡΑΨΕ 'Δώσε και τον Διαιρέτη:'
      ΔΙΑΒΑΣΕ γ

      δ1 <-- (β/γ)

      ΓΡΑΨΕ  'Λοιπόν',β,':',γ,'=',δ1,'.'
    τέλος_αν


    αν Ζ=5 τότε
      ΓΡΑΨΕ 'Δώσε τον αριθμό:'
      ΔΙΑΒΑΣΕ β
    ΤΕΛΟΣ_ΑΝ

    αν β<=0 τότε
      ΓΡΑΨΕ 'Ο αριθμός πρεπει να είναι >0'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Η ρίζα του',β,' είναι το',Τ_Ρ(β)
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'Αν θέλετε να κάνετε και άλλη πράξη πατείστε το 1 αλλιώς το 2 για έξοδο:'
    ΔΙΑΒΑΣΕ β

  ΜΕΧΡΙΣ_ΟΤΟΥ β=2
  ΓΡΑΨΕ 'ΕΥΧΑΡΙΣΤΩ ΠΟΥ ΜΕ ΔΙΑΛΕΞΑΤΕ!!!'



  ΚΑΛΕΣΕ ΚΑΘΥΣΤΕΡΗΣΗ



ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΚΑΘΥΣΤΕΡΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters