Τώρα είναι Παρ 18 Απρ 2014 03:19 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Στατιστική
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 22 Μαρ 2008 06:29 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 16 Μαρ 2008 09:35 pm
Δημοσιεύσεις: 2
ypologismos ths meshs timhs, ths typikhs apoklishs kai ths diamesou (gia askhseis mathimatikwn genikhs paidias)

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Στατιστική

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, Ν, Χ[100], Άθροισμα, Άθροισμα_2, Βοηθητική
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΤ, Τυπ_Απόκλιση, Διάμεσος

ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)'
  ΔΙΑΒΑΣΕ Ν
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε τον ', i,'-το αριθμό'
    ΔΙΑΒΑΣΕ Χ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Άθροισμα <-- 0
  Άθροισμα_2 <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν
    Άθροισμα <-- Άθροισμα + Χ[i]
    Άθροισμα_2 <-- Άθροισμα_2 + Χ[i] ^ 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΤ <-- Άθροισμα / Ν
  Τυπ_Απόκλιση <-- Τ_Ρ(Άθροισμα_2 / Ν - ΜΤ ^ 2)        
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ Χ[J-1] > Χ[j] ΤΟΤΕ
        Βοηθητική <-- Χ[j-1]
        Χ[j-1] <-- Χ[j]
        Χ[j] <-- Βοηθητική
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Ν MOD 2 = 0 ΤΟΤΕ
    Διάμεσος <-- (Χ[Α_Μ(Ν/2)] + Χ[Α_Μ(Ν/2+1)])/2
  ΑΛΛΙΩΣ
    Διάμεσος <-- Χ[Α_Μ((Ν+1)/2)]
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ'
  ΓΡΑΨΕ '============'
  ΓΡΑΨΕ 'Πλήθος τιμών =', Ν
  ΓΡΑΨΕ 'Μέση τιμή =', ΜΤ
  ΓΡΑΨΕ 'Τυπική απόκλιση =', Τυπ_Απόκλιση
  ΓΡΑΨΕ 'Διάμεσος =', Διάμεσος
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Στατιστική


+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

mporeite na vreite to programma kai sthn selida 188-189 to sxolkou vivliou tis Α.Ε.Π.Π., omos me kapoia lathoi pou diorthosa me th vohtheia apo auto to site. elpizw na sas fanei xrhsimo
~ChRiS~


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: