Τώρα είναι Παρ 28 Φεβ 2020 08:03 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΠΛΗ ΑΠΟΘΗΚΗ!
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 08 Μάιος 2003 01:11 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Χωρίς σχόλια!
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΠΟΘΗΚΗ
! ΓΙΑ ΤΗΝ ΕΚΔΟΣΗ 4 ΤΗΣ ΓΛΩΣΣΟΜΑΘΕΙΑΣ
ΣΤΑΘΕΡΕΣ
  ΟΛΑ_ΤΑ_ΕΙΔΗ = ΨΕΥΔΗΣ
  ΜΟΝΟ_ΕΚΤΟΣ_ΟΡΙΟΥ = ΑΛΗΘΗΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΕΣ: ΤΡΟΠΟΣ

ΑΡΧΗ
  ΑΝ ΝΑΙ('ΝΑ ΔΗΜΙΟΥΡΓΗΣΩ ΝΕΑ ΑΡΧΕΙΑ') ΤΟΤΕ
    ΚΑΛΕΣΕ ΔΗΜ_ΑΡΧ
  ΤΕΛΟΣ_ΑΝ
! ΒΑΖΟΥΜΕ ΤΡΙΑ ΕΙΔΗ
  ΑΝ ΝΑΙ('ΝΑ ΒΑΛΩ ΤΡΙΑ ΕΙΔΗ') ΤΟΤΕ
    ΑΝ ΕΙΣ_ΕΙΔΟΥΣ('101.10','ΝΤΟΜΑΤΕΣ',200.3,'ΚΙΛΑ',2.4,50,'ΜΑΝΑΒ1101') ΤΟΤΕ
      ΓΡΑΨΕ 'ΚΑΤΑΧΩΡΗΣΗ ΕΙΔΟΥΣ:101.10'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΕΙΣ_ΕΙΔΟΥΣ('101.11','ΦΥΚΙΑ',12.23,'ΚΙΛΑ',5.1,20,'ΒΟΥΤΗΧΤ03') ΤΟΤΕ
      ΓΡΑΨΕ 'ΚΑΤΑΧΩΡΗΣΗ ΕΙΔΟΥΣ:101.11'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΕΙΣ_ΕΙΔΟΥΣ('101.03','ΚΑΛΑΘΙΑ',17.0,'ΤΕΜ.',3,10,'ΚΑΛΑΘΑΣ01') ΤΟΤΕ
      ΓΡΑΨΕ 'ΚΑΤΑΧΩΡΗΣΗ ΕΙΔΟΥΣ:101.03'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΑΝΑΦΟΡΑ ΑΠΟΘΗΚΗΣ'
  ΤΡΟΠΟΣ <-- ΟΛΑ_ΤΑ_ΕΙΔΗ
  ΚΑΛΕΣΕ ΑΝΑΦΟΡΑ_ΑΠΟΘΗΚΗΣ(ΤΡΟΠΟΣ)
  ΓΡΑΨΕ 'ΜΟΝΟ ΤΑ ΕΙΔΗ ΕΚΤΟΣ ΟΡΙΟΥ'
  ΤΡΟΠΟΣ <-- ΜΟΝΟ_ΕΚΤΟΣ_ΟΡΙΟΥ
  ΚΑΛΕΣΕ ΑΝΑΦΟΡΑ_ΑΠΟΘΗΚΗΣ(ΤΡΟΠΟΣ)
  ΓΡΑΨΕ 'ΑΓΟΡΑΣΕΣ ΑΛΛΑ 100 ΚΑΛΑΘΙΑ! ΜΠΡΑΒΟ'
  ΑΝ ΕΝΗΜ_ΕΙΔΟΥΣ('101.03', 100) ΤΟΤΕ
    ΤΡΟΠΟΣ <-- ΟΛΑ_ΤΑ_ΕΙΔΗ
    ΚΑΛΕΣΕ ΑΝΑΦΟΡΑ_ΑΠΟΘΗΚΗΣ(ΤΡΟΠΟΣ)
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΝΑΙ(ΕΜΦΑΝΙΣΗ) :ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΜΦΑΝΙΣΗ, ΝΝ
  ΛΟΓΙΚΕΣ: ΟΚ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΕΜΦΑΝΙΣΗ,'(Ν/Ο)'
    ΔΙΑΒΑΣΕ ΝΝ
    ΟΚ <-- ΨΕΥΔΗΣ
    ΑΝ (ΝΝ='N') Ή (ΝΝ='Ν') ΤΟΤΕ
      ΝΑΙ <-- ΑΛΗΘΗΣ
      ΟΚ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ (ΝΝ='O') Ή (ΝΝ='Ο') ΤΟΤΕ
      ΝΑΙ <-- ΨΕΥΔΗΣ
      ΟΚ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΚ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΠΕΔΙΟ(Χ,Λ):ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Χ, Ψ
  ΑΚΕΡΑΙΕΣ: Ι,Λ
ΑΡΧΗ
  Ψ <-- ''
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Λ
    ΑΝ ΜΗΚΟΣ_ΧΑΡ(Χ)<Ι ΤΟΤΕ
      Ψ <-- Ψ+' '
    ΑΛΛΙΩΣ
      Ψ <-- Ψ+Χ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΠΕΔΙΟ <-- Ψ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
ΣΥΝΑΡΤΗΣΗ ΑΡΧ(Ν):ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ν
ΑΡΧΗ
  ΑΡΧ <-- 'C:\ALFA' + ΧΑΡ(48+((Ν DIV 10) MOD 10)) +ΧΑΡ(48+(Ν MOD 10))+'.DAT'
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
ΔΙΑΔΙΚΑΣΙΑ ΔΗΜ_ΑΡΧ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: Α_ΠΟΣΟΤΗΤΑ, Α_ΟΡΙΟ, Α_ΑΞΙΑ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: Α_ΚΩΔΙΚΟΣ, Α_ΕΙΔΟΣ, Α_ΜΟΝΑΔΕΣ, Α_ΚΩΔ_ΠΡΟΜ
ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΑΡΧ(1)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΑΡΧ(2)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΑΡΧ(3)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΑΡΧ(4)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΑΡΧ(5)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΑΡΧ(6)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΑΡΧ(7)

  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
  ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΑΛΛΗ_ΕΓΓΡΑΦΗ(ΚΩΔΙΚΟΣ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΕΣ: ΟΚ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ1
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: Α_ΚΩΔΙΚΟΣ
ΑΡΧΗ
  ΟΚ <-- ΨΕΥΔΗΣ
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΑΡΧ(2)
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ

  ΟΣΟ ΟΧΙ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Α_ΚΩΔΙΚΟΣ) ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ1
    ΑΝ ΚΩΔΙΚΟΣ=ΚΩΔΙΚΟΣ1 ΤΟΤΕ
      ΟΚ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΑΛΛΗ_ΕΓΓΡΑΦΗ <-- ΟΚ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΣΥΝΑΡΤΗΣΗ ΕΙΣ_ΕΙΔΟΥΣ(ΚΩΔΙΚΟΣ, ΕΙΔΟΣ, ΠΟΣΟΤΗΤΑ,ΜΟΝΑΔΕΣ, ΑΞΙΑ, ΟΡΙΟ, ΚΩΔ_ΠΡΟΜ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΤΗΤΑ, ΟΡΙΟ, ΑΞΙΑ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔΙΚΟΣ, ΕΙΔΟΣ, ΜΟΝΑΔΕΣ, ΚΩΔ_ΠΡΟΜ
  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: Α_ΠΟΣΟΤΗΤΑ, Α_ΟΡΙΟ, Α_ΑΞΙΑ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: Α_ΚΩΔΙΚΟΣ, Α_ΕΙΔΟΣ, Α_ΜΟΝΑΔΕΣ, Α_ΚΩΔ_ΠΡΟΜ
ΑΡΧΗ
  ΑΝ ΟΧΙ ΑΛΛΗ_ΕΓΓΡΑΦΗ(ΚΩΔΙΚΟΣ) ΤΟΤΕ
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΑΡΧ(1)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΑΡΧ(2)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΑΡΧ(3)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΑΡΧ(4)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΑΡΧ(5)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΑΡΧ(6)
    ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΑΡΧ(7)

    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ


    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΕΙΔΟΣ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΚΩΔΙΚΟΣ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΜΟΝΑΔΕΣ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΚΩΔ_ΠΡΟΜ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΠΟΣΟΤΗΤΑ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΟΡΙΟ)+1
    ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(Α_ΑΞΙΑ)+1

    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΕΙΔΟΣ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΜΟΝΑΔΕΣ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΚΩΔ_ΠΡΟΜ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΠΟΣΟΤΗΤΑ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΟΡΙΟ
    ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΑΞΙΑ

    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ

    ΕΙΣ_ΕΙΔΟΥΣ <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
    ΕΙΣ_ΕΙΔΟΥΣ <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΕΝΗΜ_ΕΙΔΟΥΣ(ΚΩΔΙΚΟΣ, ΠΟΣΟ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΤΩΡΙΝΗ_ΘΕΣΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΤΗΤΑ, ΠΟΣΟ, ΝΕΑ_ΠΟΣΟΤΗΤΑ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ1
  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: Α_ΠΟΣΟΤΗΤΑ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: Α_ΚΩΔΙΚΟΣ
ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΑΡΧ(2)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΑΡΧ(5)
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ

  ΟΣΟ ΟΧΙ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Α_ΚΩΔΙΚΟΣ) ΕΠΑΝΑΛΑΒΕ
    ΤΩΡΙΝΗ_ΘΕΣΗ <-- ΘΕΣΗ_ΑΡΧΕΙΟΥ(Α_ΚΩΔΙΚΟΣ)   
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ1
    ΑΝ ΚΩΔΙΚΟΣ=ΚΩΔΙΚΟΣ1 ΤΟΤΕ
      ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΤΩΡΙΝΗ_ΘΕΣΗ     
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΠΟΣΟΤΗΤΑ
      ΔΙΕΤΡΕΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΤΩΡΙΝΗ_ΘΕΣΗ     
      ΝΕΑ_ΠΟΣΟΤΗΤΑ <-- ΠΟΣΟΤΗΤΑ+ΠΟΣΟ
      ΓΡΑΨΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΝΕΑ_ΠΟΣΟΤΗΤΑ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ

  ΕΝΗΜ_ΕΙΔΟΥΣ <-- ΑΛΗΘΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΝΑΦΟΡΑ_ΑΠΟΘΗΚΗΣ(ΜΟΝΟ_ΟΡΙΟ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΤΗΤΑ, ΟΡΙΟ, ΑΞΙΑ, ΤΕΛΙΚΗ_ΑΞΙΑ
  ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔΙΚΟΣ, ΕΙΔΟΣ, ΜΟΝΑΔΕΣ, ΚΩΔ_ΠΡΟΜ
  ΑΚΕΡΑΙΕΣ: ΑΝΑ_ΑΡΑΔΕΣ, Ι, Μ
  ΛΟΓΙΚΕΣ: ΜΟΝΟ_ΟΡΙΟ
  ΑΡΧΕΙΑ ΠΡΑΓΜΑΤΙΚΩΝ: Α_ΠΟΣΟΤΗΤΑ, Α_ΟΡΙΟ, Α_ΑΞΙΑ
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: Α_ΚΩΔΙΚΟΣ, Α_ΕΙΔΟΣ, Α_ΜΟΝΑΔΕΣ, Α_ΚΩΔ_ΠΡΟΜ
ΑΡΧΗ

  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΑΡΧ(1)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΑΡΧ(2)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΑΡΧ(3)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΑΡΧ(4)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΑΡΧ(5)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΑΡΧ(6)
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΑΡΧ(7)

  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ
  ΓΡΑΨΕ_ ΠΕΔΙΟ('ΚΩΔΙΚΟΣ',11),ΠΕΔΙΟ('ΕΙΔΟΣ',15), ΠΕΔΙΟ('ΠΟΣΟΤΗΤΑ/ΜΟΝΑΔ',16),ΠΕΔΙΟ('ΣΥΝ. ΑΞΙΑ',11)
  ΓΡΑΨΕ ΠΕΔΙΟ('ΕΛΑΧ.ΠΟΣΟΤ',11),ΠΕΔΙΟ('ΚΩΔΙΚΟΣ ΠΕΛΑΤΗ',15)

  ΟΣΟ ΟΧΙ ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(Α_ΕΙΔΟΣ) ΕΠΑΝΑΛΑΒΕ

    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ, ΕΙΔΟΣ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ, ΚΩΔΙΚΟΣ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ, ΜΟΝΑΔΕΣ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ, ΚΩΔ_ΠΡΟΜ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ, ΠΟΣΟΤΗΤΑ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ, ΟΡΙΟ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ, ΑΞΙΑ
    ΑΝ  ΟΧΙ (ΜΟΝΟ_ΟΡΙΟ ΚΑΙ(ΠΟΣΟΤΗΤΑ>ΟΡΙΟ)) ΤΟΤΕ
      ΤΕΛΙΚΗ_ΑΞΙΑ <-- ΑΞΙΑ*ΠΟΣΟΤΗΤΑ
      ΓΡΑΨΕ_ ΠΕΔΙΟ(ΚΩΔΙΚΟΣ,10),ΠΕΔΙΟ('|'+ΕΙΔΟΣ,15),'|'
      ΓΡΑΨΕ ΠΟΣΟΤΗΤΑ:10:3,ΜΟΝΑΔΕΣ,'|',ΤΕΛΙΚΗ_ΑΞΙΑ:10:2,'|',ΟΡΙΟ:10:2,ΠΕΔΙΟ('|'+ΚΩΔ_ΠΡΟΜ,15)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΕΙΔΟΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔΙΚΟΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΜΟΝΑΔΕΣ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΚΩΔ_ΠΡΟΜ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΠΟΣΟΤΗΤΑ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΟΡΙΟ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ Α_ΑΞΙΑ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters