Τώρα είναι Τετ 12 Αύγ 2020 11:45 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μάχη με 3 τερατα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 25 Οκτ 2007 07:17 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ψ,Ω,Ν,Μ,Λ

ΑΡΧΗ

  ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN, 2 (ΜΕΤΡΙΟΣ) WOLF,3 (ΔΥΣΚΟΛΟ) ANTHARAS'

  ΔΙΑΒΑΣΕ Λ

  ΑΝ Λ=1 ΤΟΤΕ
    Χ <-- 50
    Ψ <-- 5
    Ν <-- 100
    Μ <-- 3
  ΤΕΛΟΣ_ΑΝ

  ΑΝ Λ=2 ΤΟΤΕ
    Χ <-- 100
    Ψ <-- 5
    Ν <-- 100
    Μ <-- 10
  ΤΕΛΟΣ_ΑΝ

  ΑΝ Λ=3 ΤΟΤΕ
    Χ <-- 100
    Ψ <-- 5
    Ν <-- 100
    Μ <-- 20
  ΤΕΛΟΣ_ΑΝ


  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ 'ΕΠΙΘΕΣΗ 1, SUPER ΕΠΙΘΕΣΗ 2 '

    ΔΙΑΒΑΣΕ Ω


    ΑΝ Ω=1 ΤΟΤΕ
      Χ <-- Χ-Ψ
      Ν <-- Ν-Μ
    ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ
      ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
    ΑΛΛΙΩΣ_ΑΝ Ω=2 ΤΟΤΕ
      Ψ <-- Ψ*2
      Χ <-- Χ-Ψ
      Ν <-- Ν-Μ
    ΤΕΛΟΣ_ΑΝ



    ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'

  ΜΕΧΡΙΣ_ΟΤΟΥ Χ<=0 Ή Ν<=0
  ΑΝ Χ<=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΤΕΛΟΣ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Ν>0 Ή Χ<=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
  ΑΛΛΙΩΣ_ΑΝ Ν<=0 Ή Χ>0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Πείτε μου την γνώμη σας για αυτό το προγραμμα.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters