Τώρα είναι Δευτ 13 Ιούλ 2020 01:32 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 13 Δεκ 2007 05:12 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΑΜΕΙΑΚΗ_ΜΗΧΑΝΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : ΠΣ[100]
  ΠΡΑΓΜΑΤΙΚΕΣ : ΤΜ[100], ΕΚΠ, ΚΚ, ΤΚ
  ΧΑΡΑΚΤΗΡΕΣ : ΟΝΜ[100]
ΑΡΧΗ
  ΚΚ <-- 0
  Ι <-- 1
  ΓΡΑΨΕ 'ΠΡΟΓΡΑΜΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΤΑΜΕΙΑΚΗΣ ΜΗΧΑΝΗΣ ΕΚΔΟΣΗ 1'
  ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΟΝΟΜΑ ΠΡΟΟΙΟΝΤΟΣ,ΔΩΣΤΕ 9999 ΓΙΑ ΤΕΛΟΣ'
  ΔΙΑΒΑΣΕ ΟΝΜ[Ι]
  ΟΣΟ (ΟΝΜ[Ι] <> '9999')ΚΑΙ(Ι < 100) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΠΟΣΟΤΗΤΑ ΠΡΟΟΙΟΝΤΟΣ'
    ΔΙΑΒΑΣΕ ΠΣ[Ι]
    ΟΣΟ (ΠΣ[Ι] <= 0) Η (ΠΣ[Ι] > 9999) ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΤΙΜΗ ΕΚΤΟΣ ΟΡΙΩΝ'
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΞΑΝΑ ΤΗΝ ΠΟΣΟΤΗΤΑ ΤΟΥ ',ΟΝΜ[Ι]
      ΔΙΑΒΑΣΕ ΠΣ[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΙΜΗ ΠΡΟΟΙΟΝΤΟΣ'
    ΔΙΑΒΑΣΕ ΤΜ[Ι]
    ΟΣΟ (ΤΜ[Ι] < 0) ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΤΙΜΗ ΕΚΤΟΣ ΟΡΙΩΝ'
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΞΑΝΑ ΤΗΝ ΤΙΜΗ ΤΟΥ ',ΟΝΜ[Ι]
      ΔΙΑΒΑΣΕ ΤΜ[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΚ <-- ΚΚ + ΤΜ[Ι]*ΠΣ[Ι]
    ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΟΝΟΜΑ ΕΠΟΜΕΝΟΥ ΠΡΟΟΙΟΝΤΟΣ,ΔΩΣΤΕ 9999 ΓΙΑ ΤΕΛΟΣ'
    Ι <-- Ι + 1
    ΔΙΑΒΑΣΕ ΟΝΜ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Ι <> 1 ΤΟΤΕ  ! ΣΕ ΠΕΡΙΠΤΩΣΗ ΠΟΥ ΕΙΣΑΧΘΕΙ ΕΞΟΔΟΣ ΑΠΟ ΤΗΝ ΑΡΧΗ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΚΠΤΩΣΗ %'
    ΔΙΑΒΑΣΕ ΕΚΠ
    ΟΣΟ (ΕΚΠ < 0) Η (ΕΚΠ > 80) ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΔΩΣΑΤΕ ΤΙΜΗ ΕΚΤΟΣ ΟΡΙΩΝ'
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΞΑΝΑ ΕΚΠΤΩΣΗ ΤΟΥ ',ΟΝΜ[Ι]
      ΔΙΑΒΑΣΕ ΕΚΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΚ <-- ΚΚ - ΚΚ*(ΕΚΠ/100)
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΓΡΑΨΕ '--------------------ΛΟΓΑΡΙΑΣΜΟΣ--------------------'
    ΚΑΛΕΣΕ ΕΜΦ_ΛΟΓ(Ι,ΟΝΜ,ΠΣ,ΤΜ)
    ΓΡΑΨΕ 'ΚΟΣΤΟΣ                                     ',ΚΚ:6:2
    ΓΡΑΨΕ 'ΕΚΠΤΩΣΗ                                    -',ΕΚΠ:6:2,'%'
    ΓΡΑΨΕ 'ΤΕΛΙΚΟ ΚΟΣΤΟΣ                               ',ΤΚ:6:2
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '---------------------------------------------------'
  ΓΡΑΨΕ '~~~~~~~**********------ΤΕΛΟΣ------**********~~~~~~~'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΤΑΜΕΙΑΚΗ_ΜΗΧΑΝΗ
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ΔΙΑΔΙΚΑΣΙΑ ΕΜΦ_ΛΟΓ(Ν,ΟΝΜ,ΠΣ,ΤΜ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : Ν,Ι,ΠΣ[100]
  ΠΡΑΓΜΑΤΙΚΕΣ : ΤΜ[100]
  ΧΑΡΑΚΤΗΡΕΣ : ΟΝΜ[100]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν - 1
    ΓΡΑΨΕ ΟΝΜ[Ι],'  x',ΠΣ[Ι],'                  ',ΤΜ[Ι]*ΠΣ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


-------------------------------------------------------------------------------------
ΝΑ ΚΑΙ ΕΝΑ ΠΡΟΓΡΑΜΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΤΑΜΕΙΑΚΗΣ ΜΗΧΑΝΗΣ
ΚΑΘΕ ΠΡΟΤΑΣΗ ΓΙΑ ΒΕΤΙΩΣΗ ΕΥΠΡΟΣΔΕΚΤΗ

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters