Τώρα είναι Σάβ 04 Ιούλ 2020 10:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 18 Δημοσιεύσεις ]  Μετάβαση στην σελίδα 1, 2  Επόμενο
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Τετ 12 Δεκ 2007 06:29 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Το πρόγραμμα αυτό έχει πολλες καινούριες δυνατότητες.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ψ,Ω,Ν,Μ,Λ,Β,Π,Ι

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 3
      Β <-- Β+10
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 10
      Β <-- Β+50
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 20
      Β <-- 100
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '

      ΔΙΑΒΑΣΕ Π




    ΤΕΛΟΣ_ΑΝ

    ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Ν <-- Ν+100
      Β <-- Β-100
    ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ψ <-- Ψ+5
      Β <-- Β-150
    ΤΕΛΟΣ_ΑΝ

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

      ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω

      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=1 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Λ=2 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Λ=3 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Ψ=0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ=0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ω=2 ΤΟΤΕ Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ



      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'

    ΜΕΧΡΙΣ_ΟΤΟΥ Χ<=0 Ή Ν<=0
    ΑΝ Χ<=0 ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ν>0 Ή Χ<=0 ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Ν<=0 Ή Χ>0 ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Λ=1 ΤΟΤΕ Β <-- Β+10
    ΑΛΛΙΩΣ_ΑΝ Λ=2 ΤΟΤΕ Β <-- Β+50
    ΑΛΛΙΩΣ_ΑΝ Λ=3 ΤΟΤΕ Β <-- Β+100
    ΤΕΛΟΣ_ΑΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Γράψτε μου καινούριες ιδέες για το πως να το αναβαθμίσω.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 02 Φεβ 2008 10:47 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
ΠΡΕΠΕΙ ΝΑ ΜΗΝ ΕΠΙΤΡΕΠΟΝΤΑΙ ΑΛΛΕΣ ΣΟΥΠΕΡ ΕΠΙΘΕΣΕΙΣ ΜΟΛΙΣ ΕΞΑΝΛΤΗΘΟΥΝ. (ΓΡΑΦΕΙ ΟΤΙ ΕΧΩ ΑΚΟΜΑ -10 ΕΠΙΘΕΣΕΙΣ!!! :D :D :D )

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Τετ 02 Απρ 2008 06:19 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ψ,Ω,Ν,Μ,Λ,Β,Π,Ι

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 3
      Β <-- Β+10
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 10
      Β <-- Β+50
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 20
      Β <-- 100
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '

      ΔΙΑΒΑΣΕ Π
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Ν <-- Ν+100
      Β <-- Β-100
    ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ψ <-- Ψ+5
      Β <-- Β-150
    ΤΕΛΟΣ_ΑΝ



    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Ι=0 ΤΟΤΕ ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΝΑΙ , ΔΕΝ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ SUPER ΕΠΙΘΕΣΕΙΣ'
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω

      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=1 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ψ=0 ΚΑΙ Ω=2 ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ=0 ΚΑΙ Ω=2 ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΚΑΙ Ω=2 ΤΟΤΕ
        Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ



      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ<=0 Ή Ν<=0



    ΑΝ Χ<=0 ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ν>0 Ή Χ<=0 ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Ν<=0 Ή Χ>0 ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Λ=1 ΤΟΤΕ Β <-- Β+10
    ΑΛΛΙΩΣ_ΑΝ Λ=2 ΤΟΤΕ Β <-- Β+50
    ΑΛΛΙΩΣ_ΑΝ Λ=3 ΤΟΤΕ Β <-- Β+100
    ΤΕΛΟΣ_ΑΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Ωρίστε και η λύση στο πρόβλημα σου φίλε DarkLord. Εκτιμώ πολύ τη βοήθεια σου. :D :D :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 03 Απρ 2008 06:53 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Δεν κάνει τίποτα. Βρήκα και ένα άλλο λαθάκι. Αν πας στο μαγαζί και πατήσεις να αγοράσεις χωρίς λεφτα τότε σου λεει να κανεις επίθεση... + Ορθογραφικό λάθος, λεει θες να επιτεθις στην γραμμη 57.
Γενικά, για να τεστάρεις ένα προγραμμα σου, καλό θα είναι να δοκιμάζεις ακραία πράγματα... Έτσι θα βρείς πιθανά λαθη που έχεις κάνει.

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Παρ 04 Απρ 2008 04:45 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ψ,Ω,Ν,Μ,Λ,Β,Π,Ι

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 3
      Β <-- Β+10
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 10
      Β <-- Β+50
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 20
      Β <-- 100
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '
      ΓΡΑΨΕ '0 ΓΙΑ ΝΑ ΒΓΕΙΣ ΑΠΟ ΤΟ ΜΑΓΑΖΙ'

      ΔΙΑΒΑΣΕ Π


      ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Ν <-- Ν+100
        Β <-- Β-100
        ΓΡΑΨΕ 'Η ΕΝΕΡΓΕΙΑ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 100'
      ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ψ <-- Ψ+5
        Β <-- Β-150
        ΓΡΑΨΕ 'Η ΕΠΙΘΕΣΗ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 5'
      ΑΛΛΙΩΣ_ΑΝ Π<>1 ΚΑΙ Π<>2 ΚΑΙ Π<>4 ΤΟΤΕ ΓΡΑΨΕ 'ΑΚΥΡΗ ΕΠΙΛΟΓΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

    ΟΣΟ Λ<>4 ΚΑΙ Χ>0 ΚΑΙ Ν>0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ι=0 ΤΟΤΕ ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΝΑΙ , ΔΕΝ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ SUPER ΕΠΙΘΕΣΕΙΣ'
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω

      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=1 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ψ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΚΑΙ Ω=2 ΤΟΤΕ
        Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Χ<=0 ΤΟΤΕ
        Χ <-- 0
      ΑΛΛΙΩΣ_ΑΝ Ν<=0 ΤΟΤΕ
        Ν <-- 0
      ΤΕΛΟΣ_ΑΝ


      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



    ΑΝ (Χ<=0 Ή Ν<=0) ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ ΜΑΧΗΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ  Ν<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Χ<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Λ=1 ΤΟΤΕ Β <-- Β+10
    ΑΛΛΙΩΣ_ΑΝ Λ=2 ΤΟΤΕ Β <-- Β+50
    ΑΛΛΙΩΣ_ΑΝ Λ=3 ΤΟΤΕ Β <-- Β+100
    ΤΕΛΟΣ_ΑΝ

  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



Ευχαριστώ και πάλι φίλε darklord.Το ορθογραφικό λάθος διορθώθηκε καθώς και το άλλο λάθος επίσης. :D :D :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Παρ 04 Απρ 2008 11:35 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Αψογος!!! :D

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 05 Απρ 2008 12:29 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Ευχαριστώ :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 06 Απρ 2008 01:09 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Μια τελική πρόταση για να γίνει ακόμα πιο καλο: βάλε την εντολή ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ μετά από κάθε διάβασε. :wink:

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 13 Απρ 2008 02:58 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ψ,Ω,Ν,Μ,Λ,Β,Π,Ι

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ


    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 3
      Β <-- Β+10
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 10
      Β <-- Β+50
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100
      Ψ <-- 5
      Ν <-- 100
      Μ <-- 20
      Β <-- 100
    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '
      ΓΡΑΨΕ '0 ΓΙΑ ΝΑ ΒΓΕΙΣ ΑΠΟ ΤΟ ΜΑΓΑΖΙ'

      ΔΙΑΒΑΣΕ Π


      ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Ν <-- Ν+100
        Β <-- Β-100
        ΓΡΑΨΕ 'Η ΕΝΕΡΓΕΙΑ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 100'
      ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ψ <-- Ψ+5
        Β <-- Β-150
        ΓΡΑΨΕ 'Η ΕΠΙΘΕΣΗ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 5'
      ΑΛΛΙΩΣ_ΑΝ Π<>1 ΚΑΙ Π<>2 ΚΑΙ Π<>4 ΤΟΤΕ ΓΡΑΨΕ 'ΑΚΥΡΗ ΕΠΙΛΟΓΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

    ΟΣΟ Λ<>4 ΚΑΙ Χ>0 ΚΑΙ Ν>0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ι=0 ΤΟΤΕ ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΝΑΙ , ΔΕΝ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ SUPER ΕΠΙΘΕΣΕΙΣ'
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω

      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (5)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=1 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΚΑΙ Π=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (10)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ψ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΚΑΙ Ω=2 ΤΟΤΕ
        Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Χ<=0 ΤΟΤΕ
        Χ <-- 0
      ΑΛΛΙΩΣ_ΑΝ Ν<=0 ΤΟΤΕ
        Ν <-- 0
      ΤΕΛΟΣ_ΑΝ


      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'


    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


    ΑΝ (Χ<=0 Ή Ν<=0) ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ ΜΑΧΗΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ  Ν<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Χ<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Λ=1 ΤΟΤΕ Β <-- Β+10
    ΑΛΛΙΩΣ_ΑΝ Λ=2 ΤΟΤΕ Β <-- Β+50
    ΑΛΛΙΩΣ_ΑΝ Λ=3 ΤΟΤΕ Β <-- Β+100
    ΤΕΛΟΣ_ΑΝ


  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Το έφτιαξα και αυτό.Αν μπορείς, πες καμία πρόσθετη λειτουργία να βάλλω.Ευχαριστώ. :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 13 Απρ 2008 09:56 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
OK! Λοιπόν μπορείς να βάλεις και αγορα αντικειμένων αλλα και ξορκιών στο μαγαζί και να βάλεις στον παικτη Mana Points τα οποία να γεμίζουν κάπως(+25 μετα απο καθε μαχη, +2 μετα από καθε επιθεση κτλ). Αμα σκεφτώ κατι άλλο θα σου πω!

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 14 Απρ 2008 03:13 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Θα πάρω υπ' όψη μου αυτά που μου είπες και θα το δοκιμάσω.
Ευχαριστώ :D :D :D :D :D


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Ιούλ 2008 11:37 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 19 Ιούλ 2008 11:29 am
Δημοσιεύσεις: 4
Μία μικρή παρατήρηση: όταν χάνεις από το δυσκολότερο αντίπαλο οι πόντοι σου γίνονται αυτόματα 200, είτε έχεις λιγότερους είτε περισσότερους. :D :shock: :lol: Δεν ξέρω εάν συμβαίνει κάτι παρόμοιο και με τους άλλους εχθρούς... ψάξε το λίγο... Τεσπα πολύ καλή δουλεια κατά τα άλλα :!: :!: :!:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 19 Ιούλ 2008 12:18 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ω,Ν,Μ,Λ,Β,Π,Ι
  ΑΚΕΡΑΙΕΣ: Ψ,Ξ,Φ
ΑΡΧΗ
  Ξ <-- 5
  Φ <-- 100
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ν <-- Φ
    ΑΝ (Χ<=0 Ή Ν<=0) ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ ΜΑΧΗΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ  Ν<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Χ<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ

    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50


      Μ <-- 3

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100


      Μ <-- 10

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100


      Μ <-- 20

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ 'ΠΑΤΑ'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '
      ΓΡΑΨΕ '3 ΓΙΑ ΤΟ ΞΥΦΟΣ REBEL ΠΟΥ ΣΟΥ ΔΙΝΕΙ 10 ΠΑΡΑΠΑΝΟ ΕΠΙΘΕΣΗ (ΧΡΕΙΑΖΕΣΑΙ 500 ΠΟΝΤΟΥΣ)'
      ΓΡΑΨΕ '4 ΓΙΑ ΝΑ ΠΑΡΕΙΣ ΤΗΝ ΠΑΝΟΠΛΙΑ FULL PLATE ΠΟΥ ΣΟΥ ΔΙΝΕΙ 250 ΕΝΕΡΓΕΙΑ (ΧΡΕΙΑΖΕΣΑΙ 400 ΠΟΝΤΟΥΣ)'

      ΓΡΑΨΕ '0 ΓΙΑ ΝΑ ΒΓΕΙΣ ΑΠΟ ΤΟ ΜΑΓΑΖΙ'

      ΔΙΑΒΑΣΕ Π


      ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Φ <-- Φ+100
        Β <-- Β-100
        ΓΡΑΨΕ 'Η ΕΝΕΡΓΕΙΑ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 100'
      ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ξ <-- Ξ+5
        Β <-- Β-150
        ΓΡΑΨΕ 'Η ΕΠΙΘΕΣΗ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 5'
      ΑΛΛΙΩΣ_ΑΝ Β>500 ΚΑΙ Π=3 ΤΟΤΕ Ξ <-- Ξ+10
      ΑΛΛΙΩΣ_ΑΝ Β>400 ΚΑΙ Π=4 ΤΟΤΕ Φ <-- Φ+250
      ΑΛΛΙΩΣ_ΑΝ Π<>1 ΚΑΙ Π<>2 ΚΑΙ Π<>3 ΚΑΙ Π<>4 ΤΟΤΕ ΓΡΑΨΕ 'ΑΚΥΡΗ ΕΠΙΛΟΓΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

    ΟΣΟ Λ<>4 ΚΑΙ Χ>0 ΚΑΙ Ν>0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ι=0 ΤΟΤΕ ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΝΑΙ , ΔΕΝ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ SUPER ΕΠΙΘΕΣΕΙΣ'
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω

      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ
      Ψ <-- Ξ
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΑΝ Ψ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΚΑΙ Ω=2 ΤΟΤΕ
        Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Χ<=0 ΤΟΤΕ
        Χ <-- 0
      ΑΛΛΙΩΣ_ΑΝ Ν<=0 ΤΟΤΕ
        Ν <-- 0
      ΤΕΛΟΣ_ΑΝ


      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'

      ΑΝ Χ=0 ΚΑΙ Λ=1 ΤΟΤΕ Β <-- Β+10
      ΑΛΛΙΩΣ_ΑΝ Χ=0 ΚΑΙ Λ=2 ΤΟΤΕ Β <-- Β+50
      ΑΛΛΙΩΣ_ΑΝ Χ=0 ΚΑΙ Λ=3 ΤΟΤΕ Β <-- Β+100
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ





  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                

Οριστε και ο νέος κώδικας. Το πρόβλημα που παρατήρησε ο φιλος μας ο σταύρος διορθώθηκε και έβαλα και 2 παραπάνω αντικείμενα στο μαγαζι. Επίσης απλούστευσα τον τρόπο υπολογισμού επίθεσης.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 21 Ιούλ 2008 12:55 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 19 Ιούλ 2008 11:29 am
Δημοσιεύσεις: 4
Φίλε Αλέξανδρε,

Ωραίος ο καινούργιος κώδικας. Μερικές συμβουλές για να διορθωθουν μερικά μικρά λαθακια που βρηκα στον τομέα του μαγαζιού:

:arrow: στο τελευταίο αλλιως αν του μαγαζιου βάλε εκτος απ' τα Π<>1 Π<>2 Π<>3 και Π<>4 και το Π<>0, γιατί όταν πατας 0 για έξοδο σου λέει ακυρη επιλογή :!:

:arrow: επίσης καλό θα ήταν να αφαιρει τους πόντους που χρεισιμοποιηθηκαν μετά την αγορά του σπαθιού και της πανοπλίας :wink: ( Β<-- Β-400 κλπ)

:arrow: θα μπορουσες να βάλεις να γραφει κάτι όταν αγοράζεις σπαθί ή πανοπλία

:arrow: (ορθογραφικό στο ξίφος)το παραπάνω γράφεται έτσι και όχι με ο

Αυτά για τώρα :!: Συνέχισε την καλή δουλειά σου :!: αν εντοπίσω αλλα προβλήματα θα σε ενημερώσω :!:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Μαχη με 3 τερατα v 2.0
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 21 Ιούλ 2008 01:37 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 17 Οκτ 2007 07:07 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σαλαμίνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ   BATTLE

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Χ,Ω,Ν,Μ,Λ,Β,Π,Ι
  ΑΚΕΡΑΙΕΣ: Ψ,Ξ,Φ
ΑΡΧΗ
  Ξ <-- 5
  Φ <-- 100
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ν <-- Φ
    ΑΝ (Χ<=0 Ή Ν<=0) ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΤΕΛΟΣ ΜΑΧΗΣ'
    ΤΕΛΟΣ_ΑΝ
    ΑΝ  Ν<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΣΕΣ'
    ΑΛΛΙΩΣ_ΑΝ Χ<0 ΚΑΙ (Λ=1 Ή Λ=2 Ή Λ=3) ΤΟΤΕ ΓΡΑΨΕ 'ΕΧΑΣΕΣ'
    ΤΕΛΟΣ_ΑΝ

    Ι <-- 5
    ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΑΝΤΙΠΑΛΟ 1 (ΕΥΚΟΛΟΣ) GREMLIN -10 ΒΑΘΜΟΙ , 2 (ΜΕΤΡΙΟΣ) WOLF -50 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ '3 (ΔΥΣΚΟΛΟ) ANTHARAS - 100 ΒΑΘΜΟΙ '
    ΓΡΑΨΕ 'ΟΙ ΒΑΘΜΟΙ ΣΟΥ ΕΙΝΑΙ'
    ΓΡΑΨΕ 'ΓΙΑ ΝΑ ΠΑΣ ΣΤΟ ΜΑΓΑΖΙ ΓΡΑΨΕ 4'
    ΔΙΑΒΑΣΕ Λ

    ΑΝ Λ=1 ΤΟΤΕ Χ <-- 50


      Μ <-- 3

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=2 ΤΟΤΕ Χ <-- 100


      Μ <-- 10

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=3 ΤΟΤΕ Χ <-- 100


      Μ <-- 20

    ΤΕΛΟΣ_ΑΝ

    ΑΝ Λ=4 ΤΟΤΕ
      ΓΡΑΨΕ 'ΤΙ ΑΝΑΒΑΘΜΙΣΗ ΘΕΛΕΙΣ?'
      ΓΡΑΨΕ 'ΠΑΤΑ'
      ΓΡΑΨΕ '1 ΕΝΕΡΓΙΑ 100 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +100 '
      ΓΡΑΨΕ '2 ΕΠΙΘΕΣΗ 150 ΠΟΝΤΟΙ ΑΠΑΡΑΙΤΗΤΟΙ +5 '
      ΓΡΑΨΕ '3 ΓΙΑ ΤΟ ΞΙΦΟΣ REBEL ΠΟΥ ΣΟΥ ΔΙΝΕΙ 10 ΠΑΡΑΠΑΝΟ ΕΠΙΘΕΣΗ (ΧΡΕΙΑΖΕΣΑΙ 500 ΠΟΝΤΟΥΣ)'
      ΓΡΑΨΕ '4 ΓΙΑ ΝΑ ΠΑΡΕΙΣ ΤΗΝ ΠΑΝΟΠΛΙΑ FULL PLATE ΠΟΥ ΣΟΥ ΔΙΝΕΙ 250 ΕΝΕΡΓΕΙΑ (ΧΡΕΙΑΖΕΣΑΙ 400 ΠΟΝΤΟΥΣ)'

      ΓΡΑΨΕ '0 ΓΙΑ ΝΑ ΒΓΕΙΣ ΑΠΟ ΤΟ ΜΑΓΑΖΙ'

      ΔΙΑΒΑΣΕ Π


      ΑΝ Π=1 ΚΑΙ Β>=100 ΤΟΤΕ Φ <-- Φ+100
        Β <-- Β-100
        ΓΡΑΨΕ 'Η ΕΝΕΡΓΕΙΑ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 100'
      ΑΛΛΙΩΣ_ΑΝ Π=2 ΚΑΙ Β>=150 ΤΟΤΕ Ξ <-- Ξ+5
        Β <-- Β-150
        ΓΡΑΨΕ 'Η ΕΠΙΘΕΣΗ ΣΟΥ ΑΥΞΗΘΗΚΕ ΚΑΤΑ 5'
      ΑΛΛΙΩΣ_ΑΝ Β>500 ΚΑΙ Π=3 ΤΟΤΕ Ξ <-- Ξ+10 ΚΑΙ Β <-- Β-500
      ΓΡΑΨΕ 'ΤΟ ΣΠΑΘΙ ΣΕ ΚΑΝΕΙ ΠΙΟ ΔΥΝΑΤΟ Η ΕΠΙΘΕΣΗ ΣΟΥ ΑΝΕΒΑΙΝΕΙ ΚΑΤΑ 10'
      ΑΛΛΙΩΣ_ΑΝ Β>400 ΚΑΙ Π=4 ΤΟΤΕ Φ <-- Φ+250 ΚΑΙ Β <-- Β-400
      ΓΡΑΨΕ 'Η ΠΑΝΟΠΛΙΑ ΣΟΥ ΑΝΕΒΑΣΕ ΤΗΝ ΕΝΕΡΓΕΙΑ ΚΑΤΑ 250'
      ΑΛΛΙΩΣ_ΑΝ Π<>1 ΚΑΙ Π<>2 ΚΑΙ Π<>3 ΚΑΙ Π<>4 ΚΑΙ Π<>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΚΥΡΗ ΕΠΙΛΟΓΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

    ΟΣΟ Λ<>4 ΚΑΙ Χ>0 ΚΑΙ Ν>0 ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ι=0 ΤΟΤΕ ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΝΑΙ , ΔΕΝ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ SUPER ΕΠΙΘΕΣΕΙΣ'
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΕΣ ΝΑ ΕΠΙΤΕΘΕΙΣ 1 ΓΙΑ ΝΑΙ, 2 ΓΙΑ SUPER ΕΠΙΘΕΣΗ ΜΠΟΡΕΙΣ ΝΑ ΚΑΝΕΙΣ ΑΛΛΕΣ ',Ι,' SUPER ΕΠΙΘΕΣΕΙΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_'0 ΓΙΑ ΕΞΟΔΟ'
      ΔΙΑΒΑΣΕ Ω
       Ψ <-- Ξ
      ΑΝ Λ=1 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (3)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=2 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (10)
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Λ=3 ΤΟΤΕ Ψ <-- ΤΥΧΑΙΟΣ (Ψ)
        Μ <-- ΤΥΧΑΙΟΣ (20)
      ΤΕΛΟΣ_ΑΝ

      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΑΝ Ψ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'ΑΣΤΟΧΗΣΕΣ'
      ΑΛΛΙΩΣ_ΑΝ Μ<=0 ΚΑΙ (Ω=2 Ή Ω=1) ΚΑΙ Ι>0 ΤΟΤΕ ΓΡΑΨΕ 'Ο ΕΧΘΡΟΣ ΑΣΤΟΧΗΣΕ'
      ΤΕΛΟΣ_ΑΝ

      ΑΝ Ω=1 ΤΟΤΕ Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
      ΑΛΛΙΩΣ_ΑΝ Ω=0 ΤΟΤΕ ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
      ΑΛΛΙΩΣ_ΑΝ Ι>0 ΚΑΙ Ω=2 ΤΟΤΕ
        Ψ <--  Ψ*2
        Χ <-- Χ-Ψ
        Ν <-- Ν-Μ
        Ι <-- Ι-1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Χ<=0 ΤΟΤΕ
        Χ <-- 0
      ΑΛΛΙΩΣ_ΑΝ Ν<=0 ΤΟΤΕ
        Ν <-- 0
      ΤΕΛΟΣ_ΑΝ


      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΤΟΥ ΑΝΤΙΠΑΛΟΥ ΕΙΝΑΙ'
      ΓΡΑΨΕ 'Η ΕΝΕΡΓΙΑ ΣΟΥ ΕΙΝΑΙ'

      ΑΝ Χ=0 ΚΑΙ Λ=1 ΤΟΤΕ Β <-- Β+10
      ΑΛΛΙΩΣ_ΑΝ Χ=0 ΚΑΙ Λ=2 ΤΟΤΕ Β <-- Β+50
      ΑΛΛΙΩΣ_ΑΝ Χ=0 ΚΑΙ Λ=3 ΤΟΤΕ Β <-- Β+100
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ





  ΜΕΧΡΙΣ_ΟΤΟΥ Λ=0

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Τα λαθάκια διορθώθηκαν και επίσης ένα λάθος ακόμα.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 18 Δημοσιεύσεις ]  Μετάβαση στην σελίδα 1, 2  Επόμενο

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters