Τώρα είναι Πέμ 27 Φεβ 2020 08:01 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΠΑΙΧΝΙΔΙ ΤΡΙΛΙΖΑ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 02 Μάιος 2003 11:34 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Το παιχνίδι αυτό σας το χαρίζω και σας προτρέπω να το φτιάξετε με λογική. Προς το παρόν παίζει χαζά (γι' αυτό και μπορούμε να το κερδίσουμε!)

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΡΙΛΙΖΑ01
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[9], ΣΕΙΡΑ, ΘΕΣΗ, ΜΕΤΡΗΜΑ
  ΑΚΕΡΑΙΕΣ:  ΑΡΧΙΚΟ, ΝΕΟ, ΑΠ, Ι, ΣΚΟΡ_ΠΑΙΚΤΗ, ΣΚΟΡ_ΥΠ

ΑΡΧΗ
  ΑΡΧΙΚΟ <-- 12123
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
      Α[Ι] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΡΑΨΕ '********** ΤΡΙΛΙΖΑ ***********'
    ΓΡΑΨΕ 'ΣΚΟΡ ΠΑΙΚΤΗ-ΥΠΟΛΟΓΙΣΤΗ '
    ΓΡΑΨΕ '     (',ΣΚΟΡ_ΠΑΙΚΤΗ,'-',ΣΚΟΡ_ΥΠ,')'
    ΜΕΤΡΗΜΑ <-- 0
    ΑΝ ΝΑΙ('ΘΑ ΠΑΙΞΩ ΠΡΩΤΟΣ;') ΤΟΤΕ
      ΚΑΛΕΣΕ ΤΥΧΑΙΟΣ(ΑΡΧΙΚΟ, ΝΕΟ)
      ΑΠ <-- (ΝΕΟ MOD 9) +1
      Α[ΑΠ] <-- -1
      ΜΕΤΡΗΜΑ <-- ΜΕΤΡΗΜΑ+1
    ΤΕΛΟΣ_ΑΝ
    ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ(Α)
    ΟΣΟ (ΜΕΤΡΗΜΑ<9) ΚΑΙ ΝΑΙ('ΘΕΣ ΝΑ ΣΥΝΕΧΙΣΕΙΣ;')  ΕΠΑΝΑΛΑΒΕ
      ΚΑΛΕΣΕ ΤΥΧΑΙΟΣ(ΑΡΧΙΚΟ, ΝΕΟ)
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΘΕΣΗ <-- ΠΑΙΚΤΗΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ Α[ΘΕΣΗ]=0
      ΝΕΟ <-- ΝΕΟ+ΘΕΣΗ
      ΓΡΑΨΕ 'ΟΚ'
      ΜΕΤΡΗΜΑ <-- ΜΕΤΡΗΜΑ+1
      Α[ΘΕΣΗ] <-- 1
      ΑΝ ΚΕΡΔΙΖΕΙ(Α,1) ΤΟΤΕ
        ΜΕΤΡΗΜΑ <-- 10
        ΓΡΑΨΕ '******** ΚΕΡΔΙΣΕΣ *********'
        ΣΚΟΡ_ΠΑΙΚΤΗ <-- ΣΚΟΡ_ΠΑΙΚΤΗ+1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΜΕΤΡΗΜΑ<9 ΤΟΤΕ      
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΚΑΛΕΣΕ ΤΥΧΑΙΟΣ(ΑΡΧΙΚΟ, ΝΕΟ)
          ΑΠ <-- (ΝΕΟ MOD 9) +1
        ΜΕΧΡΙΣ_ΟΤΟΥ Α[ΑΠ]=0
        ΜΕΤΡΗΜΑ <-- ΜΕΤΡΗΜΑ+1
        Α[ΑΠ] <-- -1
      ΤΕΛΟΣ_ΑΝ

      ΚΑΛΕΣΕ ΑΝΑΝΕΩΣΗ(Α)
      ΑΝ ΚΕΡΔΙΖΕΙ(Α, -1) ΤΟΤΕ
        ΜΕΤΡΗΜΑ <-- 10
        ΓΡΑΨΕ '********* ΚΕΡΔΙΣΑ *********'
        ΣΚΟΡ_ΥΠ <-- ΣΚΟΡ_ΥΠ +1

      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΧΙ ΝΑΙ('ΘΕΛΕΙΣ ΝΑ ΞΑΝΑΠΑΙΞΟΥΜΕ;')

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΤΥΧΑΙΟΣ(Α,Ν)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α, Ν
ΑΡΧΗ
  Ν <-- N + Α DIV 123
  Α <-- Ν + Α MOD 13031
  Ν <-- (Ν MOD 100)*100+(N DIV 100) MOD 100
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΣΗΜΕΙΟ(Τ): ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Τ
ΑΡΧΗ
  ΑΝ Τ=0 ΤΟΤΕ
    ΣΗΜΕΙΟ <-- ' '
  ΑΛΛΙΩΣ_ΑΝ Τ<0 ΤΟΤΕ
    ΣΗΜΕΙΟ <-- 'Χ'
  ΑΛΛΙΩΣ
    ΣΗΜΕΙΟ <-- 'Ο'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΝΑΝΕΩΣΗ(Κ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Κ[9]
ΑΡΧΗ
  ΓΡΑΨΕ ' 1 2 3'
  ΓΡΑΨΕ '1',ΣΗΜΕΙΟ(Κ[1]),'|', ΣΗΜΕΙΟ(Κ[2]),'|',ΣΗΜΕΙΟ(Κ[3])
  ΓΡΑΨΕ ' -+-+-'
  ΓΡΑΨΕ '2',ΣΗΜΕΙΟ(Κ[4]),'|', ΣΗΜΕΙΟ(Κ[5]),'|',ΣΗΜΕΙΟ(Κ[6])
  ΓΡΑΨΕ '-+-+-'
  ΓΡΑΨΕ '3',ΣΗΜΕΙΟ(Κ[7]),'|', ΣΗΜΕΙΟ(Κ[8]),'|',ΣΗΜΕΙΟ(Κ[9])
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ Ε(ΚΚ, Μ,Ν,Ξ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΚ[9], Μ, Ν, Ξ
ΑΡΧΗ
  Ε <-- ΚΚ[Μ]+ΚΚ[Ν]+ΚΚ[Ξ]
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΚΕΡΔΙΖΕΙ(Κ, ΧΟ):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Κ[9], ΟΧΟ, ΧΟ
  ΛΟΓΙΚΕΣ: Ζ1,Ζ2,Ζ3
ΑΡΧΗ
  ΟΧΟ <-- 3*ΧΟ
  Ζ1 <-- (Ε(Κ,1,2,3)=ΟΧΟ) Ή (Ε(Κ,4,5,6)=ΟΧΟ) Ή (Ε(Κ,7,8,9)=ΟΧΟ)
  Ζ2 <-- (Ε(Κ,1,4,7)=ΟΧΟ) Ή (Ε(Κ,2,5,8)=ΟΧΟ) Ή (Ε(Κ,3,6,9)=ΟΧΟ)
  Ζ3 <-- (Ε(Κ,1,5,9)=ΟΧΟ) Ή (Ε(Κ,3,5,7)=ΟΧΟ)

  ΑΝ Ζ1 Ή Ζ2 Ή Ζ3 ΤΟΤΕ
    ΚΕΡΔΙΖΕΙ <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
    ΚΕΡΔΙΖΕΙ <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΝΑΙ(ΕΜΦΑΝΙΣΗ) :ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΜΦΑΝΙΣΗ, ΝΝ
  ΛΟΓΙΚΕΣ: ΟΚ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΕΜΦΑΝΙΣΗ,'(Ν/Ο)'
    ΔΙΑΒΑΣΕ ΝΝ
    ΟΚ <-- ΨΕΥΔΗΣ
    ΑΝ (ΝΝ='N') Ή (ΝΝ='Ν') ΤΟΤΕ
      ΝΑΙ <-- ΑΛΗΘΗΣ
      ΟΚ <-- ΑΛΗΘΗΣ
    ΑΛΛΙΩΣ_ΑΝ (ΝΝ='O') Ή (ΝΝ='Ο') ΤΟΤΕ
      ΝΑΙ <-- ΨΕΥΔΗΣ
      ΟΚ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΟΚ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΕΙΣΑΓΩΓΗ_ΑΚ(ΕΜΦΑΝΙΣΗ, ΚΑΤΩ_ΟΡΙΟ, ΠΑΝΩ_ΟΡΙΟ) :ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΕΜΦΑΝΙΣΗ
  ΑΚΕΡΑΙΕΣ: ΚΑΤΩ_ΟΡΙΟ, ΠΑΝΩ_ΟΡΙΟ, ΑΡΧΙΚΗ
ΑΡΧΗ
  ΑΡΧΙΚΗ <-- ΚΑΤΩ_ΟΡΙΟ-1
  ΟΣΟ (ΑΡΧΙΚΗ<ΚΑΤΩ_ΟΡΙΟ) Ή (ΑΡΧΙΚΗ>ΠΑΝΩ_ΟΡΙΟ) ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ ΕΜΦΑΝΙΣΗ
    ΔΙΑΒΑΣΕ ΑΡΧΙΚΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΕΙΣΑΓΩΓΗ_ΑΚ <-- ΑΡΧΙΚΗ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΠΑΙΚΤΗΣ: ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΣΕΙΡΑ, ΣΤΗΛΗ
ΑΡΧΗ
  ΣΕΙΡΑ <-- ΕΙΣΑΓΩΓΗ_ΑΚ('ΔΩΣΕ ΣΕΙΡΑ',1,3)
  ΣΤΗΛΗ <-- ΕΙΣΑΓΩΓΗ_ΑΚ('ΔΩΣΕ ΣΤΗΛΗ',1,3)
  ΠΑΙΚΤΗΣ <-- ΣΤΗΛΗ+(ΣΕΙΡΑ-1)*3
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΠΑΙΧΝΙΔΙ ΤΡΙΛΙΖΑ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 29 Ιούλ 2008 04:18 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 22 Απρ 2008 02:55 pm
Δημοσιεύσεις: 12
Μια αποπειρα για να αποκτησει λογικη


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΡΙΛΙΖ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,ΦΟΡΕΣ,ΝΙΚ,ΗΤΤ,ΙΣΟΠ
  ΧΑΡΑΚΤΗΡΕΣ:Θ[9],Χ,ΝΙΚΗ,Τ
ΑΡΧΗ
  ΝΙΚ <-- 0
  ΗΤΤ <-- 0
  ΙΣΟΠ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '1.Αν θες να παιξεις πρωτος'
    ΓΡΑΨΕ '2.Αν οχι'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ Τ
    ΜΕΧΡΙΣ_ΟΤΟΥ Τ='1' Η Τ='2'
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΑΝ Τ='1' ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
        ΠΗΓΑΙΝΕ_ΧΥ 65,4
        ΓΡΑΨΕ 'Νικες:    ',ΝΙΚ
        ΠΗΓΑΙΝΕ_ΧΥ 65,5
        ΓΡΑΨΕ 'Ηττες:    ',ΗΤΤ
        ΠΗΓΑΙΝΕ_ΧΥ 65,6
        ΓΡΑΨΕ 'Ισοπαλιες:',ΙΣΟΠ
        ΦΟΡΕΣ <-- 0
        ΚΑΛΕΣΕ ΠΛΑΙΣΙΟ
        ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
          Θ[Ι] <-- 'Κ'
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 1,24
          ΓΡΑΨΕ 'Θεση:'
          ΠΗΓΑΙΝΕ_ΧΥ 7,24
          ΓΡΑΨΕ '                                                     '
          ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΠΗΓΑΙΝΕ_ΧΥ 7,24
              ΔΙΑΒΑΣΕ Χ
              ΠΗΓΑΙΝΕ_ΧΥ 7,24
              ΓΡΑΨΕ '                                            '
              ΠΗΓΑΙΝΕ_ΧΥ 7,24
              ΓΡΑΨΕ '    '
              ΠΗΓΑΙΝΕ_ΧΥ 7,24
              ΑΝ ΟΧΙ(Χ='Α1' Η Χ='Α2' Η Χ='Α3' Η Χ='Β1' Η Χ='Β2' Η Χ='Β3' Η Χ='Γ1' Η Χ='Γ2' Η Χ='Γ3') ΤΟΤΕ
                ΠΗΓΑΙΝΕ_ΧΥ 20,24
                ΓΡΑΨΕ 'Δεν υπαρχει τετοια θεση!'
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Χ='Α1' Η Χ='Α2' Η Χ='Α3' Η Χ='Β1' Η Χ='Β2' Η Χ='Β3' Η Χ='Γ1' Η Χ='Γ2' Η Χ='Γ3'
            Ι <-- ΘΕΣΗ(Χ)
            ΑΝ Θ[Ι]<>'Κ' ΤΟΤΕ
              ΠΗΓΑΙΝΕ_ΧΥ 12,24
              ΓΡΑΨΕ '                     '
              ΠΗΓΑΙΝΕ_ΧΥ 12,24
              ΓΡΑΨΕ 'Η θεση ειναι πιασμενη'
            ΤΕΛΟΣ_ΑΝ
          ΜΕΧΡΙΣ_ΟΤΟΥ Θ[Ι]='Κ'
          ΦΟΡΕΣ <-- ΦΟΡΕΣ+1
          Θ[Ι] <-- 'Χ'
          ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
          ΚΑΛΕΣΕ ΕΜΦΑΝΙΣΗ(Θ)
          ΑΝ ΝΙΚΗ='Κ' ΚΑΙ ΦΟΡΕΣ<5 ΤΟΤΕ
            Ι <-- ΠΙΣΙ(Θ)
            Θ[Ι] <-- 'Ο'
            ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
            ΚΑΛΕΣΕ ΕΜΦΑΝΙΣΗ(Θ)
          ΤΕΛΟΣ_ΑΝ
        ΜΕΧΡΙΣ_ΟΤΟΥ ΝΙΚΗ<>'Κ' Η ΦΟΡΕΣ=5
        ΑΝ ΝΙΚΗ<>'Κ' ΤΟΤΕ
          ΠΗΓΑΙΝΕ_ΧΥ 1,24
          ΓΡΑΨΕ 'Νικησαν  τα "',ΝΙΚΗ,'"'
          ΑΝ ΝΙΚΗ='Χ' ΤΟΤΕ
            ΝΙΚ <-- ΝΙΚ+1
          ΑΛΛΙΩΣ
            ΗΤΤ <-- ΗΤΤ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΙΣΟΠ <-- ΙΣΟΠ+1
        ΤΕΛΟΣ_ΑΝ
        ΠΗΓΑΙΝΕ_ΧΥ 1,26
        ΓΡΑΨΕ 'Enter για συνεχεια'
        ΠΗΓΑΙΝΕ_ΧΥ 65,3
        ΓΡΑΨΕ 'Νικες:    ',ΝΙΚ
        ΠΗΓΑΙΝΕ_ΧΥ 65,4
        ΓΡΑΨΕ 'Ηττες:    ',ΗΤΤ
        ΠΗΓΑΙΝΕ_ΧΥ 65,5
        ΓΡΑΨΕ 'Ισοπαλιες:',ΙΣΟΠ
        ΔΙΑΒΑΣΕ Τ
      ΜΕΧΡΙΣ_ΟΤΟΥ Τ='ΤΕΛΟΣ' Η Τ='ΜΕΝΟΥ'
    ΑΛΛΙΩΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
        ΠΗΓΑΙΝΕ_ΧΥ 65,4
        ΓΡΑΨΕ 'Νικες:    ',ΝΙΚ
        ΠΗΓΑΙΝΕ_ΧΥ 65,5
        ΓΡΑΨΕ 'Ηττες:    ',ΗΤΤ
        ΠΗΓΑΙΝΕ_ΧΥ 65,6
        ΓΡΑΨΕ 'Ισοπαλιες:',ΙΣΟΠ
        ΦΟΡΕΣ <-- 0
        ΚΑΛΕΣΕ ΠΛΑΙΣΙΟ
        ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 9
          Θ[Ι] <-- 'Κ'
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΠΗΓΑΙΝΕ_ΧΥ 1,24
          ΓΡΑΨΕ 'Θεση:'
          ΠΗΓΑΙΝΕ_ΧΥ 7,24
          ΓΡΑΨΕ '                                                     '
          Ι <-- ΠΙΣΙ(Θ)
          ΦΟΡΕΣ <-- ΦΟΡΕΣ+1
          Θ[Ι] <-- 'Ο'
          ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
          ΚΑΛΕΣΕ ΕΜΦΑΝΙΣΗ(Θ)
          ΑΝ ΝΙΚΗ='Κ' ΚΑΙ ΦΟΡΕΣ<5 ΤΟΤΕ
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                ΠΗΓΑΙΝΕ_ΧΥ 7,24
                ΔΙΑΒΑΣΕ Χ
                ΠΗΓΑΙΝΕ_ΧΥ 7,24
                ΓΡΑΨΕ '                                            '
                ΠΗΓΑΙΝΕ_ΧΥ 7,24
                ΓΡΑΨΕ '    '
                ΠΗΓΑΙΝΕ_ΧΥ 7,24
                ΑΝ ΟΧΙ(Χ='Α1' Η Χ='Α2' Η Χ='Α3' Η Χ='Β1' Η Χ='Β2' Η Χ='Β3' Η Χ='Γ1' Η Χ='Γ2' Η Χ='Γ3') ΤΟΤΕ
                  ΠΗΓΑΙΝΕ_ΧΥ 20,24
                  ΓΡΑΨΕ 'Δεν υπαρχει τετοια θεση!'
                ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ Χ='Α1' Η Χ='Α2' Η Χ='Α3' Η Χ='Β1' Η Χ='Β2' Η Χ='Β3' Η Χ='Γ1' Η Χ='Γ2' Η Χ='Γ3'
              Ι <-- ΘΕΣΗ(Χ)
              ΑΝ Θ[Ι]<>'Κ' ΤΟΤΕ
                ΠΗΓΑΙΝΕ_ΧΥ 12,24
                ΓΡΑΨΕ '                     '
                ΠΗΓΑΙΝΕ_ΧΥ 12,24
                ΓΡΑΨΕ 'Η θεση ειναι πιασμενη'
              ΤΕΛΟΣ_ΑΝ
            ΜΕΧΡΙΣ_ΟΤΟΥ Θ[Ι]='Κ'
            Θ[Ι] <-- 'Χ'
            ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
            ΚΑΛΕΣΕ ΕΜΦΑΝΙΣΗ(Θ)
          ΤΕΛΟΣ_ΑΝ
        ΜΕΧΡΙΣ_ΟΤΟΥ ΝΙΚΗ<>'Κ' Η ΦΟΡΕΣ=5
        ΑΝ ΝΙΚΗ<>'Κ' ΤΟΤΕ
          ΠΗΓΑΙΝΕ_ΧΥ 1,24
          ΓΡΑΨΕ 'Νικησαν  τα "',ΝΙΚΗ,'"'
          ΑΝ ΝΙΚΗ='Χ' ΤΟΤΕ
            ΝΙΚ <-- ΝΙΚ+1
          ΑΛΛΙΩΣ
            ΗΤΤ <-- ΗΤΤ+1
          ΤΕΛΟΣ_ΑΝ
        ΑΛΛΙΩΣ
          ΙΣΟΠ <-- ΙΣΟΠ+1
        ΤΕΛΟΣ_ΑΝ
        ΠΗΓΑΙΝΕ_ΧΥ 1,26
        ΓΡΑΨΕ 'Enter για συνεχεια'
        ΠΗΓΑΙΝΕ_ΧΥ 65,3
        ΓΡΑΨΕ 'Νικες:    ',ΝΙΚ
        ΠΗΓΑΙΝΕ_ΧΥ 65,4
        ΓΡΑΨΕ 'Ηττες:    ',ΗΤΤ
        ΠΗΓΑΙΝΕ_ΧΥ 65,5
        ΓΡΑΨΕ 'Ισοπαλιες:',ΙΣΟΠ
        ΔΙΑΒΑΣΕ Τ
      ΜΕΧΡΙΣ_ΟΤΟΥ Τ='ΤΕΛΟΣ' Η Τ='ΜΕΝΟΥ'
    ΤΕΛΟΣ_ΑΝ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ Τ='ΤΕΛΟΣ'
  ΚΛΕΙΣΕ_ΠΑΡΑΘΥΡΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ ΠΛΑΙΣΙΟ
ΑΡΧΗ
  ΠΗΓΑΙΝΕ_ΧΥ 1,2
  ΓΡΑΨΕ '                   1               2                3        '
  ΓΡΑΨΕ '           %%%%%%%%%%%%%%%+%%%%%%%%%%%%%%%%%+%%%%%%%%%%%%%%%%'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '      Α    %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %--------------+-----------------+---------------%'
  ΓΡΑΨΕ '           %--------------+-----------------+---------------%'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '      Β    %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %--------------+-----------------+---------------%'
  ΓΡΑΨΕ '           %--------------+-----------------+---------------%'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '      Γ    %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %              |                 |               %'
  ΓΡΑΨΕ '           %%%%%%%%%%%%%%%+%%%%%%%%%%%%%%%%%+%%%%%%%%%%%%%%%%'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


ΣΥΝΑΡΤΗΣΗ ΘΕΣΗ(Χ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ
ΑΡΧΗ
  ΑΝ Χ='Α1' ΤΟΤΕ
    Ι <-- 1
  ΑΛΛΙΩΣ_ΑΝ Χ='Α2' ΤΟΤΕ
    Ι <-- 2
  ΑΛΛΙΩΣ_ΑΝ Χ='Α3' ΤΟΤΕ
    Ι <-- 3
  ΑΛΛΙΩΣ_ΑΝ Χ='Β1' ΤΟΤΕ
    Ι <-- 4
  ΑΛΛΙΩΣ_ΑΝ Χ='Β2' ΤΟΤΕ
    Ι <-- 5
  ΑΛΛΙΩΣ_ΑΝ Χ='Β3' ΤΟΤΕ
    Ι <-- 6
  ΑΛΛΙΩΣ_ΑΝ Χ='Γ1' ΤΟΤΕ
    Ι <-- 7
  ΑΛΛΙΩΣ_ΑΝ Χ='Γ2' ΤΟΤΕ
    Ι <-- 8
  ΑΛΛΙΩΣ_ΑΝ Χ='Γ3' ΤΟΤΕ
    Ι <-- 9
  ΤΕΛΟΣ_ΑΝ
  ΘΕΣΗ <-- Ι
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΔΙΑΔΙΚΑΣΙΑ ΕΜΦΑΝΙΣΗ(Θ)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Χ,Π,Θ[9]
  ΑΚΕΡΑΙΕΣ:Κ,Ι,ΕΠ
ΑΡΧΗ
  ΓΙΑ ΕΠ ΑΠΟ 1 ΜΕΧΡΙ 9
    Κ <-- 0
    Ι <-- 0
    ΑΝ ΕΠ>=1 ΚΑΙ ΕΠ<=3 ΤΟΤΕ
      Ι <-- 4
    ΑΛΛΙΩΣ_ΑΝ ΕΠ>=4 ΚΑΙ ΕΠ<=6 ΤΟΤΕ
      Ι <-- 11
    ΑΛΛΙΩΣ
      Ι <-- 18
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΕΠ=1 Η ΕΠ=4 Η ΕΠ=7 ΤΟΤΕ
      Κ <-- 13
    ΑΛΛΙΩΣ_ΑΝ ΕΠ=2 Η ΕΠ=5 Η ΕΠ=8 ΤΟΤΕ
      Κ <-- 29
    ΑΛΛΙΩΣ_ΑΝ ΕΠ=3 Η ΕΠ=6 Η ΕΠ=9 ΤΟΤΕ
      Κ <-- 46
    ΤΕΛΟΣ_ΑΝ
    ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι
    ΑΝ Θ[ΕΠ]='Χ' ΤΟΤΕ
      ΓΡΑΨΕ ' Χ          Χ'
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+1
      ΓΡΑΨΕ '   Χ     Χ   '
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+2
      ΓΡΑΨΕ '      Χ      '
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+3
      ΓΡΑΨΕ '    Χ    Χ   '
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+4
      ΓΡΑΨΕ ' Χ          Χ'
    ΑΛΛΙΩΣ_ΑΝ Θ[ΕΠ]='Ο' ΤΟΤΕ
      ΓΡΑΨΕ '      Ο '
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+1
      ΓΡΑΨΕ '  Ο      Ο '
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+2
      ΓΡΑΨΕ 'Ο           Ο'
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+3
      ΓΡΑΨΕ '  Ο       Ο'
      ΠΗΓΑΙΝΕ_ΧΥ Κ,Ι+4
      ΓΡΑΨΕ '      Ο'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ



ΣΥΝΑΡΤΗΣΗ ΠΟΙΟΣ(Θ):ΧΑΡΑΚΤΗΡΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Θ[9]
  ΑΚΕΡΑΙΕΣ:Ι
ΑΡΧΗ
  ΠΟΙΟΣ <-- 'Κ'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7 ΜΕ ΒΗΜΑ 3
    ΑΝ Θ[Ι]=Θ[Ι+1] ΚΑΙ Θ[Ι+1]=Θ[Ι+2] ΚΑΙ Θ[Ι]<>'Κ' ΤΟΤΕ
      ΠΟΙΟΣ <-- Θ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Θ[1]=Θ[5] ΚΑΙ Θ[5]=Θ[9] ΚΑΙ Θ[1]<>'Κ' ΤΟΤΕ
    ΠΟΙΟΣ <-- Θ[1]
  ΑΛΛΙΩΣ_ΑΝ Θ[3]=Θ[5] ΚΑΙ Θ[5]=Θ[7] ΚΑΙ Θ[3]<>'Κ' ΤΟΤΕ
    ΠΟΙΟΣ <-- Θ[3]
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΑΝ Θ[Ι]=Θ[Ι+3] ΚΑΙ Θ[Ι+3]=Θ[Ι+6] ΚΑΙ Θ[Ι]<>'Κ' ΤΟΤΕ
      ΠΟΙΟΣ <-- Θ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΣΥΝΑΡΤΗΣΗ ΠΙΣΙ(Θ):ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,ΠΡ
  ΧΑΡΑΚΤΗΡΕΣ:Θ[9],ΝΙΚΗ
  ΛΟΓΙΚΕΣ:ΒΡ
ΑΡΧΗ
!ΜΗΠΩΣ ΝΙΚΑΕΙ
  ΠΡ <-- 0
  Ι <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι+1
    ΒΡ <-- Α_Ψ1(Θ,Ι)
    ΑΝ ΒΡ=ΑΛΗΘΗΣ ΤΟΤΕ
      ΠΡ <-- Ι
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΒΡ=ΑΛΗΘΗΣ Η Ι=9
!ΜΗΠΩΣ ΧΑΝΕΙ
  ΑΝ ΠΡ=0 ΤΟΤΕ
    ΠΡ <-- 0
    Ι <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Ι <-- Ι+1
      ΒΡ <-- Α_Ψ2(Θ,Ι)
      ΑΝ ΒΡ=ΑΛΗΘΗΣ ΤΟΤΕ
        ΠΡ <-- Ι
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΒΡ=ΑΛΗΘΗΣ Η Ι=9
  ΤΕΛΟΣ_ΑΝ
  Ι <-- 0
  ΑΝ ΠΡ=0 ΤΟΤΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΠΡ <-- ΤΥΧΑΙΟΣ(9)
      ΜΕΧΡΙΣ_ΟΤΟΥ ΠΡ<>0
      Ι <-- Ι+1
    ΜΕΧΡΙΣ_ΟΤΟΥ Θ[ΠΡ]='Κ' Η Ι=100 ! Ναι ειναι λιγο μπακαλιστικο . . . :Ρ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Ι=100 ΤΟΤΕ
    ΠΡ <-- 9
  ΤΕΛΟΣ_ΑΝ
  ΠΙΣΙ <-- ΠΡ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ



ΣΥΝΑΡΤΗΣΗ Α_Ψ2(Θ,Ι):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι
  ΛΟΓΙΚΕΣ:ΠΡ
  ΧΑΡΑΚΤΗΡΕΣ:Θ[9],ΝΙΚΗ
ΑΡΧΗ
  ΠΡ <-- ΨΕΥΔΗΣ
  ΑΝ Θ[Ι]='Κ' ΤΟΤΕ
    Θ[Ι] <-- 'Χ'
    ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
    ΑΝ ΝΙΚΗ='Χ' ΤΟΤΕ
      ΠΡ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  Α_Ψ2 <-- ΠΡ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ Α_Ψ1(Θ,Ι):ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι
  ΛΟΓΙΚΕΣ:ΠΡ
  ΧΑΡΑΚΤΗΡΕΣ:Θ[9],ΝΙΚΗ
ΑΡΧΗ
  ΠΡ <-- ΨΕΥΔΗΣ
  ΑΝ Θ[Ι]='Κ' ΤΟΤΕ
    Θ[Ι] <-- 'Ο'
    ΝΙΚΗ <-- ΠΟΙΟΣ(Θ)
    ΑΝ ΝΙΚΗ='Ο' ΤΟΤΕ
      ΠΡ <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  Α_Ψ1 <-- ΠΡ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters