Τώρα είναι Τετ 03 Ιουν 2020 06:40 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Το πρώτο μου πρόγραμμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 14 Ιουν 2008 01:32 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 14 Ιουν 2008 01:13 pm
Δημοσιεύσεις: 1
Το πρώτο μου πρόγραμμα. Κρατάει στατιστικά για ένα παιχνίδι. Μερικά στοιχεία του κώδικα είναι κλεμμένα :oops: (δεν μετανιώνω για τίποτα) απο το πρόγραμμα του τηλεφωνικού καταλόγου.
Syntax: [ Download ] [ Hide ]
!---------------------------------------Spectre~Shadows-----------------------------------------!
ΠΡΟΓΡΑΜΜΑ DotAStats
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: choice
  ΑΡΧΕΙΑ ΑΚΕΡΑΙΩΝ: wins,losses,kills,deaths,assists,games
  ΑΡΧΕΙΑ ΧΑΡΑΚΤΗΡΩΝ: acc
!---------------------------------------Spectre~Shadows-----------------------------------------!
ΑΡΧΗ
                                         ! Files !
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ wins, 'C:\D-S\wins.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ losses, 'C:\D-S\losses.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ kills, 'C:\D-S\kills.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ deaths, 'C:\D-S\deaths.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ assists, 'C:\D-S\assists.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ games, 'C:\D-S\games.GM'
  ΣΥΣΧΕΤΙΣΕ_ΑΡΧΕΙΟ acc, 'C:\D-S\acc.GM'
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\wins.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ wins
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ wins
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\losses.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ losses
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ losses
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\kills.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ kills
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ kills
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\deaths.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ deaths
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ deaths
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\assists.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ assists
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ assists
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\games.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ games
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ games
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΥΠΑΡΧΕΙ_ΑΡΧΕΙΟ('C:\D-S\acc.GM')=ΨΕΥΔΗΣ ΤΟΤΕ
    ΔΗΜΙΟΥΡΓΗΣΕ_ΑΡΧΕΙΟ acc
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
  ΤΕΛΟΣ_ΑΝ
                                         ! Intro !
  ΓΡΑΨΕ 'Welcome to DotA-Stats'
  ΚΑΛΕΣΕ Intro
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ DotAStats
!---------------------------------------Spectre~Shadows-----------------------------------------!
                                         ! Intro !
ΔΙΑΔΙΚΑΣΙΑ Intro
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: choice
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΡΑΨΕ 'What would you like to do?'
  ΓΡΑΨΕ '(1.Add player, 2.Add game for a player)'
  ΓΡΑΨΕ '(3.Search for player stats, 0. Exit)'
  ΓΡΑΨΕ '(4.Victory percentage [v1.3])'
  ΔΙΑΒΑΣΕ choice
  ΕΠΙΛΕΞΕ choice
    ΠΕΡΙΠΤΩΣΗ 0
      ΤΕΡΜΑΤΙΣΜΟΣ
    ΠΕΡΙΠΤΩΣΗ 1
      ΚΑΛΕΣΕ Add_Player
    ΠΕΡΙΠΤΩΣΗ 2
      ΚΑΛΕΣΕ Add_Game
    ΠΕΡΙΠΤΩΣΗ 3
      ΚΑΛΕΣΕ Search_Stats
    ΠΕΡΙΠΤΩΣΗ 4
      ΚΑΛΕΣΕ Victory_Percentage
    ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ
      ΚΑΛΕΣΕ Intro
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!---------------------------------------Spectre~Shadows-----------------------------------------!
                                         ! Menu  !
!---------------------------------------Spectre~Shadows-----------------------------------------!
                                         ! AddAcc!
ΔΙΑΔΙΚΑΣΙΑ Add_Player
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: tpt, ο
  ΑΚΕΡΑΙΕΣ: number
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΡΑΨΕ 'Adding a new player...'
  ΓΡΑΨΕ
  ΓΡΑΨΕ_ 'Account name? '
  ΔΙΑΒΑΣΕ ο
  number <-- 0
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ games
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ wins
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ losses
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ kills
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ deaths
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ assists
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ acc, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(acc)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ games, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(games)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ wins, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(wins)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ losses, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(losses)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ kills, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(kills)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ deaths, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(deaths)+1
  ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ assists, ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(assists)+1
  ΓΡΑΨΕ_ΑΡΧΕΙΟ acc, ο
  ΓΡΑΨΕ_ΑΡΧΕΙΟ games, number
  ΓΡΑΨΕ_ΑΡΧΕΙΟ wins, number
  ΓΡΑΨΕ_ΑΡΧΕΙΟ losses, number
  ΓΡΑΨΕ_ΑΡΧΕΙΟ kills, number
  ΓΡΑΨΕ_ΑΡΧΕΙΟ deaths, number
  ΓΡΑΨΕ_ΑΡΧΕΙΟ assists, number
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Player ', o,' has been added to the list'
  ΓΡΑΨΕ 'Player ', o,' has been assigned to player no.', ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(acc)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ games
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ wins
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ losses
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ kills
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ deaths
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ assists
  ΔΙΑΒΑΣΕ tpt
  ΚΑΛΕΣΕ Intro
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
                                         ! Game  !
ΔΙΑΔΙΚΑΣΙΑ Add_Game
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: εγγ, μεγ, number,number2
  ΧΑΡΑΚΤΗΡΕΣ: ο, α, tpt
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
  μεγ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(acc)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
  ΓΡΑΨΕ 'Adding game...'
  ΑΝ μεγ>0 ΤΟΤΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'In order to add a game you must know'
    ΓΡΑΨΕ 'the player no. of the player to whom you want to add a game.'
    ΓΡΑΨΕ '(To find out the player no. of someone you can use the "search stats" option)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'Be careful of what you type!'
    ΓΡΑΨΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ_ 'Player no. index (1-', μεγ, ') '
      ΔΙΑΒΑΣΕ εγγ
    ΜΕΧΡΙΣ_ΟΤΟΥ (εγγ>0) ΚΑΙ (εγγ<=μεγ)
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ acc,εγγ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ acc,o
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ 'Player no.',εγγ,'is assigned to',o
    ΓΡΑΨΕ_ 'Continue adding game? (Y/N)'
    ΔΙΑΒΑΣΕ α
    ΑΝ α<>'Y' ΚΑΙ α<>'N' ΤΟΤΕ
      ΟΣΟ α<>'Y' ΚΑΙ α<>'N' ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ_ 'Continue adding game? (Y/N)'
        ΔΙΑΒΑΣΕ α
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ α='Y' ΤΟΤΕ
      ΓΡΑΨΕ_ 'Adding game to ',o,'....'
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ games
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ wins
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ losses
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ kills
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ deaths
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ assists
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ acc,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ games,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ wins,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ losses,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ kills,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ deaths,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ assists,εγγ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ games,number
      number <-- number+1
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ games,εγγ
      ΓΡΑΨΕ_ΑΡΧΕΙΟ games,number
      ΓΡΑΨΕ_ 'Did he win or did he lose? (Leaving counts as a loss)(W/L)'
      ΔΙΑΒΑΣΕ α
      ΟΣΟ α<>'W' ΚΑΙ α<>'L' ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ_ 'Did he win or did he lose? (Leaving counts as a loss)(W/L)'
        ΔΙΑΒΑΣΕ α
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ α='W' ΤΟΤΕ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ wins,number
        number <-- number+1
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ wins,εγγ
        ΓΡΑΨΕ_ΑΡΧΕΙΟ wins,number
      ΑΛΛΙΩΣ
        ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ losses,number
        number <-- number+1
        ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ losses,εγγ
        ΓΡΑΨΕ_ΑΡΧΕΙΟ losses,number
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ_ 'Enter number of kills'
      ΔΙΑΒΑΣΕ number2
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ kills,number
      number <-- number+number2
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ kills,εγγ
      ΓΡΑΨΕ_ΑΡΧΕΙΟ kills,number
      ΓΡΑΨΕ_ 'Enter number of deaths'
      ΔΙΑΒΑΣΕ number2
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ deaths,number
      number <-- number+number2
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ deaths,εγγ
      ΓΡΑΨΕ_ΑΡΧΕΙΟ deaths,number
      ΓΡΑΨΕ_ 'Enter number of assists'
      ΔΙΑΒΑΣΕ number2
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ assists,number
      number <-- number+number2
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ assists,εγγ
      ΓΡΑΨΕ_ΑΡΧΕΙΟ assists,number
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ games
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ wins
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ losses
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ kills
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ deaths
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ assists
      ΓΡΑΨΕ
      ΓΡΑΨΕ 'Game Added.Press <ENTER> to continue...'
      ΔΙΑΒΑΣΕ tpt
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ_ 'Returning to menu....'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ
    ΓΡΑΨΕ '[NO PLAYERS ADDED TO THE LIST]'
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'Press <ENTER> to continue...'
    ΔΙΑΒΑΣΕ tpt
  ΤΕΛΟΣ_ΑΝ
  ΚΑΛΕΣΕ Intro
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
                                         ! Stats !
ΔΙΑΔΙΚΑΣΙΑ Search_Stats
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, κ, q, g, w, l, d, e
  ΧΑΡΑΚΤΗΡΕΣ: ο, α, τ, ζητ_ο, ζητ_α
  ΛΟΓΙΚΕΣ: βρέθηκε
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ games
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ wins
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ losses
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ kills
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ deaths
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ assists
  ΓΡΑΨΕ_ 'Enter account name'
  ΔΙΑΒΑΣΕ ζητ_ο
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Search results...'
  ΓΡΑΨΕ
  βρέθηκε <-- ΨΕΥΔΗΣ
  ι <-- 1
  ΟΣΟ (ΤΕΛΟΣ_ΑΡΧΕΙΟΥ(acc)=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ acc, ο
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ games, g
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ wins, w
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ losses, l
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ kills, q
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ deaths, d
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ assists, e
    ΑΝ ο=ζητ_ο ΤΟΤΕ
      βρέθηκε <-- ΑΛΗΘΗΣ
      ΓΡΑΨΕ 'Account name',ο,'with player number ',ι,' :'
      ΓΡΑΨΕ 'Games :', g
      ΓΡΑΨΕ 'Wins :', w
      ΓΡΑΨΕ 'Losses :', l
      ΓΡΑΨΕ 'Kills :', q
      ΓΡΑΨΕ 'Deaths :', d
      ΓΡΑΨΕ 'Assists :', e
    ΤΕΛΟΣ_ΑΝ
    ι <-- ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ βρέθηκε=ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ '[NO SUCH ACCOUNT NAME IN THE LIST]'
  ΤΕΛΟΣ_ΑΝ
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ games
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ wins
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ losses
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ kills
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ deaths
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ assists
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'The search is completed. Press <ENTER> to continue...'
  ΔΙΑΒΑΣΕ τ
  ΚΑΛΕΣΕ Intro
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!---------------------------------------Spectre~Shadows-----------------------------------------!
ΣΥΝΑΡΤΗΣΗ  percent(c,b): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: b, c
ΑΡΧΗ
  percent <-- (c/b)*100
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
                                         ! Vic % !
ΔΙΑΔΙΚΑΣΙΑ Victory_Percentage
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: b, εγγ, μεγ, number, number2, c
  ΧΑΡΑΚΤΗΡΕΣ: tpt, a, o
ΑΡΧΗ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
  μεγ <-- ΜΕΓΕΘΟΣ_ΑΡΧΕΙΟΥ(acc)
  ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
  ΓΡΑΨΕ 'Victory percentage...'
  ΑΝ μεγ>0 ΤΟΤΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'In order to see the victory percentage of a player'
    ΓΡΑΨΕ 'you must know his player no.'
    ΓΡΑΨΕ '(To find out the player no. of someone you can use the "search stats" option)'
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'Be careful of what you type!'
    ΓΡΑΨΕ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ_ 'Player no. index (1-', μεγ, ') '
      ΔΙΑΒΑΣΕ εγγ
    ΜΕΧΡΙΣ_ΟΤΟΥ (εγγ>  0) ΚΑΙ (εγγ<=μεγ)
    ΑΝΟΙΞΕ_ΑΡΧΕΙΟ acc
    ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ acc,εγγ
    ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ acc,o
    ΚΛΕΙΣΕ_ΑΡΧΕΙΟ acc
    ΓΡΑΨΕ
    ΓΡΑΨΕ_ 'Player no.',εγγ,'is assigned to',o
    ΓΡΑΨΕ_ 'Continue to his victory percentage? (Y/N)'
    ΔΙΑΒΑΣΕ α
    ΑΝ α<>'Y' ΚΑΙ α<>'N' ΤΟΤΕ
      ΟΣΟ α<>'Y' ΚΑΙ α<>'N' ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ_ 'Continue to his victory percentage? (Y/N)'
        ΔΙΑΒΑΣΕ α
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ α='Y' ΤΟΤΕ
      ΓΡΑΨΕ_ 'Victory percentage of ',o,'....'
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ games
      ΑΝΟΙΞΕ_ΑΡΧΕΙΟ wins
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ games,εγγ
      ΔΙΑΤΡΕΞΕ_ΑΡΧΕΙΟ wins,εγγ
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ games, b
      ΔΙΑΒΑΣΕ_ΑΡΧΕΙΟ wins, c
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ games
      ΚΛΕΙΣΕ_ΑΡΧΕΙΟ wins
      ΑΝ number=0 ΤΟΤΕ
        ΚΑΛΕΣΕ intro
      ΤΕΛΟΣ_ΑΝ
      ΑΝ b=0 ΤΟΤΕ
        ΚΑΛΕΣΕ intro
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ o,' has played '
      ΓΡΑΨΕ β,'games out of which'
      ΓΡΑΨΕ 'he has won ', percent(c,b),' %'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ_ 'Returning to menu....'
  ΤΕΛΟΣ_ΑΝ
  ΔΙΑΒΑΣΕ α
  ΚΑΛΕΣΕ Intro
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!---------------------------------------Spectre~Shadows-----------------------------------------!

Πηγαίνω στην τρίτη γυμνασίου, έμαθα για τη γλωσσομάθεια από το Internet και πριν ίξερα μόνο λίγο HTML...

_________________
Yours faithfully,
Spectre~Shadows


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 4 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters