Τώρα είναι Τετ 12 Αύγ 2020 11:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Password Generator
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 09 Ιαν 2006 01:55 am 
Καλησπέρα...

Είπα μιας και αύριο γράφω διαγώνισμα να δοκιμάσω τη ΓλωσσοΜαθεια.
Και αφού αποφάσισα δοκιμάσω, προσπάθησα να φτιάξω ένα psedo-random password generator για να έχει ενδιαφέρων η εξάσκηση.

Ο κώδικας είναι αυτός:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ pwdgen

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: χ,len,ran

ΑΡΧΗ

  γράψε_ 'Αριθμός χαρακτήρων:'
  διάβασε len

  όσο χ < len επανάλαβε
    ran <-- τυχαιος(127)
    αν ran >= 33 τότε
      γραψε_ χαρ(ran)              
      χ <-- χ + 1
    τέλος_αν
  τελος_επαναληψης

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ pwdgen


Κατι ακόμα, είναι ενοχλητικά τα κενά που παραγοντε αυτόματα με την "χαρ()", θα έπρεπε νομίζω να αφαιρεθούν έτσι, αν θελήσει ο coder κενό μπορεί να τo βάζει αυτός όταν τo χρειάζεται...

Θέλω επίσης να πω πως θα ήταν πολύ καλό να υπήρχε το IDE και για Linux ή έστω ο compiler γιατί το PC σέρνεται με VM...
Πιστεύω και οι υπόλοιπου χρήστες Linux θα έχουν το ίδιο αίτημα & πρόβλημα...

Ωραία η προσπάθεια για το IDE πάντως. :)

Ευχαριστώ για το χρόνω σας.


Κορυφή
  
 
 Θέμα δημοσίευσης: Re: Password Generator
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 23 Δεκ 2006 03:13 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Zapotek έγραψε:
Καλησπέρα...
Κατι ακόμα, είναι ενοχλητικά τα κενά που παραγοντε αυτόματα με την "χαρ()", θα έπρεπε νομίζω να αφαιρεθούν έτσι, αν θελήσει ο coder κενό μπορεί να τo βάζει αυτός όταν τo χρειάζεται...


Κανενα προβλημα :wink:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ pwdgen

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: χ,len,ran
  ΧΑΡΑΚΤΗΡΕΣ: y

ΑΡΧΗ

  γράψε_ 'Αριθμός χαρακτήρων:'
  διάβασε len

  όσο χ < len επανάλαβε
    ran <-- τυχαιος(127)  
    αν ran >= 33 τότε
      y <-- y + χαρ(ran)
      χ <-- χ + 1
    τέλος_αν
  τελος_επαναληψης
  ΓΡΑΨΕ y

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ pwdgen
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 01 Μαρ 2007 12:50 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μαρ 2007 12:47 am
Δημοσιεύσεις: 1
Τοποθεσία: Greece`
Re paidia den xreiazetai sinartisi gia to tixaios?????


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 01 Μαρ 2007 03:44 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
tonykarkats έγραψε:
Re paidia den xreiazetai sinartisi gia to tixaios?????


Τα προγράμματα που δημοσιεύονται σε αυτήν την κατηγορία ξεφεύγουν από τα όρια της ΑΕΠΠ επειδή περιέχουν εντολές του "Εμπλουτισμένου Συντακτικού".
Άρα δεν είναι εκτελέσιμα σε εκδόσεις μεγαλύτερες από την 8.5 (εκδόσεις διερμηνευτή), γιατί σε αυτές δεν υποστηρίζονται (ακόμα) αυτές οι πρόσθετες εντολές.
Για να τα εκτελέσετε χρειάζεστε την έκδοση του μεταγλωττιστή (8.5).


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 4 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters