Τώρα είναι Πέμ 09 Ιούλ 2020 03:12 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μαγική πρόσθεση
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 21 Ιαν 2007 01:33 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
Δοκιμάστε το παρακάτω πρόγραμμα:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜαγικήΠρόσθεση

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α
ΑΡΧΗ

  Α <-- 2147483647
  Α <-- Α + 1
  ΓΡΑΨΕ Α
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Η έξοδος είναι -2147483648 αντί για +2147483648!
Μαγικό; Όχι :)

Hints:
1) Λέξεις κλειδιά:
--Υπερχείλιση
--Προσημασμένοι ακέραιοι

2) Το 2147483647 είναι ίσο με 2^31 - 1


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 13 Δεκ 2007 06:22 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 13 Δεκ 2007 04:15 pm
Δημοσιεύσεις: 21
Η ΕΜΒΕΛΕΙΑ ΤΩΝ ΑΚΕΡΑΙΩΝ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ΜΟΛΙΣ -2147483648 ΕΩΣ +2147483647, ΚΑΙ ΟΤΑΝ ΠΡΟΣΤΙΘΕΤΑΙ ΤΟ 1 ΣΤΟΝ ΤΕΛ ΑΡΙΘΜΟ ΠΟΥ ΜΠΟΡΕΙ ΝΑ ΥΠΑΡΧΕΙ, ΤΟΤΕ ΞΑΝΑΡΧΙΖΕΙ ΑΠΟ ΤΗΝ ΑΡΧΗ.
ΑΝ Η Α ΑΛΛΑΞΕΙ ΣΕ ΠΡΑΓΜΑΤΙΚΗ ΤΟΤΕ ΘΑ ΓΙΝΕΙ ΣΩΣΤΑ Η ΠΡΟΣΘΕΣΗ, ΓΙΑΤΙ Η ΕΜΒΕΛΕΙΑ ΤΩΝ ΠΡΑΓΜΑΤΙΚΩΝ ΕΙΝΑΙ ΠΟΛΥ ΜΕΓΑΛΥΤΕΡΗ. 8)
ΔΗΛ.
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜαγικήΠρόσθεση

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α
ΑΡΧΗ

  Α <-- 2147483647
  Α <-- Α + 1
  ΓΡΑΨΕ Α
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
--** The Develloper is the God of the programs**--


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 15 Δεκ 2007 07:23 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
Σωστά!
(2147483648 = 2^32 :wink: )

_________________
"Imagination is more important than knowledge. For knowledge is limited to all we now know and understand, while imagination embraces the entire world, and all there ever will be to know and understand."

Albert Einstein


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters