Τώρα είναι Σάβ 29 Φεβ 2020 12:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Τ_Ρ ενος αριθμου
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 04 Νοέμ 2006 01:39 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Ενα απλο προγραμματακι για υπολογισμου τετραγωνικης ριζας ενος αριθμου:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ριζα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α

ΑΡΧΗ
  ΓΡΑΨΕ 'Γραψε εναν αριθμο:'
  ΔΙΑΒΑΣΕ α

  ΑΝ α>=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ριζα του α:', Τ_Ρ(α)
  ΑΛΛΙΩΣ
    ΚΑΛΕΣΕ λαθος
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ριζα

!=======================================
ΔΙΑΔΙΚΑΣΙΑ λαθος
ΑΡΧΗ
  ΓΡΑΨΕ 'Ο αριθμος πρεπει να ειναι >= από το 0:'
  ΔΙΑΒΑΣΕ α

  ΑΝ α>=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ριζα του α:', Τ_Ρ(α)
  ΑΛΛΙΩΣ
    ΚΑΛΕΣΕ λαθος
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!=======================================
 


:roll: :oops: :wink:

PS Μολις χθες ανακαλυψα την ΓλωσσοΜάθεια και αυτο ειναι το πρωτο μου προγραμμα (ειμαι Τεχνολογικη Κατ. Γ Λυκειου)


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Νοέμ 2006 12:10 am 
Κουφο. Να ενας τροπος να πετυχεις επαναληψη χωρις δομες επαναληψης.
Μια διαδικασια να καλει τον εαυτο της!


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Νοέμ 2006 04:33 pm 
Anonymous έγραψε:
Κουφο. Να ενας τροπος να πετυχεις επαναληψη χωρις δομες επαναληψης.
Μια διαδικασια να καλει τον εαυτο της!

Αυτό φίλε μου λέγεται αναδρομή οταν μία συνάρτισι-διαδικασία-μέθοδος (όπως θέλεις πές το) καλέι τον εαυτό της.Βασική προυπόθεση της αναδρομής είναι να υπάρχει ένα σημείο ελέγχου ώστε να μπορεί να τερματίσει,επίσης σε αναδρομική διαδικάσία δεν επιτρέπεται επαναληπτική δομή(δηλαδή καποιο for ή while) αν καποιοσ το κάνει τότε σίγουρα είναι λάθος.Αυτά περί αναδρομής ελπίζω να φανούν χρήσιμα αυτά σε κάποιον..


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 23 Δεκ 2006 03:52 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
ή πιο απλα:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ριζα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α

ΑΡΧΗ
  ΚΑΛΕΣΕ υπολογ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ριζα

!=======================================
ΔΙΑΔΙΚΑΣΙΑ υπολογ
ΑΡΧΗ
  ΓΡΑΨΕ 'Γραψε εναν  αριθμο'
  ΓΡΑΨΕ 'Ο αριθμος πρεπει να ειναι > από το 0:'
  ΔΙΑΒΑΣΕ α

  ΑΝ α>0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ριζα του α:', Τ_Ρ(α)
  ΑΛΛΙΩΣ
    ΚΑΛΕΣΕ υπολογ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!=======================================


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Τ_Ρ ενος αριθμου
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 16 Μαρ 2008 09:37 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 16 Μαρ 2008 09:35 pm
Δημοσιεύσεις: 2
paidia, auto einai to diorthwmeno:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ριζα

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α

ΑΡΧΗ
  ΓΡΑΨΕ 'Γραψε εναν αριθμο:'
  ΔΙΑΒΑΣΕ α

  ΑΝ α>=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ριζα του α:', Τ_Ρ(α)
  ΑΛΛΙΩΣ
    ΚΑΛΕΣΕ λαθος
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ριζα

!=======================================
ΔΙΑΔΙΚΑΣΙΑ λαθος

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α

ΑΡΧΗ
  ΓΡΑΨΕ 'Ο αριθμος πρεπει να ειναι >= από το 0:'
  ΔΙΑΒΑΣΕ α

  ΑΝ α>=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ριζα του α:', Τ_Ρ(α)
  ΑΛΛΙΩΣ
    ΚΑΛΕΣΕ λαθος
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!=======================================


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 5 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters