Τώρα είναι Σάβ 29 Φεβ 2020 01:04 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 7 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΝΑΒΟΣΒΗΝΩ
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Ιαν 2006 11:18 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 18 Ιαν 2006 08:37 pm
Δημοσιεύσεις: 2
Τοποθεσία: Katerini
Κάτι "πρωτότυπο" :wink: και όμως τόσο απλό :idea: . Θα μπορούσα να το κάνω αλλιώς; :oops:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝΑΒΟΣΒΗΝΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Χ, Κ
  ΧΑΡΑΚΤΗΡΕΣ: Μ
ΑΡΧΗ
  ΓΡΑΨΕ 'Πόσες φορές θέλετε να αναβοσβήσει μήνυμα;'
  ΔΙΑΒΑΣΕ Χ
  ΓΡΑΨΕ 'Γράψτε το μήνυμα:'
  ΔΙΑΒΑΣΕ Μ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Χ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ Μ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ TIMER


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΝΑΒΟΣΒΗΝΩ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 26 Ιαν 2006 10:15 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 26 Ιαν 2006 10:04 pm
Δημοσιεύσεις: 1
Τοποθεσία: athina
Παράθεση:
Κάτι "πρωτότυπο" :wink: και όμως τόσο απλό :idea: . Θα μπορούσα να το κάνω αλλιώς; :oops:


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝΑΒΟΣΒΗΝΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Χ, Κ
  ΧΑΡΑΚΤΗΡΕΣ: Μ
ΑΡΧΗ
  ΓΡΑΨΕ 'Πόσες φορές θέλετε να αναβοσβήσει μήνυμα;'
  ΔΙΑΒΑΣΕ Χ
  ΓΡΑΨΕ 'Γράψτε το μήνυμα:'
  ΔΙΑΒΑΣΕ Μ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ Χ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000
    "ΕΔΩ ΓΙΑΤΙ ΔΕΝ ΕΒΑΛΕΣ ΤΙΠΟΤΑ?ΔΕΝ ΕΧΕΙ ΝΟΗΜΑ Η ΕΠΑΝΑΛΗΨΗ"!!!!! :twisted:
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ Μ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ TIMER

_________________
ευχομαι σε όλους τους υποψηφιους των φετινων πανελληνίων καλη επιτυχια!!!κουραγιο,guys,ερχονται και οι καλυτερες εποχες(βλ.του χρονου)!!!μην τα παρατατε ειδικα οσοι θελετε υψηλοβαθμες σχολες οπως θελω εγω,πολυτεχνειο και τι στον κοσμο!!!Immortal4ver


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 31 Μάιος 2007 05:01 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 31 Μάιος 2007 03:34 am
Δημοσιεύσεις: 3
Τοποθεσία: Θεσσαλονικη
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΝΑΒΟΣΒΗΝΩ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: TIMES,Ι,J
  ΧΑΡΑΚΤΗΡΕΣ: MESSAGE
ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΜΗΝΥΜΑ ΠΟΥ ΘΕΣ ΝΑ ΑΝΑΒΟΣΒΗΝΕΙ:'
  ΔΙΑΒΑΣΕ MESSAGE
  ΓΡΑΨΕ 'ΔΩΣΕ ΠΟΣΕΣ ΦΟΡΕΣ ΘΕΣ ΝΑ ΑΝΑΒΟΣΒΗΣΕΙ ΤΟ ΜΗΝΥΜΑ ΣΟΥ:'
  ΔΙΑΒΑΣΕ TIMES
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ TIMES
    ΓΡΑΨΕ MESSAGE
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 1000000     !ΟΙ ΔΥΟ ΕΠΑΝΑΛΗΨΕΙΣ ΤΟΥ J ΔΕΝ ΕΙΝΑΙ ΑΣΚΟΠΕΣ!
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ              !Ο ΡΟΛΟΣ ΤΟΥΣ ΕΙΝΑΙ ΝΑ "ΚΑΘΥΣΤΕΡΟΥΝ ΤΗ ΡΟΗ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ                !ΤΟΥ ΠΡΟΓΡΑΜΜΑΤΟΣ, ΩΣΤΕ ΤΟ ΑΝΑΒΟΣΒΗΜΑ ΤΟΥ
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 1000000     !ΤΟΥ ΜΗΝΥΜΑΤΟΣ ΝΑ ΜΠΟΡΕΙ ΝΑ ΓΙΝΕΙ ΑΝΤΙΛΗΠΤΟ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ              !ΑΠΟ ΤΟ ΧΡΗΣΤΗ...
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


(Ο παραπανω κωδικας ειναι ακριβως ο ιδιος με αυτον του spank απλα μειωσα τον αριθμο των επαναληψεων, γιατι ηταν υπερβολικα αργα για το δικο μου συστημα... :P )

Οι επαναληψεις του J εχουν σκοπο μονο να καθυστερησουν το προγραμμα για να αναβοσβηνει με εναν "αισθητο" ρυθμο το μηνυμα. (εαν δεν βαζαμε τις επαναληψεις το μονο που θα βλεπαμε κατα την εκτελεση του προγραμματος θα ηταν το μηνυμα να τρεμοσβηνει...)

ΣΗΜΕΙΩΣΗ: Ο ρυθμος αναβοσβηματος εξαρταται απο: 1) των αριθμο των επαναληψεων του J και 2) απο την ταχυτητα του επεξεργαστη που εκτελει το προγραμμα!
Με τον παραπανω αριθμο επαναληψεων στο δικο μου "απαρχαιμενο" συστημα (CPU Clock: 500MHz, 128 Mb RAM κτλ...) το μηνυμα αναβοσβηνει σχεδον ανα δευτερολεπτο. Σε πιο καινουργια συστηματα ισως να εμφανιζεται υπερβολικα γρηγορα (Αν και μου φαινεται πολυ περιεργο, αφου για τετοιες μικρες διαδικασιες η διαφορα στον χρονο εκτελεσης θα πρεπει να ειναι απειροελαχιστη ακομα και για διαφορα αρκετων ΜHz)

Εξυπνο προγραμμα παρολα αυτα αν και πιστευω πως το λυσαμε καπως "μπακαλικα"... :P

Γι'αυτο θελω να ρωτησω αν θα μπορουσε να γινει το παρακατω:
ΥΠΟΘΕΣΗ

Μια πιο "σοβαρη" λυση θα μπορουσε να ηταν αν συνδεαμε το προγραμμα με το χρονιστη του υπολογιστη, ωστε αυτο να λειτουργει με βαση την πραγματικη "αισθηση του χρονου" και να βαζαμε χρονικη διαρκεια αναμεσα στις εμφανισεις...

Το συγκεκριμενο βεβαια δεν ξερω αν ειναι δυνατο να πραγματοποιηθει στη ΓλωσσοΜαθεια ή σε καποια αλλη γλωσσα. :roll:
Παντως οποιος ξερει κατι παραπανω σε σχεση με το πως χρησιμοποιουμε σωστα το χρονο στον προγραμματισμο (π.χ. πως γινεται να φτιαξουμε ενα ψηφιακο ρολόι) να απαντησει εδω ή να μου στειλει pm plz
:?


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 05 Ιούλ 2007 10:41 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 03 Ιούλ 2007 06:21 pm
Δημοσιεύσεις: 4
Τοποθεσία: Χανιά, προσεχώς Αθήνα
Η ίδια λογική με το μήνυμα που αναβοσβήνει, μόνο που αυτή τη φορά κινείται τυχαία στην οθόνη...

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΗΝΥΜΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:ΜΗΝ
  ΑΚΕΡΑΙΕΣ:Υ,Χ,Ι
ΑΡΧΗ
  ΓΡΑΨΕ 'ΚΑΛΩΣΗΡΘΕΣ!'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΜΗΝΥΜΑ ΣΟΥ:'
  ΔΙΑΒΑΣΕ ΜΗΝ
  ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
  ΠΗΓΑΙΝΕ_ΧΥ 32,8
  ΓΡΑΨΕ '*',ΜΗΝ,'*'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ ΒΗΜΑ 0
    ΚΑΛΕΣΕ ΚΑΘΥΣΤΕΡΗΣΗ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    Χ <-- ΤΥΧΑΙΟΣ(21)+1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Υ <-- ΤΥΧΑΙΟΣ(77)+1
    ΜΕΧΡΙΣ_ΟΤΟΥ Υ<=77-ΜΗΚΟΣ_ΧΑΡ(ΜΗΝ)   !ΤΟ ΜΗΝΥΜΑ ΘΑ ΧΩΡΑΕΙ ΟΛΟΚΛΗΡΟ ΣΤΗΝ ΟΘΟΝΗ
    ΠΗΓΑΙΝΕ_ΧΥ Υ,Χ
    ΓΡΑΨΕ '*',ΜΗΝ,'*'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΚΑΘΥΣΤΕΡΗΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι
ΑΡΧΗ                                                      
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10000000
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


:wink

_________________
http://misparrow.blogspot.com


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΝΑΒΟΣΒΗΝΩ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 17 Νοέμ 2010 05:27 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 28 Οκτ 2010 06:33 pm
Δημοσιεύσεις: 2
:roll:Γειά σας..!! Αντιμετωπίζω ένα μικρό πρόβλημα με την πρόταση <<ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ>>. Μόλις τρέχω το πρόγραμμα στην γλωσσομάθεια μου βγάζει Άγνωστη εντολή.Τι πρέπει να κάνω ώστε να τρέξει σωστά το πρόγραμμα;(κάθε είδους βοήθεια δεκτή!!)
Συνημμένο:
γλωσσομάθεια.jpg
γλωσσομάθεια.jpg [ 92.13 KiB | 3283 προβολές ]


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΝΑΒΟΣΒΗΝΩ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 17 Νοέμ 2010 07:49 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 09:46 pm
Δημοσιεύσεις: 49
HACKERAKI έγραψε:
:roll:Γειά σας..!! Αντιμετωπίζω ένα μικρό πρόβλημα με την πρόταση <<ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ>>. Μόλις τρέχω το πρόγραμμα στην γλωσσομάθεια μου βγάζει Άγνωστη εντολή.Τι πρέπει να κάνω ώστε να τρέξει σωστά το πρόγραμμα;(κάθε είδους βοήθεια δεκτή!!)

Είσαι στην κατηγορία "ΕΜΠΛΟΥΤΙΣΜΕΝΟ ΣΥΝΤΑΚΤΙΚΟ » Προγράμματα εμπλουτισμένου συντακτικού", όλα τα προγράμματα που θα βρεις εδώ χρειάζονται την έκδοση εμπλουτισμένου συντακτικού (Λήψη (παλιάς) έκδοσης μεταγλωττιστή - [ 8.5 ]).

_________________
"Δύο πράγματα είναι ατελείωτα (άπειρα), το σύμπαν και η ανθρώπινη βλακεία, για το 1ο δεν είμαι σίγουρος." Einstein
"Τα πάντα ρει" (Τα πάντα ρέουν/αλλάζουν) Ηράκλειτος
"Μη μου τους κύκλους τάραττε" Αρχιμήδης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΝΑΒΟΣΒΗΝΩ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 23 Ιαν 2011 04:44 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 28 Οκτ 2010 06:33 pm
Δημοσιεύσεις: 2
Σωστά..Ευχαριστώ πολύ φίλε μου...!!!


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 7 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters