Τώρα είναι Τετ 29 Ιαν 2020 08:55 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 07 Απρ 2009 01:56 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 25 Φεβ 2009 12:19 am
Δημοσιεύσεις: 8
Να γράψετε πρόγραμμα το οποίο θα διαβάζει ένα μιγαδικό αριθμό z και θα εμφανίζει α) το μέτρο του, β) το συζυγή του και γ) τον αντίστροφό του εφόσον αυτός υπάρχει, διαφορετικά θα εμφανίζει σχετικό μήνυμα. Ο υπολογισμός σε κάθε υποερώτημα θα γίνεται από διαφορετικό υποπρόγραμμα.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Μιγαδικοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β
ΑΡΧΗ
  ΚΑΛΕΣΕ ΕισαγωγήΜιγαδικού(α,β)
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'Το μέτρο του μιγαδικού'
  ΚΑΛΕΣΕ ΕμφάνισηΜιγαδικού(α,β)
  ΓΡΑΨΕ 'είναι', ΜέτροΜιγαδικού(α,β)
  ΓΡΑΨΕ
  ΚΑΛΕΣΕ Συζυγής(α,β)
  ΓΡΑΨΕ
  ΚΑΛΕΣΕ ΑντίστροφοςΜιγαδικού(α,β)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Μιγαδικοί

ΔΙΑΔΙΚΑΣΙΑ ΕισαγωγήΜιγαδικού(α,β)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε το πραγματικό μέρος του μιγαδικού αριθμού'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δώσε το συντελεστή του φανταστικού μέρους του μιγαδικού αριθμού'
  ΔΙΑΒΑΣΕ β
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ ΕισαγωγήΜιγαδικού

ΣΥΝΑΡΤΗΣΗ ΜέτροΜιγαδικού(α,β):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β
ΑΡΧΗ
  ΜέτροΜιγαδικού <-- Τ_Ρ(α^2+β^2)
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ ΜέτροΜιγαδικού

ΔΙΑΔΙΚΑΣΙΑ ΕμφάνισηΜιγαδικού(α,β)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:Σύμβολο
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β,β2
ΑΡΧΗ
  ΑΝ β>=0 ΤΟΤΕ
    Σύμβολο <-- '+'
  ΑΛΛΙΩΣ
    Σύμβολο <-- '-'
  ΤΕΛΟΣ_ΑΝ
  β2 <-- Α_Τ(β)
  ΓΡΑΨΕ α, Σύμβολο, β2, 'i'
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ ΕμφάνισηΜιγαδικού

ΔΙΑΔΙΚΑΣΙΑ Συζυγής(α,β)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β,β2
ΑΡΧΗ
  β2 <-- -β
  ΓΡΑΨΕ 'Ο συζυγής του μιγαδικού'
  ΚΑΛΕΣΕ ΕμφάνισηΜιγαδικού(α,β)
  ΓΡΑΨΕ 'είναι ο μιγαδικός'
  ΚΑΛΕΣΕ ΕμφάνισηΜιγαδικού(α,β2)
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Συζυγής

ΔΙΑΔΙΚΑΣΙΑ ΑντίστροφοςΜιγαδικού(α,β)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ,δ,Παρανομαστής
ΑΡΧΗ
  Παρανομαστής <-- α^2+β^2
  ΑΝ Παρανομαστής>0 ΤΟΤΕ
    γ <-- α/Παρανομαστής
    δ <-- -β/Παρανομαστής
    ΓΡΑΨΕ 'Ο αντίστροφος του μιγαδικού'
    ΚΑΛΕΣΕ ΕμφάνισηΜιγαδικού(α,β)
    ΓΡΑΨΕ 'είναι ο μιγαδικός'
    ΚΑΛΕΣΕ ΕμφάνισηΜιγαδικού(γ,δ)
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν ορίζεται ο αντίστροφος του μιγαδικού που δώσατε!'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ ΑντίστροφοςΜιγαδικού
 


Ανάμεσα σε άλλα, δώστε ιδιαίτερη έμφαση:
1) Στο υποπρόγραμμα της εισόδου, το οποίο επιστρέφει "ένα" δεδομένο το οποίο αποτελείται από δύο μέρη, συνεπώς είναι αναγκαστικά Διαδικασία με δύο παραμέτρους εξόδου,
2) στο κοινόχρηστο υποπρόγραμμα για την εμφάνιση μιγαδικού το οποίο καλείται από διάφορα σημεία του προγράμματος.


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters