Τώρα είναι Τρί 29 Σεπ 2020 11:16 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 07 Ιαν 2008 12:37 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 19 Νοέμ 2007 01:27 am
Δημοσιεύσεις: 3
Τοποθεσία: Greece - Thessaloniki
Παιδια εχω κολλησει εδω και θελω τα φωτα σας !!!!

οποαδηποτε βοηθεια μπας και το βγαλουμε !!!!!


Λοιπον

Να γινει προγραμμα το οποιο δεχεται απο τον χηστη εναν αριθμο , τη βαση του αριθμιτικου συστηματος το οποιο βισκεται
και την βασση του αριθμιτικου συστηματος στο οποιο οποιο θελουμε να μετατραπει .
το προγραμμα τυπωνει τον αριθμο στο νεο αιυμιτικο προγραμμα .

Σημειωση
1) Τα συστηματα ειναι τα εξης 2δικο , 8δικο , 16δικο , 10δικο
2) Δεινοντι οι τελεστες ''mod'' και ''div''.


Περιμενω τις ιδεες σας παιδια

ευχαριστω !!!!


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 11 Ιαν 2008 04:59 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
Μια έκδοση χωρίς μετατροπή από 16αδικό στα άλλα συστήματα γιατί ο προγραμματισμός περιέχει χειρισμό χαρακτήρων.
Syntax: [ Download ] [ Hide ]
!******************************************************************************************************
!*Να γινει προγραμμα το οποιο δεχεται απο τον χρηστη εναν αριθμο , τη βαση του αριθμιτικου συστηματος *
!*το οποιο βρισκεται και την βαση του αριθμιτικου συστηματος στο οποιο οποιο θελουμε να μετατραπει .  *
!*το προγραμμα τυπωνει τον αριθμο στο νεο αιυμιτικο προγραμμα .                                       *
!*                                                                                                    *
!*Σημειωση                                                                                            *
!*1) Τα συστηματα ειναι τα εξης 2δικο , 8δικο , 16δικο , 10δικο                                       *
!*2) Δεινοντι οι τελεστες ''mod'' και ''div''.                                                        *
!******************************************************************************************************
ΠΡΟΓΡΑΜΜΑ    arithmitikes_baseis
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x,vasi,vasi1
  ΧΑΡΑΚΤΗΡΕΣ: y
ΑΡΧΗ
  ΓΡΑΨΕ '****************************************************************************************'
  ΓΡΑΨΕ '*                                  **Made by periptero**                               *'
  ΓΡΑΨΕ '*                                  **    Έκδοση 1.0   **                               *'
  ΓΡΑΨΕ '*         **Δεν περιέχει μετατροπή από 16αδικό στα άλλα αριθμητικά συστήματα**         *'
  ΓΡΑΨΕ '*            **Υπολογίζει μέχρι τον αριθμό *1048575* στο δυαδικό σύστημα**             *'
  ΓΡΑΨΕ '****************************************************************************************'
  ΓΡΑΨΕ 'Δώσε τη βάση του αριθμητικού συστήματος'
  ΓΡΑΨΕ '2αδικό (2), 8αδικό (8), 16αδικό (16), 10αδικό (10)'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ vasi
    ΑΝ vasi<>2 ΚΑΙ vasi<>10 ΚΑΙ vasi<>16 ΚΑΙ vasi<>8  ΤΟΤΕ
      ΓΡΑΨΕ 'Δώσατε λάθος βάση. Παρακαλώ διαλέξτε έναν αριθμό ανάμεσα στους 2,8,16,10'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ vasi=2 Η vasi=8 Η vasi=16 Η vasi=10
  ΓΡΑΨΕ 'Δώσε τον αριθμό :'
  ΑΝ vasi=16  ΤΟΤΕ
    ΔΙΑΒΑΣΕ y
  ΑΛΛΙΩΣ
    ΔΙΑΒΑΣΕ x
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Δώσε τη βάση του αριθμητικού συστήματος στην οποία θέλετε να μεταρέψετε τον αριθμό'
  ΓΡΑΨΕ '2αδικό (2), 8αδικό (8), 16αδικό (16), 10αδικό (10)'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ vasi1
    ΑΝ vasi1<>2 ΚΑΙ vasi1<>10 ΚΑΙ vasi1<>16 ΚΑΙ vasi1<>8  ΤΟΤΕ
      ΓΡΑΨΕ 'Δώσατε λάθος βάση. Παρακαλώ διαλέξτε έναν αριθμό ανάμεσα στους 2,8,16,10'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ vasi1=2 Η vasi1=8 Η vasi1=16 Η vasi1=10
  ΚΑΛΕΣΕ metatropi(vasi,vasi1,x,y)
  ΑΝ vasi1=16  ΤΟΤΕ
    ΓΡΑΨΕ 'O αριθμός που ζητάτε είναι ο :',y
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'O αριθμός που ζητάτε είναι ο :',x
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ  metatropi(v,v1, arithmos,arithmos1)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  i,p[20],temp,temp1,a[20],v,v1,arithmos,temp2
  ΧΑΡΑΚΤΗΡΕΣ: arithmos1,z, z1[4]
ΑΡΧΗ
  ΑΝ v=2  ΤΟΤΕ
    ΑΝ v1=8  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 2
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        temp1 <-- temp1+p[i]*2^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp DIV 3)+1
        a[i] <-- temp1 MOD 8
        temp1 <-- temp1 DIV 8
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp DIV 3)+1
        arithmos <-- arithmos+ a[i]*10^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=10  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 2
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        arithmos <-- arithmos+p[i]*2^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=16  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 2
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        temp1 <-- temp1+p[i]*2^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp DIV 4)+1
        a[i] <-- temp1 MOD 16
        temp1 <-- temp1 DIV 16
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      arithmos1 <-- ''
      ΓΙΑ i  ΑΠΟ   (temp DIV 4)+1     ΜΕΧΡΙ 1  ΜΕ ΒΗΜΑ        -1
        temp2 <-- a[i]
        z <-- dekaxi(temp2)
        arithmos1 <-- arithmos1+z
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ v=8  ΤΟΤΕ
    ΑΝ v1=2  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 10
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        temp1 <-- temp1+p[i]*8^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp * 3)+1
        a[i] <-- temp1 MOD 2
        temp1 <-- temp1 DIV 2
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp * 3)+1
        arithmos <-- arithmos+ a[i]*10^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=10  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 10
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        arithmos <-- arithmos+p[i]*8^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=16  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 10
        arithmos <-- arithmos DIV 10
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ  1  ΜΕΧΡΙ  temp
        temp1 <-- temp1+p[i]*8^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  (temp DIV 2)+1
        a[i] <-- temp1 MOD 16
        temp1 <-- temp1 DIV 16
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      arithmos1 <-- ''
      ΓΙΑ i  ΑΠΟ   (temp DIV 2)+1     ΜΕΧΡΙ 1  ΜΕ ΒΗΜΑ        -1
        temp2 <-- a[i]
        z <-- dekaxi(temp2)
        arithmos1 <-- arithmos1+z
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ v=10  ΤΟΤΕ
    ΑΝ v1=8  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 8
        arithmos <-- arithmos DIV 8
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  temp
        arithmos <-- arithmos+ p[i]*10^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=2  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 2
        arithmos <-- arithmos DIV 2
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  temp
        arithmos <-- arithmos+ p[i]*10^(i-1)
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ_ΑΝ v1=16  ΤΟΤΕ
      i <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        i <-- i+1
        p[i] <-- arithmos MOD 16
        arithmos <-- arithmos DIV 16
      ΜΕΧΡΙΣ_ΟΤΟΥ arithmos =0 Η i > 20
      temp <-- i
      temp1 <-- 0
      arithmos1 <-- ''
      ΓΙΑ i  ΑΠΟ    temp     ΜΕΧΡΙ 1  ΜΕ ΒΗΜΑ        -1
        temp2 <-- p[i]
        z <-- dekaxi(temp2)
        arithmos1 <-- arithmos1+z
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ  dekaxi(k) : ΧΑΡΑΚΤΗΡΑΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: k
ΑΡΧΗ
  ΕΠΙΛΕΞΕ k
    ΠΕΡΙΠΤΩΣΗ 0
      dekaxi <-- '0'
    ΠΕΡΙΠΤΩΣΗ 1
      dekaxi <-- '1'
    ΠΕΡΙΠΤΩΣΗ 2
      dekaxi <-- '2'
    ΠΕΡΙΠΤΩΣΗ 3
      dekaxi <-- '3'
    ΠΕΡΙΠΤΩΣΗ 4
      dekaxi <-- '4'
    ΠΕΡΙΠΤΩΣΗ 5
      dekaxi <-- '5'
    ΠΕΡΙΠΤΩΣΗ 6
      dekaxi <-- '6'
    ΠΕΡΙΠΤΩΣΗ 7
      dekaxi <-- '7'
    ΠΕΡΙΠΤΩΣΗ 8
      dekaxi <-- '8'
    ΠΕΡΙΠΤΩΣΗ 9
      dekaxi <-- '9'
    ΠΕΡΙΠΤΩΣΗ 10
      dekaxi <-- 'A'
    ΠΕΡΙΠΤΩΣΗ 11
      dekaxi <-- 'B'
    ΠΕΡΙΠΤΩΣΗ 12
      dekaxi <-- 'C'
    ΠΕΡΙΠΤΩΣΗ 13
      dekaxi <-- 'D'
    ΠΕΡΙΠΤΩΣΗ 14
      dekaxi <-- 'E'
    ΠΕΡΙΠΤΩΣΗ 15
      dekaxi <-- 'F'
  ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters