Τώρα είναι Τετ 30 Σεπ 2020 11:27 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τετ 31 Οκτ 2007 02:29 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 31 Οκτ 2007 01:48 pm
Δημοσιεύσεις: 3
Τοποθεσία: ΛΕΥΚΑΔΑ
Syntax: [ Download ] [ Hide ]
   
!-------------------------------------------------
!  Το πρόγραμμα δέχεται δύο ακέραιους αριθμούς και
!  υπολογίζει το ΜΚΔ και το ΕΚΠ
!  χρησιμοποώντας1 διαδικασία και 2 συναρτήσεις
!-------------------------------------------------------

ΠΡΟΓΡΑΜΜΑ ΜΚΔ_ΕΚΠ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Χ,Υ,ΜΓ,ΕΛ
ΑΡΧΗ

  ΓΡΑΨΕ_ 'Δώσε τον πρώτο ακέραιο'
  ΔΙΑΒΑΣΕ Χ
  ΓΡΑΨΕ_ 'Δώσε τον δεύτερο ακέραιο'
  ΔΙΑΒΑΣΕ Υ
  ΜΓ <-- ΜΚΔ(Χ,Υ)
  ΕΛ <-- ΕΚΠ(Χ,Υ,ΜΓ)
  ΓΡΑΨΕ 'Ο ΜΚΔ των αριθμών ',Χ,' και ',Υ ,' είναι ο ',ΜΓ
  ΓΡΑΨΕ 'Το ΕΚΠ των αριθμών ',Χ,' και ',Υ ,' είναι ο ',ΕΛ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΜΚΔ_ΕΚΠ
!-------------------------------------------------------------------------------------------
!  Η διαδικασία τοποθετεί στην πρώτη μεταβλητή το μικρότερο και στην Β το μεγαλύτερο αριθμό
!-------------------------------------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(Α,Β)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,ΒΟΗΘ

ΑΡΧΗ
  ΑΝ Α>Β ΤΟΤΕ
    ΒΟΗΘ <-- Α
    Α <-- Β
    Β <-- ΒΟΗΘ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------------------------------------------------
!  Η συνάρτηση υπολογίζει το ΜΚΔ των Α και Β
!-------------------------------------------------------------------------------------------
ΣΥΝΑΡΤΗΣΗ ΜΚΔ(Α,Β): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,Ι,Μ,ΒΟΗΘ
ΑΡΧΗ
  ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(Α,Β)
  Ι <-- 1
  Μ <-- 1
  ΟΣΟ Ι<=Α ΕΠΑΝΑΛΑΒΕ
    ΑΝ (Α MOD Ι=0) ΚΑΙ (Β MOD Ι=0) ΤΟΤΕ
      Μ <-- Ι
    ΤΕΛΟΣ_ΑΝ
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΚΔ <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-------------------------------------------------------------------------------------------
!  Η συνάρτηση υπολογίζει το ΕΚΠ των Α και Β
!-------------------------------------------------------------------------------------------
ΣΥΝΑΡΤΗΣΗ ΕΚΠ(Α,Β,Μ) : ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,Μ
ΑΡΧΗ
  ΕΚΠ <--    Α*Β  DIV Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 

_________________
takis


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters