Τώρα είναι Πέμ 13 Αύγ 2020 12:34 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Σύγκριση & μέγιστα πινάκων
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 10 Μαρ 2003 10:59 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ================================================
! Να γίνει πρόγραμμα το οποίο:
! α) Να διαβάζει έναν πίνακα Α, ακεραίων αριθμών,
!    10 θέσεων.
! β) Να διαβάζει έναν όμοιο πίνακα Β.
! γ) Να αποθηκεύει σε κάθε θέση ενός όμοιου πίνακα
!    Γ το μεγαλύτερο από τα στοιχεία που περιέχουν
!    στην αντίστοιχη θέση οι πίνακες Α και Β.
! δ) Να εμφανίζει τα περιεχόμενα του πίνακα Γ.
! ΣΗΜΕΙΩΣΕΙΣ:
! - Το διάβασμα των πινάκων Α και Β να γίνεται με
!   κλήσεις μιας ΔΙΑΔΙΚΑΣΙΑΣ.
! - Η εύρεση του μεγίστου να γίνεται με κλήση
!   ΣΥΝΑΡΤΗΣΗΣ.
! - Η εμφάνιση του πίνακα Γ να γίνεται με κλήση
!   ΔΙΑΔΙΚΑΣΙΑΣ.
! ================================================


ΠΡΟΓΡΑΜΜΑ Σύγκριση_και_μέγιστα_πινάκων

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[10], Β[10], Γ[10], i

ΑΡΧΗ

  ΚΑΛΕΣΕ Διάβασε_πίνακα(Α)
  ΚΑΛΕΣΕ Διάβασε_πίνακα(Β)

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Γ[i] <-- Μέγιστο(Α[i], Β[i])
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΛΕΣΕ Εμφάνισε_πίνακα(Γ)

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Σύγκριση_και_μέγιστα_πινάκων

!-------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ Διάβασε_πίνακα(Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[10], j
ΑΡΧΗ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε το ', j, 'ο στοιχείο του πίνακα:'
    ΔΙΑΒΑΣΕ Π[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------

!-------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ Εμφάνισε_πίνακα(Π)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[10], j
ΑΡΧΗ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Το ', j, 'ο στοιχείο του πίνακα είναι:'
    ΓΡΑΨΕ Π[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!-------------------------------------------------

!-------------------------------------------------
ΣΥΝΑΡΤΗΣΗ Μέγιστο(Χ,Υ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Χ, Υ
ΑΡΧΗ
  ΑΝ Χ>Υ ΤΟΤΕ
    Μέγιστο <-- Χ
  ΑΛΛΙΩΣ
    Μέγιστο <-- Υ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!-------------------------------------------------

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters