Τώρα είναι Τετ 29 Ιαν 2020 11:23 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 01 Μάιος 2003 10:30 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Πρέβεζα
Syntax: [ Download ] [ Hide ]
!Σε διάστημα δυο ακέραιων αριθμών να υπολογίσετε το πλήθος των ζυγών και το άθροισμά τους
!Προσοχή << Χωρίς ανακύκλωση >>
!ΓΙΩΡΓΟΣ ΚΑΡΡΑΣ **the Bugman**

ΠΡΟΓΡΑΜΜΑ ΖΥΓΟΙ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κ, λ

ΑΡΧΗ
  ΓΡΑΨΕ 'ΔΩΣΕ ΠΡΩΤΟ ΑΚΕΡΑΙΟ'
  ΔΙΑΒΑΣΕ Κ
  ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΥΤΕΡΟ ΑΚΕΡΑΙΟ'
  ΔΙΑΒΑΣΕ Λ
   ! ΒΑΖΟΥΜΕ ΣΕ ΤΑΞΗ ΤΟΥΣ ΑΚΕΡΑΙΟΥΣ
  ΑΝ Κ>Λ ΤΟΤΕ
    ΚΑΛΕΣΕ ΑΛΛΑΓΗ(Κ,Λ)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΜΕΤΑΞΥ ',Κ,' ΚΑΙ '
   !ΕΔΩ ΞΕΚΙΝΑΕΙ ΤΟ ΜΥΣΤΙΚΟ ΚΟΛΠΟ!
  ΑΝ ΖΥΓΟΣ(Κ) ΤΟΤΕ
    Κ <-- Κ-1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΖΥΓΟΣ(Λ) ΤΟΤΕ
    Λ <-- Λ+1
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΥΠΑΡΧΟΥΝ ',(Λ-Κ) DIV 2,' ΖΥΓΟΙ'
  ΓΡΑΨΕ 'ΠΟΥ ΕΧΟΥΝ ΑΘΡΟΙΣΜΑ ',(Λ*Λ-Κ*Κ) DIV 4


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΖΥΓΟΣ(α): ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α
ΑΡΧΗ
  ΑΝ α MOD 2 = 0 ΤΟΤΕ
    ΖΥΓΟΣ <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
    ΖΥΓΟΣ <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΛΛΑΓΗ(α, β)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α,β,γ
ΑΡΧΗ
  γ <-- α
  α <-- β
  β <-- γ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters