Τώρα είναι Τετ 29 Ιαν 2020 11:24 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 14 Μάιος 2007 01:03 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 13 Μάιος 2007 11:23 am
Δημοσιεύσεις: 2
Τοποθεσία: Κομοτηνή
Syntax: [ Download ] [ Hide ]
! Σε ένα διαγωνισμό σκοποβολής συμμετέχουν 120 διαγωνιζόμενοι.
! Ο κάθε διαγωνιζόμενος εκτελεί 10 βολές.
! Η τελική βαθμολογία του είναι το άθροισμα όλων των βαθμών που πέτυχε
! εκτός της καλύτερης και της χειρότερης βολής.
! 1) Να αναπτύξετε συνάρτηση που θα δέχεται ως είσοδο
! έναν πίνακα 10 στοιχείων με τους βαθμούς κάποιου διαγωνιζόμενου
! και θα επιστρέφει την τελική του βαθμολογία.
! 2) Να αναπτύξετε διαδικασία η οποία θα βρίσκει το μεγαλύτερο αριθμό
! που υπάρχει σε ένα μονοδιάστατο πίνακα 120 στοιχείων.
! 3) Να χρησιμοποιήσετε τα παραπάνω υποπρογράμματα για να φτιάξετε
! το κύριο πρόγραμμα, το οποίο θα δέχεται το όνομα του διαγωνιζόμενου
! και στη συνέχεια διαδοχικά τους βαθμούς των 10 βολών του.
! Αφού η διαδικασία αυτή ολοκληρωθεί και για τους 120 διαγωνιζόμενους,
! θα εμφανίζει το όνομα του νικητή.
! Σε περίπτωση ισοβαθμίας το βραβείο μοιράζονται όλοι οι διαγωνιζόμενοι
! που βρίσκονται στην κορυφή της βαθμολογίας.
ΠΡΟΓΡΑΜΜΑ σκοποβολή
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j
  ΠΡΑΓΜΑΤΙΚΕΣ: max,βολές[10],βαθμοί[120]
  ΧΑΡΑΚΤΗΡΕΣ: ονόματα[120]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 120
    ΓΡΑΨΕ 'Δώσε το όνομα του',i,'ου διαγωνιζόμενου:'
    ΔΙΑΒΑΣΕ ονόματα[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΡΑΨΕ 'Δώσε το βαθμό της',j,'ης βολής του:'
      ΔΙΑΒΑΣΕ βολές[j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    βαθμοί[i] <-- βαθμολογία(βολές)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΛΕΣΕ μεγαλύτερος(βαθμοί,max)
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 120
    ΑΝ max=βαθμοί[i] ΤΟΤΕ
      ΓΡΑΨΕ όνοματα[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ μεγαλύτερος(βαθμοί,max)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i
  ΠΡΑΓΜΑΤΙΚΕΣ: max,βαθμοί[120]
ΑΡΧΗ
  max <-- βαθμοί[1]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 120
    ΑΝ βαθμοί[i]>max ΤΟΤΕ
      max <-- βαθμοί[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ βαθμολογία(βολές) : ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i
  ΠΡΑΓΜΑΤΙΚΕΣ: sum,max,min,βολές[10]
ΑΡΧΗ
  sum <-- 0
  max <-- βολές[1]
  min <-- βολές[1]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    sum <-- sum+βολές[i]
    ΑΝ βολές[i]>max ΤΟΤΕ
      max <-- βολές[i]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ βολές[i]<min ΤΟΤΕ
      min <-- βολές[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  βαθμολογία <-- sum-max-min
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters