Τώρα είναι Τετ 30 Σεπ 2020 11:17 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Τρί 30 Ιαν 2007 04:08 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 14 Ιαν 2007 03:43 pm
Δημοσιεύσεις: 18
Τοποθεσία: Κομοτηνή
Φτιάξτε ένα πρόγραμμα που να διαβάζει 3 ακεραίους και να τους εκτυπώνει ταξινομημένους. Μη χρησιμοποιήσετε την ταξινόμηση της φυσαλίδας.

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ταξινόμηση3Αριθμών

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α[3], ι, min, max, mid

ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΡΑΨΕ 'Αριθμός ', ι
    ΔΙΑΒΑΣΕ α[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- ελάχιστος(ελάχιστος(α[1], α[2]), α[3])
  max <-- μέγιστος(μέγιστος(α[1], α[2]), α[3])
  mid <-- α[1] + α[2] + α[3] - min - max

  ΓΡΑΨΕ min, ' ', mid, ' ', max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ ελάχιστος (α, β): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
ΑΡΧΗ                                    
  ΑΝ α < β ΤΟΤΕ
    ελάχιστος <-- α
  ΑΛΛΙΩΣ
    ελάχιστος <-- β
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΣΥΝΑΡΤΗΣΗ μέγιστος (α, β): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
ΑΡΧΗ
  ΑΝ α > β ΤΟΤΕ
    μέγιστος <-- α
  ΑΛΛΙΩΣ
    μέγιστος <-- β
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

_________________
"Imagination is more important than knowledge. For knowledge is limited to all we now know and understand, while imagination embraces the entire world, and all there ever will be to know and understand."

Albert Einstein


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Παρ 20 Ιουν 2008 10:32 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Υπάρχει πιο εύκολος τρόπος!
το παρακάτω γραμμένο σε Μ2000
edit a
ανοίγει ο διορθωτής και γράφουμε τα παρακάτω
Syntax: [ Download ] [ Hide ]
dim a(3)
read a(0), a(1), a(2)
for i=1 to 3 {
if a(0)<=a(1) then {
if a(1)>a(2) then {
 c=a(1):a(1)=a(2):a(2)=c
 }
 } else {
   c=a(0):a(0)=a(1):a(1)=c
  }
}
print a(0), a(1), a(2)
 


γράφουμε
a 3,2,1
1 2 3

για τη ΓΛΩΣΣΑ να το πρόγραμμα:

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Ταξινόμηση3Αριθμών_εκδοση2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α[3], β, ι
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α[1], α[2], α[3]
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΑΝ α[1]<=α[2] ΤΟΤΕ
      ΑΝ α[2]>α[3] ΤΟΤΕ
        β <-- α[2]
        α[2] <-- α[3]
        α[3] <-- β
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      β <-- α[1]
      α[1] <-- α[2]
      α[2] <-- β
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ α[1], ' ', α[2], ' ', α[3]

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters