Τώρα είναι Τετ 29 Ιαν 2020 11:26 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Υπολογισμός παράστασης
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 21 Μαρ 2004 08:52 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Άσκηση 10.6.4 δικτυακού κόμβου : Να διαβαστεί αριθμός εντός του διαστήματος [1, 10] και να υπολογιστεί η παράσταση:

S = (a+1)^2/1! + (a+2)^2/2! + ... + (a+a)^2/a!

Syntax: [ Download ] [ Hide ]

ΠΡΟΓΡΑΜΜΑ Υπολογισμός_Παράστασης
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: μετρητής, κάτω_όριο, άνω_όριο, Α, αριθμητής, παρονομαστής, παράγοντας
  ΠΡΑΓΜΑΤΙΚΕΣ: άθροισμα

ΑΡΧΗ
  κάτω_όριο <-- 0
  άνω_όριο <-- 10
  ΚΑΛΕΣΕ Επιτρεπτή_Τιμή (Α, κάτω_όριο, άνω_όριο)!  έλεγχος δεδομένων με διαδικασία
  άθροισμα <-- 0
  ΓΙΑ μετρητής ΑΠΟ 1 ΜΕΧΡΙ Α
    παράγοντας <-- Α + μετρητής
    αριθμητής <-- Εις_το_Τετράγωνο (παράγοντας)
    παρονομαστής <-- Παραγοντικό (μετρητής)
    άθροισμα <-- άθροισμα + αριθμητής / παρονομαστής
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η παράσταση είναι ', άθροισμα
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!==================================================================
ΔΙΑΔΙΚΑΣΙΑ Επιτρεπτή_Τιμή (αριθμός, όριο_κάτω, όριο_άνω)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : αριθμός, όριο_κάτω, όριο_άνω, εκτίμηση
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δώστε έναν αριθμό στο διάστημα [', όριο_κάτω, ', ',  όριο_άνω, ']'
    ΔΙΑΒΑΣΕ εκτίμηση
  ΜΕΧΡΙΣ_ΟΤΟΥ (εκτίμηση >= όριο_κάτω) ΚΑΙ (εκτίμηση <= όριο_άνω)
  αριθμός <-- εκτίμηση
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!==================================================================
ΣΥΝΑΡΤΗΣΗ Παραγοντικό (αριθμός):    ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : αριθμός, εκτίμηση, i
ΑΡΧΗ
  ΑΝ (αριθμός < 0) ΤΟΤΕ
    εκτίμηση <-- -1!   Η  τιμή -1 θα ερμηνευτεί ως λάθος δεδομένο εισόδου
  ΑΛΛΙΩΣ
    εκτίμηση <-- 1
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ αριθμός
      εκτίμηση <-- εκτίμηση * i
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
  Παραγοντικό <-- εκτίμηση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!==================================================================
ΣΥΝΑΡΤΗΣΗ Εις_το_Τετράγωνο (Χ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  Χ, εκτίμηση
ΑΡΧΗ
  εκτίμηση <-- Α_Μ (Χ^2)
  Εις_το_Τετράγωνο <-- εκτίμηση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!==================================================================
 


Με εκτίμηση, :)


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters