Τώρα είναι Τετ 29 Ιαν 2020 08:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 19 Φεβ 2004 12:00 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 15 Φεβ 2004 09:10 pm
Δημοσιεύσεις: 18
Τοποθεσία: Ενιαίο Λύκειο Χιλιομοδίου Κορινθίας
Πρέπει να δώσουμε βαρύτητα και σε ασκήσεις υποπρογραμμάτων

Syntax: [ Download ] [ Hide ]
! http://users.kor.sch.gr/ptsiotakis/aepp/aepp_ask/ch10/aepp_ask10_3.htm άσκηση 5
! Να γράψετε πρόγραμμα που να δέχεται έναν ακέραιο τριψήφιο αριθμό
! και να επιστρέφει τον αντίστοιχο δυαδικό αριθμό
ΠΡΟΓΡΑΜΜΑ  Μετατροπή
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i, αριθμός, ΠΙΝΑΚΑΣ[10], στοιχεία
  ΛΟΓΙΚΕΣ: εκτίμηση
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Παρακαλώ δώστε έναν τριψήφιο αριθμό'
    ΔΙΑΒΑΣΕ αριθμός
    εκτίμηση <-- Έλεγχος_Τριψήφιος (αριθμός)
  ΜΕΧΡΙΣ_ΟΤΟΥ  εκτίμηση = ΑΛΗΘΗΣ

  ΚΑΛΕΣΕ  Δεκαδικός_σε_Δυαδικό (αριθμός, ΠΙΝΑΚΑΣ, στοιχεία)
  ΓΡΑΨΕ
  ΓΡΑΨΕ_ 'Ακολουθεί ο αντίστοιχος δυαδικός αριθμός:  '

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ στοιχεία
    ΓΡΑΨΕ_ ΠΙΝΑΚΑΣ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!============================================================
ΔΙΑΔΙΚΑΣΙΑ Δεκαδικός_σε_Δυαδικό (αριθμός, ΠΙΝΑΚΑΣ, ψηφία)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : αριθμός, temp_αριθμός, i, ΠΙΝΑΚΑΣ[10], temp_ΠΙΝΑΚΑΣ[10], ψηφία
ΑΡΧΗ
  temp_αριθμός <-- αριθμός
  ψηφία <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ψηφία <-- ψηφία + 1
    temp_ΠΙΝΑΚΑΣ[ψηφία] <-- temp_αριθμός MOD 2
    temp_αριθμός <-- temp_αριθμός DIV 2
  ΜΕΧΡΙΣ_ΟΤΟΥ (temp_αριθμός = 0)
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ψηφία                   !  αντιστροφή πίνακα
    ΠΙΝΑΚΑΣ[i] <-- temp_ΠΙΝΑΚΑΣ[ψηφία + 1 - i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
!============================================================
! Τροποποίηση της http://users.kor.sch.gr/ptsiotakis/aepp/aepp_ask/ch10/aepp_ask10_1.htm άσκηση 9
ΣΥΝΑΡΤΗΣΗ Έλεγχος_Τριψήφιος (αριθμός): ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΛΟΓΙΚΕΣ: εκτίμηση
  ΑΚΕΡΑΙΕΣ : αριθμός
  ΠΡΑΓΜΑΤΙΚΕΣ : χιλιάδες
ΑΡΧΗ
  χιλιάδες <-- αριθμός DIV 100
  ΑΝ (χιλιάδες >= 1) ΚΑΙ (χιλιάδες <= 9) ΤΟΤΕ
    εκτίμηση <-- ΑΛΗΘΗΣ
  ΑΛΛΙΩΣ
    εκτίμηση <-- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΑΝ
  Έλεγχος_Τριψήφιος <-- εκτίμηση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
!============================================================

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters