Τώρα είναι Πέμ 27 Ιουν 2019 03:51 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΒΙΒΛΙΟΘΗΚΗ ΥΠΟΠΡΟΓΡΑΜΜΑΤΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Τρί 16 Δεκ 2014 10:12 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 16 Δεκ 2014 09:32 am
Δημοσιεύσεις: 1
Syntax: [ Download ] [ Hide ]
! Στο πρόγραμμα που ακολουθεί γίνεται επίδειξη
! των υποπρογραμμάτων της βιβλιοθήκης
ΠΡΟΓΡΑΜΜΑ ΒΙΒΛΙΟΘΗΚΗ_ΥΠΟΠΡΟΓΡΑΜΜΑΤΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι,Κ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α,Β,Γ,ΠΙΝ[5],ΠΙΝ2[3,5]
ΑΡΧΗ
  Α <-- 2.5
  Β <-- 1
  Γ <-- 6.2
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    ΠΙΝ[Ι] <-- Ι
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5
      ΠΙΝ2[Ι,Κ] <-- Ι*10+Κ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ΜΙΝ2(Α,Β)
  ΓΡΑΨΕ ΜΑΧ2(Α,Β)
  ΓΡΑΨΕ ΜΑΧ3(Α,Β,Γ)
  ΓΡΑΨΕ ΑΘΡΟΙΣΜΑ_ΠΙΝΑΚΑ1(ΠΙΝ)
  ΓΡΑΨΕ ΑΘΡΟΙΣΜΑ_ΣΤΗΛΗΣ(ΠΙΝ2,2)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Ακουλουθούν τα υποπρογράμματα...

! Η παρακάτω συνάρτηση δέχεται 2 πραγματικούς αριθμούς
! και επιστρέφει το μεγαλύτερό τους
! Στην περίπτωση που είναι ίσοι επιστρέφει την (κοινή) τιμή τους
ΣΥΝΑΡΤΗΣΗ ΜΑΧ2(Μ1,Μ2):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Μ1,Μ2,Μ
ΑΡΧΗ
  ΑΝ Μ1>=Μ2 ΤΟΤΕ
    Μ <-- Μ1
  ΑΛΛΙΩΣ
    Μ <-- Μ2
  ΤΕΛΟΣ_ΑΝ
  ΜΑΧ2 <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! Η παρακάτω συνάρτηση δέχεται 2 πραγματικούς αριθμούς
! και επιστρέφει το μικρότερό τους
! Στην περίπτωση που είναι ίσοι επιστρέφει την (κοινή) τιμή τους
ΣΥΝΑΡΤΗΣΗ ΜΙΝ2(Μ1,Μ2):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Μ1,Μ2,Μ
ΑΡΧΗ
  ΑΝ Μ1<=Μ2 ΤΟΤΕ
    Μ <-- Μ1
  ΑΛΛΙΩΣ
    Μ <-- Μ2
  ΤΕΛΟΣ_ΑΝ
  ΜΙΝ2 <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! Η παρακάτω συνάρτηση δέχεται 3 πραγματικούς αριθμούς
! και επιστρέφει το μικρότερό τους
! Στην περίπτωση που είναι ίσοι επιστρέφει την (κοινή) τιμή τους
ΣΥΝΑΡΤΗΣΗ ΜΑΧ3(Μ1,Μ2,Μ3):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Μ1,Μ2,Μ3,Μ
ΑΡΧΗ
  Μ <-- Μ1
  ΑΝ Μ2>Μ ΤΟΤΕ
    Μ <-- Μ2
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Μ3>Μ ΤΟΤΕ
    Μ <-- Μ3
  ΤΕΛΟΣ_ΑΝ
  ΜΑΧ3 <-- Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! Η παρακάτω συνάρτηση επιστρέφει το άθροισμα των στοιχείων
! ενός πραγματικού πίνακα μίας διάστασης.
! Για λόγους δοκιμών, το μέγεθος του πίνακα είναι 5 στοιχεία,
! αλλά μπορεί εύκολα να προσαρμοστεί σε οποιαδήποτε διάσταση
ΣΥΝΑΡΤΗΣΗ ΑΘΡΟΙΣΜΑ_ΠΙΝΑΚΑ1(Π):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΈΣ:Π[5],ΑΘ
  ΑΚΕΡΑΙΕΣ: ΑΚ
ΑΡΧΗ
  ΑΘ <-- 0
  ΓΙΑ ΑΚ ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΘ <-- ΑΘ+Π[ΑΚ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΘΡΟΙΣΜΑ_ΠΙΝΑΚΑ1 <-- ΑΘ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! Η παρακάτω συνάρτηση επιστρέφει το άθροισμα των στοιχείων
! μίας στήλης ενός πραγματικού πίνακα δύο διαστάσεων.
! Για λόγους δοκιμών, οι διαστάσεις του πίνακα είναι 3 Χ 5 (3 ΓΡΑΜΜΕΣ Χ 5 ΣΤΗΛΕΣ),
! αλλά μπορεί εύκολα να προσαρμοστεί σε οποιαδήποτε διάσταση.
! Η παράμετρος Σ είναι ο αριθμός της στήλης τα στοιχεία της οποίας αθροίζονται.
ΣΥΝΑΡΤΗΣΗ ΑΘΡΟΙΣΜΑ_ΣΤΗΛΗΣ(Π,Σ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΈΣ:Π[3,5],ΑΘ
  ΑΚΕΡΑΙΕΣ: Σ,ΑΚ
ΑΡΧΗ
  ΑΘ <-- 0
  ΓΙΑ ΑΚ ΑΠΟ 1 ΜΕΧΡΙ 3
    ΑΘ <-- ΑΘ+Π[ΑΚ,Σ]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΘΡΟΙΣΜΑ_ΣΤΗΛΗΣ <-- ΑΘ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters