Τώρα είναι Τρί 26 Μάιος 2020 08:34 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:19 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ02 =================================================================
! Ένα συγκρότημα κατοικιών αποτελείται από 20 όμοιες πολυκατοικίες που κάθε
! μία έχει δέκα ορόφους και κάθε όροφος έχει πέντε διαμερίσματα.
! Να γραφεί πρόγραμμα το οποίο :
! · να ζητά και να καταχωρεί σε τρισδιάστατο πίνακα τον αριθμό των ατόμων
!   που διαμένουν σε κάθε διαμέρισμα. Ο καθένας από τους δείκτες του πίνακα
!   πίνακα αναφέρεται αντίστοιχα στην πολυκατοικία, τον όροφο και το διαμέ-
!   ρισμα. Να γίνεται έλεγχος εγκυρότητας με δεδομένο ότι σε κάθε διαμέρισμα
!   μπορούν να μένουν το πολύ 6 άτομα. Προφανώς για τα διαμερίσματα θα κατα-
!   χωρηθεί το μηδέν.
! · να υπολογίζει και να εμφανίζει τον αριθμό των άδειων διαμερισμάτων κάθε
!   πολυκατοικίας.
! · να υπολογίζει και να εμφανίζει τον αριθμό των κατοίκων κάθε πολυκατοικί-
!   ας.
! · να υπολογίζει και να εμφανίζει τον αριθμό των κατοίκων του συγκροτήματος
! · να υπολογίζει και να εμφανίζει το μέσο όρο των ατόμων που διαμένουν σε
!   κάθε διαμέρισμα του συγκροτήματος (τα άδεια διαμερίσματα δεν πρέπει να
!   να ληφθούν υπ΄ όψιν).
! =========================================================================

ΠΡΟΓΡΑΜΜΑ ΤΕΛ02
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : a[20,10,5] , i , j , k , n , nol , s , sol
  ΠΡΑΓΜΑΤΙΚΕΣ : mo                                                
ΑΡΧΗ

! ΕΙΣΑΓΩΓΗ ΔΕΔΟΜΕΝΩΝ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20           ! ΠΟΛΥΚΑΤΟΙΚΙΑ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10         ! ΟΡΟΦΟΣ
      ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 5        ! ΔΙΑΜΕΡΙΣΜΑ
        ΓΡΑΨΕ 'Δώσε τον αριθμό των ατόμων που μένουν στο διαμέρισμα' , k , 'του ορόφου' , j , 'της πολυκατοικίας' , i
        ΔΙΑΒΑΣΕ a[i,j,k]
        ΟΣΟ a[i,j,k] < 0 ή a[i,j,k] > 6 ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'Λάθος. Ξαναδώσε (0 έως 6)'
          ΔΙΑΒΑΣΕ a[i,j,k]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΜΕΤΡΗΣΗ ΑΔΕΙΩΝ ΔΙΑΜΕΡΙΣΜΑΤΩΝ ΚΑΘΕ ΠΟΛΥΚΑΤΟΙΚΙΑΣ ΚΑΙ ΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΑΔΕΙΩΝ
  nol <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    n <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 5
        ΑΝ a[i,j,k] = 0 ΤΟΤΕ
          n <-- n + 1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Ο αριθμός των άδειων διαμερισμάτων είναι' , 'της πολυκατοικίας', i , 'είναι', n
    nol <-- nol + n
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΡΙΘΜΟΣ ΚΑΤΟΙΚΩΝ ΚΑΘΕ ΠΟΛΥΚΑΤΟΙΚΙΑΣ ΚΑΙ ΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΚΑΤΟΙΚΩΝ
  sol <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    S <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
        s <-- s + a[i,j,k]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Ο αριθμός των κατοίκων της πολυκατοικίας ' , i , 'είναι' , S
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    sol <-- sol + s
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο αριθμός των κατοίκων του συγκροτήματος είναι ' , Sol

! ΜΕΣΟΣ ΟΡΟΣ ΚΑΤΟΙΚΩΝ ΑΝΑ ΔΙΑΜΕΡΙΣΜΑ
  mo <-- sol/(1000 - nol)
  ΓΡΑΨΕ 'Ο μέσος όρος των ατόμων του κάθε διαμερίσματος είναι ' , mo , 'άτομα'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters