Τώρα είναι Σάβ 06 Ιουν 2020 03:28 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:06 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ06 =================================================================
! Από μετρήσεις που έγιναν σε 20 μοντέλα κινητών τηλεφώνων βρέθηκε ότι
! ακτινοβολούν διαφορετικά ανάλογα με την εταιρεία κινητής τηλεφωνίας.
! Η ακτινοβολία τους μετριέται με το δείκτη απορρόφησης ακτινοβολίας από
! τον άνθρωπο (SAR).
! Να γραφεί πρόγραμμα το οποίο :
!  · να δημιουργεί πίνακα με τα ονόματα των εταιρειών κινητής τηλεφωνίας
!    (ΤΙΜ , VODAFONΕ , COSMOTE , Q)
!  · να ζητά και να καταχωρεί σε κατάλληλο πίνακα το όνομα του μοντέλου και
!    το δείκτη SAR κάθε τηλεφώνου που ελέγχθηκε σε κάθε μία από τις εταιρείες
!    κινητής τηλεφωνίας.
!  · να υπολογίζει και να εμφανίζει το μέσο επίπεδο SAR κάθε μοντέλου.
!  · να υπολογίζει και να εμφανίζει το μέσο επίπεδο SAR όλων των μοντέλων.
!  · να υπολογίζει και να εμφανίζει το μέσο επίπεδο SAR κάθε εταιρείας.
!  · να εμφανίζει κατά αύξουσα σειρά μέσου επιπέδου SAR τα ονόματα των
!    μοντέλων, το μέσο επίπεδο SAR και τις αντίστοιχες τιμές SAR του συγκε-
!    κριμένου μοντέλου για κάθε εταιρεία.
!  . να βρίσκει ποια μοντέλα είναι λιγότερο επικίνδυνα αν θεωρηθεί ότι είναι
!    αυτά που έχουν μέσο επίπεδο SAR μικρότερο το 1/3 του μέσου όρου.
! =========================================================================
!
ΠΡΟΓΡΑΜΜΑ TEL_06
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i , j , k
  ΠΡΑΓΜΑΤΙΚΕΣ : SAR[20,4] , mean[20] , s , meso , m , temp2
  ΧΑΡΑΚΤΗΡΕΣ: ετ[4] , model[20] , temp1
ΑΡΧΗ
  ετ[1] <-- 'ΤΙΜ'
  ετ[2] <-- 'VODAFONE'
  ετ[3] <-- 'COSMOTE'
  ετ[4] <-- 'Q'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα του μοντέλου Νο :', i
    ΔΙΑΒΑΣΕ model[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
      ΓΡΑΨΕ 'Δώσε το δείκτη SAR του ', model[i] , 'στην εταιρεία ' , ετ[j]
      ΔΙΑΒΑΣΕ SAR[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Το μέσο επίπεδο SAR του καθενός εκ των τηλεφώνων που εξετάστηκαν είναι :'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    s <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4
      s <-- s + SAR[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    mean[i] <-- s / 4
    ΓΡΑΨΕ model[i] , mean[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  s <-- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20
    s <-- s + mean[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  meso <-- s / 20
  ΓΡΑΨΕ 'Το μέσο επίπεδο SAR όλων των τηλεφώνων που εξετάστηκαν είναι :' , meso
  ΓΡΑΨΕ 'Το μέσο επίπεδο SAR κάθε εταιρείας είναι :'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 4
    s <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      s <-- s + SAR[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    m <-- s / 20
    ΓΡΑΨΕ ετ[j] , m
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ mean[j-1] > mean[j] ΤΟΤΕ
        temp1 <-- model[j-1]
        model[j-1] <-- model[j]
        model[j] <-- temp1
        temp2 <-- mean[j-1]
        mean[j-1] <-- mean[j]
        mean[j] <-- temp2
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 4
          temp2 <-- SAR[j-1,k]
          SAR[j-1,k] <-- SAR[j,k]
          SAR[j,k] <-- temp2
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ ΜΕΤΡΗΣΕΩΝ'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ model[i] , mean[i] , SAR[i,1] , SAR[i,2] , SAR[i,3] , SAR[i,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τα λιγότερο επικίνδυνα μοντέλα από αυτά  που εξετάστηκαν είναι :'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ mean[i] < meso/3 ΤΟΤΕ
      ΓΡΑΨΕ model[i]        
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters