Τώρα είναι Παρ 29 Μάιος 2020 03:43 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Eurovision 2007
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:03 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ07 =================================================================
! Στην τελική φάση του διαγωνισμού τραγουδιού της EUROVISION 2007 θα πάρουν
! μέρος 24 χώρες. Στη βαθμολογία του διαγωνισμού θα πάρουν μέρος 42 χώρες
! και κάθε μία από αυτές  δίνει διαδοχικά 1, 2, 3, 4, 5, 6, 7, 8, 10 και 12
! βαθμούς σε 10 από τις 24 χώρες που παίρνουν μέρος στον τελικό.
! Να γραφεί πρόγραμμα το οποίο :
! · να ζητά τα ονόματα των 42 χωρών που συμμετέχουν στο διαγωνισμό και να τα
!   καταχωρεί σε κατάλληλο πίνακα Ο[42]. Στις πρώτες 24 θέσεις του πίνακα θα
!   είναι τα ονόματα των χωρών που θα πάρουν μέρος στον τελικό με τη σειρά
!   που θα διαγωνιστούν.
! · να ζητά από την κάθε μία από τις 42 χώρες σε ποια χώρα δίνει βαθμούς και
!   καταχωρεί την αντίστοιχη βαθμολογία σε δισδιάστατο πίνακα Β[42,24].
!   Καμία χώρα δεν επιτρέπεται να βαθμολογήσει τον εαυτό της, ούτε να βαθμο-
!   λογήσει άλλη χώρα δύο φορές και ούτε να βαθμολογήσει χώρα που δε συμμε-
!   τέχει στην τελική φάση του διαγωνισμού. (Να γίνεται κατάλληλος έλεγχος).
! · να εμφανίζει τη χώρα-νικήτρια του διαγωνισμού (θεωρήστε ότι δεν υπάρχει
!   περίπτωση ισοψηφίας).
! · να βρίσκει και εμφανίζει τη χώρα (ή τις χώρες) που έδωσε τη μεγαλύτερη
!   βαθμολογία στην Ελλάδα αν είναι γνωστό ότι η Ελλάδα είναι η χώρα που θα
!   διαγωνιστεί δέκατη στο διαγωνισμό.
! · βρίσκει και εμφανίζει (αν υπάρχουν) το πλήθος και τα ονόματα των χωρών
!   που δεν πήραν ούτε ένα βαθμό.
! =========================================================================
!
ΠΡΟΓΡΑΜΜΑ TEL07
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: b[42,24] , s[24] , i , j , k , max , N
  ΧΑΡΑΚΤΗΡΕΣ: name[42] , winner
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
    ΓΡΑΨΕ 'Δώσε το όνομα της χώρας', i
    ΔΙΑΒΑΣΕ name[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24
      b[i,j] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
    ΓΡΑΨΕ 'ΚΑΛΗΣΠΕΡΑ', name[i]
    ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΡΑΨΕ 'Δώσε ποια χώρα βαθμολογείς'
      ΔΙΑΒΑΣΕ j
      ΟΣΟ j < 1 ή j > 24 ή j = i ή b[i,j] <> 0 ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'Λάθος. Ξαναδώστε.'
        ΔΙΑΒΑΣΕ j
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ k < 9 ΤΟΤΕ
        b[i,j] <-- k
      ΑΛΛΙΩΣ_ΑΝ k = 9 ΤΟΤΕ
        b[i,j] <-- 10
      ΑΛΛΙΩΣ
        b[i,j] <-- 12
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24
      s[j] <-- 0
      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
        s[j] <-- s[j] + b[i,j]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max <-- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24
    ΑΝ s[j] > max ΤΟΤΕ
      max <-- s[j]
      winner <-- name[j]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Νικήτρια χώρα είναι η' , winner
  max <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
    ΑΝ b[i,10] > max ΤΟΤΕ
      max <-- b[i,10]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 42
    ΑΝ b[i,10] = max ΤΟΤΕ
      ΓΡΑΨΕ name[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  N <-- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 24
    ΑΝ s[j] = 0 ΤΟΤΕ
      ΓΡΑΨΕ name[j]
      N <-- N + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ N
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Eurovision 2007
ΔημοσίευσηΔημοσιεύτηκε: Τετ 04 Φεβ 2009 05:35 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 14 Οκτ 2008 04:34 pm
Δημοσιεύσεις: 2
Ωραία άσκηση...
Θα μπορούσε να λυθεί κάνοντας χρήση μόνο μονοδιάστατων πινάκων.
Το μόνο ίσως "ελάττωμα" που υπάρχει σ'αυτή τη λύση, είναι πως ζητάει να δωθεί η θέση της χώρας η οποία ψηφίζεται και όχι το όνομα της.Στο διαγωνισμό συνηθίζεται να λέγεται π.χ. " οι 10 βαθμοί πηγαίνουν στη Δανία".
Μια διαφορετική λύση με μονοδιάστατους:
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ EUROVISION
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι,Κ,Μ,Λ,ΒΑΘΜΟΣ,ΒΑΘΜ[24],ΣΗΜΑΙΑ[24],ΜΑΧ,ΜΗΔΕΝ
  ΛΟΓΙΚΕΣ: ΧΩΡΑ_ΤΕΛΙΚΟΥ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜ[42],ΧΩΡΑ

ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 42
    ΑΝ (Ι<=24) ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΧΩΡΑΣ (ΣΥΜΜΕΤΕΧΕΙ ΣΤΟΝ ΤΕΛΙΚΟ)'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΔΩΣΕ ΟΝΟΜΑ ΧΩΡΑΣ (ΔΕΝ ΣΥΜΜΕΤΕΧΕΙ ΣΤΟΝ ΤΕΛΙΚΟ)'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΟΝΟΜ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 24
    ΒΑΘΜ[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 42
    ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 24
      ΣΗΜΑΙΑ[Μ] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΨΗΦΙΖΕΙ:',ΟΝΟΜ[Ι]
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
      ΑΝ (Κ=9) ΤΟΤΕ
        ΒΑΘΜΟΣ <-- 10
      ΑΛΛΙΩΣ_ΑΝ (Κ=10) ΤΟΤΕ
        ΒΑΘΜΟΣ <-- 12
      ΑΛΛΙΩΣ
        ΒΑΘΜΟΣ <-- Κ
      ΤΕΛΟΣ_ΑΝ
      ΧΩΡΑ_ΤΕΛΙΚΟΥ <-- ΨΕΥΔΗΣ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ 'ΔΩΣΕ ΧΩΡΑ ΤΗΝ ΟΠΟΙΑ ΘΕΛΕΙΣ ΝΑ ΒΑΘΜΟΛΟΓΗΣΕΙΣ ΜΕ',ΒΑΘΜΟΣ,';'
        ΔΙΑΒΑΣΕ ΧΩΡΑ
        ΑΝ (ΧΩΡΑ=ΟΝΟΜ[10]) ΚΑΙ (ΒΑΘΜΟΣ=12) ΤΟΤΕ
          ΓΡΑΨΕ 'Η ΧΩΡΑ',ΟΝΟΜ[Ι],'ΕΔΩΣΕ 12αρι ΣΤΗΝ ΕΛΛΑΔΑ'
        ΤΕΛΟΣ_ΑΝ
        ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 24
          ΑΝ (ΧΩΡΑ=ΟΝΟΜ[Λ]) ΚΑΙ (ΧΩΡΑ<>ΟΝΟΜ[Ι]) ΚΑΙ (ΣΗΜΑΙΑ[Λ]=0) ΤΟΤΕ
            ΧΩΡΑ_ΤΕΛΙΚΟΥ <-- ΑΛΗΘΗΣ
            ΣΗΜΑΙΑ[Λ] <-- ΣΗΜΑΙΑ[Λ]+1
            ΒΑΘΜ[Λ] <-- ΒΑΘΜ[Λ]+ΒΑΘΜΟΣ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΜΕΧΡΙΣ_ΟΤΟΥ (ΧΩΡΑ_ΤΕΛΙΚΟΥ=ΑΛΗΘΗΣ)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΑΧ <-- ΒΑΘΜ[1]
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 24
    ΑΝ (ΜΑΧ<ΒΑΘΜ[Ι]) ΤΟΤΕ
      ΜΑΧ <-- ΒΑΘΜ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 24
    ΑΝ ΒΑΘΜ[Ι]=ΜΑΧ ΤΟΤΕ
      ΓΡΑΨΕ 'ΜΕΓΙΣΤΗ ΒΑΜΟΛΟΓΙΑ:',ΟΝΟΜ[Ι]
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ΒΑΘΜ[Ι]=0 ΤΟΤΕ
      ΜΗΔΕΝ <-- ΜΗΔΕΝ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Eurovision 2007
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 04 Νοέμ 2013 06:22 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 21 Οκτ 2013 02:53 pm
Δημοσιεύσεις: 1
[quote="Hugo30
Η ίδια άσκηση αλλά με 10 χώρες που συμμετέχουν, 8 πάνε στον τελικό και κάθε μια από τις 10 χώρες που ψηφίζει βαθμολογεί 5 χώρες με 12,10,8,7 και 6 βαθμούς αντίστοιχα.
Η Ελλάδα εμφανίζεται 5η.
Μείωσα επίτηδες τα νούμερα για να είναι πιο εύκολος ο έλεγχος και διόρθωσα κάποια λάθη]
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ    euro
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: xora[10],winner
  ΑΚΕΡΑΙΕΣ: i,j,k,l,m,vathm[10,8],sy[8],max,mix,null
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Dose to onoma tis xoras No',i
    ΔΙΑΒΑΣΕ xora[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ j  ΑΠΟ  1  ΜΕΧΡΙ  8
      vathm[i,j] <-- 0

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 μέχρι 10
    ΓΡΑΨΕ 'Geia sou',xora[i]
    ΓΡΑΨΕ 'Parakalw grapse με ti seira'
    ΓΡΑΨΕ 'poies 5 xores vathmologeis'

    ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 5

      ΔΙΑΒΑΣΕ j

      ΟΣΟ j>8  ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'H xora pou edoses den lamvanei'
        ΓΡΑΨΕ 'meros ston diagonismo, parakalw'
        ΓΡΑΨΕ 'ksanadwse'
        ΔΙΑΒΑΣΕ j
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ΟΣΟ j=i Ή  j<1 Ή vathm[i,j]<>0  ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'Lathos,parakalw ksanagrapse'
        ΔΙΑΒΑΣΕ j
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΕΠΙΛΕΞΕ k
        ΠΕΡΙΠΤΩΣΗ 1
          vathm[i,j] <-- 12
        ΠΕΡΙΠΤΩΣΗ 2
          vathm[i,j] <-- 10
        ΠΕΡΙΠΤΩΣΗ 3
          vathm[i,j] <-- 8
        ΠΕΡΙΠΤΩΣΗ 4
          vathm[i,j] <-- 7
        ΠΕΡΙΠΤΩΣΗ 5
          vathm[i,j] <-- 6
      ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
      sy[j] <-- 0
      ΓΙΑ m ΑΠΟ 1 ΜΕΧΡΙ 10
        sy[j] <-- sy[j]+vathm[m,j]

      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΑΝ sy[i]>max ΤΟΤΕ
      max <-- sy[i]
      winner <-- xora[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'H nikitria xora einai h:',winner
  ΓΡΑΨΕ '==============================='
  ΓΡΑΨΕ 'H ellade pire 12 vathmous από tis eksis xores:'

  mix <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8

    ΑΝ vathm[i,5]=12 ΤΟΤΕ
      ΓΡΑΨΕ xora[i]
    ΑΛΛΙΩΣ_ΑΝ vathm[i,5]<>12   ΤΟΤΕ
      mix <-- mix+1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ mix=8 ΤΟΤΕ
      ΓΡΑΨΕ 'Kammia xora den edwse 12 vathmous stin Ellada'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  null <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΑΝ sy[i]=0       ΤΟΤΕ
      null <-- null+1

    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ null,'xores den piran kanenan vathmo και einai oi eksis:'

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 8
    ΑΝ sy[i]=0       ΤΟΤΕ
      ΓΡΑΨΕ xora[i]

    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ
  ΓΡΑΨΕ
  ΓΡΑΨΕ




  ΓΙΑ j ΑΠΟ  1 ΜΕΧΡΙ  8
    ΓΡΑΨΕ 'Η xora',xora[j],'exei',sy[j],'vathmous'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 
[/quote]


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters