Τώρα είναι Τρί 26 Μάιος 2020 08:06 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 18 Μάιος 2007 08:00 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! = ΤΕΛ08 =================================================================
! Να γραφεί πρόγραμμα το οποίο :
!  · να δέχεται και καταχωρεί τα στοιχεία ενός δισδιάστατου πίνακα ακεραίων
!    Α[50,40]
!  · να τον ταξινομεί κατά αύξουσα σειρά, συνολικά. Μεταθέτει δηλαδή τα
!    στοιχεία του έτσι ώστε στο τέλος να ισχύει :
!    Α[1,1] <= Α[1,2] <= .... <= Α[2,1] <= Α[2,2] <= Α[2,2] ... <= Α[50,40]
!
! ΥΠΟΔΕΙΞΗ :
!  · Δημιουργήστε έναν μονοδιάστατο πίνακα ακεραίων Β[2000] ο οποίος θα
!    περιέχει τα στοιχεία του πίνακα Α.
!  · Ταξινομήστε τον πίνακα Β.
!  · Μεταφέρετε κατάλληλα τα στοιχεία του πίνακα Β στον πίνακα Α.
! =========================================================================
!
ΠΡΟΓΡΑΜΜΑ TEL_08
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , j , k
  ΠΡΑΓΜΑΤΙΚΕΣ : a[50,40] , b[2000] , temp
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 40                                      
      ΔΙΑΒΑΣΕ a[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΜΕΤΑΦΟΡΑ ΤΩΝ ΔΕΔΟΜΕΝΩΝ ΤΟΥ ΠΙΝΑΚΑ a[50,40] ΣΤΟ ΜΟΝΟΔΙΑΣΤΑΤΟ b[2000]
k <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 50
      b[k] <-- a[i,j]
      k <-- k +1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΥΞΟΥΣΑ ΤΑΞΙΝΟΜΗΣΗ ΤΟΥ ΠΙΝΑΚΑ b[2000]
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 2000
    ΓΙΑ j ΑΠΟ 2000 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ b[j-1] > b[j] ΤΟΤΕ
        temp <-- b[j-1]
        b[j-1] <-- b[j]
        b[j] <-- temp
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΜΕΤΑΦΟΡΑ ΤΩΝ ΔΕΔΟΜΕΝΩΝ ΤΟΥ ΜΟΝΟΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ b[2000] ΣΤΟΝ a[50,40]
k <-- 1
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 40
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 50
      a[i,j] <-- b[k]
      k <-- k +1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters