Τώρα είναι Σάβ 06 Ιουν 2020 03:56 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 14 Μάιος 2007 12:55 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 13 Μάιος 2007 11:23 am
Δημοσιεύσεις: 2
Τοποθεσία: Κομοτηνή
Syntax: [ Download ] [ Hide ]
! Κατά τη διάρκεια διεθνών αγώνων στίβου, στον ακοντισμό έλαβαν μέρος
! δέκα αθλητές. Κάθε αθλητής έκανε έξι έγκυρες ρίψεις, που
! καταχωρούνται ως επιδόσεις εκφρασμένες σε μέτρα.
! Να αναπτύξετε ΠΡΟΓΡΑΜΜΑ σε "ΓΛΩΣΣΑ" το οποίο:
! 1. Θα εισάγει σε πίνακα δύο διαστάσεων τις επιδόσεις όλων των αθλητών.
! 2. Θα υπολογίζει και θα καταχωρεί σε μονοδιάστατο πίνακα την καλύτερη
! από τις επιδόσεις κάθε αθλητή.
! 3. Θα ταξινομεί κατά φθίνουσα διάταξη τις καλύτερες επιδόσεις των
! αθλητών που καταχωρήθηκαν στο μονοδιάστατο πίνακα.
! 4. Θα εμφανίζει με ανάλογο μήνυμα την καλύτερη επίδοση των αθλητών
! που πήραν μετάλλια (πρώτη, δεύτερη και τρίτη θέση).
! Παρατήρηση: Υποθέστε ότι όλες οι επιδόσεις είναι διαφορετικές μεταξύ
! τους.
ΠΡΟΓΡΑΜΜΑ ακοντισμός
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j
  ΠΡΑΓΜΑΤΙΚΕΣ: επιδόσεις[10,6],max[10],temp
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'Δώσε την',j,'η επίδοση του',i,'ου αθλητή:'
      ΔΙΑΒΑΣΕ επιδόσεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    max[i] <-- επιδόσεις[i,1]
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 6
      ΑΝ επιδόσεις[i,j]>max[i] ΤΟΤΕ
        max[i] <-- επιδόσεις[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 10 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ max[j]>max[j-1] ΤΟΤΕ
        temp <-- max[j]
        max[j] <-- max[j-1]
        max[j-1] <-- temp
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Επίδοση πρώτης θέσης:',max[1]
  ΓΡΑΨΕ 'Επίδοση δεύτερης θέσης:',max[2]
  ΓΡΑΨΕ 'Επίδοση τρίτης θέσης:',max[3]
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters