Τώρα είναι Παρ 29 Μάιος 2020 04:10 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 07 Απρ 2007 04:44 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ========================================================
! Σε μια εκπαιδευτική περιφέρεια υπάγονται πέντε λύκεια
! στα οποία φοιτούν συνολικά 500 μαθητές της τεχνολογικής
! κατεύθυνσης οι οποίοι πήραν μέρος για πρώτη φορά σε
! πανελλήνιες εξετάσεις.
! Να γραφεί πρόγραμμα το οποίο :
!  · να δημιουργεί πίνακα με τα έξι μαθήματα που
!    εξετάστηκαν οι μαθητές πανελλαδικά.
!  · για κάθε μαθητή να ζητά τον αριθμό του λυκείου
!    στο οποίο φοιτά, το όνομά του, τον κωδικό του
!    και το βαθμό στο κάθε ένα από τα έξι μαθήματα
!    στα οποία εξετάστηκε.
!    Να γίνεται έλεγχος εγκυρότητας των τιμών και
!    καταχώρησή τους σε κατάλληλους πίνακες.
!    Ο κωδικός κάθε υποψηφίου είναι ακέραιος οκταψήφιος
!    αριθμός με τα δύο πρώτα ψηφία να είναι 07 και τα
!    επόμενα δύο 13. Ο βαθμός κάθε μαθήματος είναι
!    ακέραιος από μηδέν έως και 100.
! · να ταξινομεί κατάλληλα τους πίνακες και
! · να εμφανίζει τα αποτελέσματα για κάθε λύκειο χωριστά
!   ταξινομημένα αλφαβητικά.
! =========================================================
!
ΠΡΟΓΡΑΜΜΑ LAST_01
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: L[500] , code[500] , b[500,6] , i , j , k , temp2
  ΠΡΑΓΜΑΤΙΚΕΣ: x
  ΧΑΡΑΚΤΗΡΕΣ: m[6] , name[500] , temp1
ΑΡΧΗ
  m[1] <-- 'ΓΛΩΣΣΑ'
  m[2] <-- 'ΜΑΘΗΜΑΤΙΚΑ ΚΑΤ.'
  m[3] <-- 'ΦΥΣΙΚΗ ΚΑΤ.'
  m[4] <-- 'ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ'
  m[5] <-- 'ΔΙΟΙΚΗΣΗ ΕΠΙΧ.'
  m[6] <-- 'ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
    ΓΡΑΨΕ 'Δώσε το όνομα του μαθητή Νο:',i
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Δώσε το λύκειο που φοιτά ο ',name[i]
    ΔΙΑΒΑΣΕ x
    ΟΣΟ x <> Α_Μ(x) ή x < 1 ή x > 5 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ x
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    L[i] <-- Α_Μ(x)
    ΓΡΑΨΕ 'Δώσε τον κωδικό του ',name[i]
    ΔΙΑΒΑΣΕ x
    ΟΣΟ x <> Α_Μ(x) ή x < 7130000 ή x > 7139999 η Α_Μ(x) DIV 10000 <> 713 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ x
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    code[i] <-- Α_Μ(x)
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'Δώσε το βαθμό του στο μάθημα',m[j]
      ΔΙΑΒΑΣΕ x
      ΟΣΟ x <> Α_Μ(x) ή x < 0 ή x > 100 ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
        ΔΙΑΒΑΣΕ x
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      b[i,j] <-- Α_Μ(x)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 500
    ΓΙΑ j ΑΠΟ 500 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ name[j-1] > name[j] ΤΟΤΕ
        temp1 <-- name[j-1]
        name[j-1] <-- name[j]
        name[j] <-- temp1
        temp2 <-- L[j-1]
        L[j-1] <-- L[j]
        L[j] <-- temp2
        temp2 <-- code[j-1]
        code[j-1] <-- code[j]
        code[j] <-- temp2
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 6
          temp2 <-- b[j-1,k]
          b[j-1,k] <-- b[j,k]
          b[j,k] <-- temp2
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ k , 'o ΛΥΚΕΙΟ - ΑΠΟΤΕΛΕΣΜΑΤΑ ΠΑΝΕΛΛΛΗΝΙΩΝ'
    ΓΡΑΨΕ '========================================'
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 500
      ΑΝ L[i] = k ΤΟΤΕ
        ΓΡΑΨΕ
        ΓΡΑΨΕ name[i] , code[i]
        ΓΡΑΨΕ '----------------------------------------'
        ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
          ΓΡΑΨΕ m[i] , ' - ' , b[i,j]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '========================================'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters