Τώρα είναι Παρ 29 Μάιος 2020 02:54 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΠΟΘΗΚΕΣ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 17 Δεκ 2006 05:34 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Μια εταιρεία έχει 10 αποθήκες σε δέκα διαφορετικές πόλεις.
! Σε κάθε μία από αυτές αποθηκεύει τα 20 προϊόντα που εμπορεύεται.
! Να γράψετε πρόγραμμα το οποίο :
!  α) να ζητά και να καταχωρεί σε κατάλληλο πίνακα τα ονόματα
!     των είκοσι προϊόντων.
!  β) να ζητά και να καταχωρεί σε κατάλληλο πίνακα τα ονόματα
!     των δέκα πόλεων όπου βρίσκονται οι αποθήκες.
!  γ) να ζητά και να καταχωρεί σε κατάλληλο πίνακα τον αριθμό
!     των τεμαχίων κάθε ενός από τα προϊόντα σε κάθε μία από τις αποθήκες.
!  δ) να εμφανίζει ποια προϊόντα λείπουν από κάθε αποθήκη.
!  ε) να εμφανίζει για κάθε προϊόν, το όνομά του και το συνολικό αριθμό
!     τεμαχίων του σε όλες τις αποθήκες μαζί.
! στ) να εμφανίζει για κάθε αποθήκη τις ελλείψεις σε προϊόντα, αναφέροντας
!     το όνομα και τον αριθμό τεμαχίων κάθε προϊόντος που o αριθμός των
!     τεμαχίων του στη συγκεκριμένη αποθήκη είναι από 15 και κάτω.
!
! =========================================================================
!
!
ΠΡΟΓΡΑΜΜΑ Αποθήκες
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,q[20,10],s
  ΧΑΡΑΚΤΗΡΕΣ: name[20],city[10]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα του προϊόντος',i
    ΔΙΑΒΑΣΕ name[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε το όνομα της πόλης στην οποία βρίσκεται η αποθήκη',j
    ΔΙΑΒΑΣΕ city[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε τον αριθμό των τεμαχίων του κάθε προϊόντος που ακολουθεί'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Πόλη',city[j]
    ΓΡΑΨΕ '=============='
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      ΓΡΑΨΕ name[i],';'
      ΔΙΑΒΑΣΕ q[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τα εξής προϊόντα λείπουν τελείως από τις αντίστοιχες αποθήκες'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ city[j]
    ΓΡΑΨΕ '=============='
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      ΑΝ q[i,j] = 0 ΤΟΤΕ
        ΓΡΑΨΕ name[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '=============='
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    s <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      s <-- s + q[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Συνολικός αριθμός τεμαχίων από το ',name[i],'=',s
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΕΛΛΕΙΨΕΙΣ ΑΝΑ ΑΠΟΘΗΚΗ'
  ΓΡΑΨΕ '======================'
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'ΠΟΛΗ :',city[j]
    ΓΡΑΨΕ '---------------'
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      ΑΝ q[i,j] <= 15 ΤΟΤΕ
        ΓΡΑΨΕ name[i],'Αριθμός τεμαχίων που υπάρχουν στην αποθήκη',q[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '---------------'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters