Τώρα είναι Παρ 29 Μάιος 2020 02:37 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Μάθε παιδί μου γράμματα **
ΔημοσίευσηΔημοσιεύτηκε: Τετ 13 Σεπ 2006 07:04 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Να γίνει πρόγραμμα το οποίο

α) διαβάζει τα ονόματα 10 μαθητών και τους βαθμούς (0-100) που έχουν λάβει στα 6 μαθήματα των εξετάσεων. Να διαβάζονται στη συνέχεια και τα ονόματα των μαθημάτων.

β) Εμφανίζει τα ονόματα των 2 μαθητών με το μεγαλύτερο μέσο όρο, και το μάθημα που αυτοί είχαν το μεγαλύτερο βαθμό.

γ) Να εμφανίζει το μεγαλύτερο μέσο όρο από τους μαθητές που είχαν βαθμολογία μεγαλύτερη του 80 σε τουλάχιστον 2 μαθήματα.

δ) Να εμφανίζει το πρώτο μάθημα που ο κάθε μαθητής βελτίωσε την επίδοση του σε σχέση με το προηγούμενο μάθημα

ε) Να ζητά ένα όνομα μαθητή και ένα μάθημα, και να εμφανίζει το βαθμό που πέτυχε στις εξετάσεις.

στ) Να εμφανίζει τον χαρακτηρισμό για κάθε μαθητή σύμφωνα με τον επόμενο πίνακα:

0-2 μαθήματα με βαθμό >75 Μέτριος
3-4 μαθήματα με βαθμό >75 Καλός
5-6 μαθήματα με βαθμό >75 Άριστος

ζ) Να εμφανίζει τους μαθητές σε αλφαβητική σειρά και στη συνέχεια για κάθε μαθητή τους βαθμούς του σε φθίνουσα σειρά, παράλληλα με την εμφάνιση των ονομάτων των μαθημάτων.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ μαθητές_extreme
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,k,Μ,θ1,θ2
  ΠΡΑΓΜΑΤΙΚΕΣ:ΒΑΘ[10,6],Σ,ΜΟ[10],temp,temp3,max,max2
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΜ[10], ΜΑΘ[6],temp2,ΜΘ_max,ON_max,ΜΑΘΤ,ΜΑΘΜ,ΜΑΘ2[6,10]
  ΛΟΓΙΚΕΣ: βρ
ΑΡΧΗ

! ----- α ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε όνομα ',i,'ου μαθητή'
    ΔΙΑΒΑΣΕ ΟΝΜ[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'Δώσε βαθμό του',ΟΝΜ[i],'στο μάθημα',j
      ΔΙΑΒΑΣΕ ΒΑΘ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΡΑΨΕ 'Δώσε όνομα ',j,'ου μαθηματος'
    ΔΙΑΒΑΣΕ ΜΑΘ[j]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- β ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Σ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      Σ <-- Σ+ ΒΑΘ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ[i] <-- Σ/6
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 10 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ΜΟ[j-1]<ΜΟ[j] ΤΟΤΕ
        temp <-- ΜΟ[j-1]
        ΜΟ[j-1] <-- ΜΟ[j]
        ΜΟ[j] <-- temp
        temp2 <-- ΟΝΜ[j-1]
        ΟΝΜ[j-1] <-- ΟΝΜ[j]
        ΟΝΜ[j] <-- temp2
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 6
          temp3 <-- ΒΑΘ[j-1,k]
          ΒΑΘ[j-1,k] <-- ΒΑΘ[j,k]
          ΒΑΘ[j,k] <-- temp3
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 2
    max <-- ΒΑΘ[i,1]
    ΜΘ_max <-- ΜΑΘ[1]
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 6
      ΑΝ ΒΑΘ[i,j]>max ΤΟΤΕ
        max <-- ΒΑΘ[i,j]
        ΜΘ_max <-- ΜΑΘ[j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ i,'ο μεγαλύτερο ΜΟ έχει ο', ΟΝΜ[i],'με μεγαλύτερο του βαθμό στο μαθημα',ΜΘ_max
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- γ ερωτημα ------
  max2 <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Μ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ ΒΑΘ[i,j]>80 ΤΟΤΕ
        Μ <-- Μ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ Μ>=2 ΤΟΤΕ
      ΑΝ ΜΟ[i]>max2 ΤΟΤΕ
        max2 <-- ΜΟ[i]
        ON_max <-- ΟΝΜ[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ max2

! ----- δ ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    βρ <-- ψευδής
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 6
      ΑΝ ( ΒΑΘ[i,j]>ΒΑΘ[i,j-1]) ΚΑΙ (βρ=ψευδής) ΤΟΤΕ
        ΓΡΑΨΕ 'Στο μάθημα',ΜΑΘ[j],'βελτιώθηκε για πρωτη φορά ή επίδοση του',ΟΝΜ[i]
        βρ <-- αληθής
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- ε ερωτημα ------
  ΓΡΑΨΕ 'δώσε όνομα μαθητή και μαθήματος προς αναζήτηση'
  ΔΙΑΒΑΣΕ ΜΑΘΤ,ΜΑΘΜ

  i <-- 1
  βρ <-- ψευδής
  ΟΣΟ (i<=10) ΚΑΙ (βρ=ψευδής) ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΟΝΜ[i]=ΜΑΘΤ ΤΟΤΕ
      θ1 <-- i
      βρ <-- αληθής
    ΤΕΛΟΣ_ΑΝ
    i <-- i+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  j <-- 1
  βρ <-- ψευδής
  ΟΣΟ (j<=10) ΚΑΙ (βρ=ψευδής) ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΜΑΘ[j]=ΜΑΘΜ ΤΟΤΕ
      θ2 <-- j
      βρ <-- αληθής
    ΤΕΛΟΣ_ΑΝ
    j <-- j+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ ΒΑΘ[θ1,θ2]

 ! ----- στ ερωτημα ------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Μ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ ΒΑΘ[i,j]>75 ΤΟΤΕ
        Μ <-- Μ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΟΝΜ[i],'είναι'
    ΑΝ Μ<=2 ΤΟΤΕ
      ΓΡΑΨΕ 'Μέτριος'
    ΑΛΛΙΩΣ_ΑΝ Μ<=4 ΤΟΤΕ
      ΓΡΑΨΕ 'Καλός'
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Αριστος'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ! ----- ζ ερωτημα ------
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 10 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ΟΝΜ[j-1]>ΟΝΜ[j] ΤΟΤΕ
        temp2 <-- ΟΝΜ[j-1]
        ΟΝΜ[j-1] <-- ΟΝΜ[j]
        ΟΝΜ[j] <-- temp2
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 6
          temp3 <-- ΒΑΘ[j-1,k]
          ΒΑΘ[j-1,k] <-- ΒΑΘ[j,k]
          ΒΑΘ[j,k] <-- temp3
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
    ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
      ΜΑΘ2[i,j] <-- ΜΑΘ[j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 6
      ΓΙΑ k ΑΠΟ 6 ΜΕΧΡΙ j ΜΕ ΒΗΜΑ -1
        ΑΝ ΒΑθ[i,k-1]<ΒΑθ[i,k] ΤΟΤΕ
          temp3 <-- ΒΑθ[i,k-1]
          ΒΑθ[i,k-1] <-- ΒΑθ[i,k]
          ΒΑθ[i,k] <-- temp3
          temp2 <-- ΜΑΘ2[i,k-1]
          ΜΑθ2[i,k-1] <-- ΜΑθ2[i,k]
          ΜΑθ2[i,k] <-- temp2
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ ΟΝΜ[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ  ΒΑθ[i,j],'στο μαθημα',ΜΑθ2[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
     
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters