Τώρα είναι Παρ 29 Μάιος 2020 03:36 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Formula 1
ΔημοσίευσηΔημοσιεύτηκε: Τετ 13 Σεπ 2006 12:37 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Σε μια χρονιά η Formula 1 έχει 18 αγώνες στους οποίους συμμετέχουν 11 ομάδες με 2 οδηγούς η κάθε μια. Σε κάθε αγώνα οι οδηγοί βαθμολογούνται σύμφωνα με τη σειρά κατάταξης. Βαθμολογούνται μόνο οι 8 πρώτοι που τερματίζουν με αντίστοιχη βαθμολογία 10, 8, 6, 5, 4, 3, 2, 1. Στο τέλος της χρονιάς στέφεται πρωταθλητής ο οδηγός που έχει συγκεντρώσει την υψηλότερη βαθμολογία και πρωταθλήτρια, η ομάδα της οποίας οι οδηγοί έχουν συγκεντρώσει συνολικά τους περισσότερους βαθμούς. Να γίνει αλγόριθμος που να:

α) Διαβάζει τα ονόματα των ομάδων και των οδηγών και να τα αποθηκεύει αντίστοιχα σε 1 μονοδιάστατο και 1 δισδιάστατο πίνακα πχ ομάδα[11] και οδηγός[11,2].

β) Για καθέναν από τους 18 αγώνες να διαβάζει τη σειρά κατάταξης
(πχ αγώνας 1)
1 Michael Schumacher
2 Fernando Alonso
3 Kimi Räikkönen
4 Giancarlo Fisichella
5 Felipe Massa
6 Jenson Button
7 Juan Pablo Montoya
8 Rubens Barrichello

(πχ αγώνας 2)
1 Fernando Alonso
2 Michael Schumacher
3 Ralf Schumacher
4 Felipe Massa
5 Jacques Villeneuve
6 Nick Heidfeld
7 David Coulthard
8 Mark Webber

Και να διατηρεί τη συνολική βαθμολογία των οδηγών

γ) Στο τέλος της χρονιάς να ταξινομεί τα ονόματα των οδηγών σύμφωνα με την τελική τους βαθμολογία και να εμφανίζει το όνομα του πρωταθλητή.

δ) Να εμφανίζει τα ονόματα των ομάδων ταξινομημένα ανάλογα με τη συνολική τους βαθμολογία, δηλαδή το σύνολο των βαθμών των δύο οδηγών της, καθώς και το όνομα της πρωταθλήτριας ομάδας.


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ formula1
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  i,j,ΣΒ_ΟΔ[11,2],αγ,κατ,κ,ΣΒ[22],temp,ΣΟΜ[22]
  ΧΑΡΑΚΤΗΡΕΣ: ομαδα[11],οδηγος[11,2],ονομα,ΟΔΓ[22],temp2
ΑΡΧΗ

! ------- α ερωτημα -------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
    ΓΡΑΨΕ 'Δώσε όνομα ομάδας ',i
    ΔΙΑΒΑΣΕ ομαδα[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      ΓΡΑΨΕ 'Δώσε όνομα ',j,'ου οδηγου'
      ΔΙΑΒΑΣΕ οδηγος[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ------- β ερωτημα -------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      ΣΒ_ΟΔ[i,j] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ αγ ΑΠΟ 1 ΜΕΧΡΙ 18
    ΓΙΑ κατ ΑΠΟ 1 ΜΕΧΡΙ 8
      ΓΡΑΨΕ 'Δώσε όνομα οδηγου που τερματησε ',κατ,'ος στον αγωνα',αγ
      ΔΙΑΒΑΣΕ ονομα
      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
        ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
          ΑΝ ονομα=οδηγος[i,j] ΤΟΤΕ
            ΑΝ κατ=1 ΤΟΤΕ
              ΣΒ_ΟΔ[i,j] <-- ΣΒ_ΟΔ[i,j]+10
            ΑΛΛΙΩΣ_ΑΝ κατ=2 ΤΟΤΕ
              ΣΒ_ΟΔ[i,j] <-- ΣΒ_ΟΔ[i,j]+8
            ΑΛΛΙΩΣ
              ΣΒ_ΟΔ[i,j] <-- ΣΒ_ΟΔ[i,j]+(9-κατ)
            ΤΕΛΟΣ_ΑΝ
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ------- γ ερωτημα -------
  κ <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      κ <-- κ+1
      ΟΔΓ[κ] <-- οδηγος[i,j]
      ΣΒ[κ] <-- ΣΒ_ΟΔ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 22
    ΓΙΑ j ΑΠΟ 22 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ΣΒ[j-1]<ΣΒ[j] ΤΟΤΕ
        temp <-- ΣΒ[j-1]
        ΣΒ[j-1] <-- ΣΒ[j]
        ΣΒ[j] <-- temp
        temp2 <-- ΟΔΓ[j-1]
        ΟΔΓ[j-1] <-- ΟΔΓ[j]
        ΟΔΓ[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'πρωταθλητης ειναι ο',ΟΔΓ[1]

! ------- δ ερωτημα -------
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
    ΣΟΜ[i] <-- ΣΒ_ΟΔ[i,1]+ ΣΒ_ΟΔ[i,2]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 11
    ΓΙΑ j ΑΠΟ 11 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
        ΑΝ ΣΟΜ[j-1]<ΣΟΜ[j] ΤΟΤΕ
        temp <-- ΣΟΜ[j-1]
        ΣΟΜ[j-1] <-- ΣΟΜ[j]
        ΣΟΜ[j] <-- temp
        temp2 <-- ομαδα[j-1]
        ομαδα[j-1] <-- ομαδα[j]
        ομαδα[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 11
    ΓΡΑΨΕ ομαδα[i],'κατεταγει',i,'η'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'πρωταθλητρια ομαδα ειναι η',ομαδα[1]

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                                                        
 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters