Τώρα είναι Παρ 29 Μάιος 2020 04:15 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Eurovision
ΔημοσίευσηΔημοσιεύτηκε: Τετ 15 Μαρ 2006 12:10 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Σε ένα διεθνή διαγωνισμό τραγουδιού συμμετέχουν 25 χώρες. Να αναπτυχθεί αλγόριθμος ο οποίος:
α) Διαβάζει τα ονόματα των συμμετεχόντων χωρών και τα καταχωρεί σε κατάλληλο πίνακα Ο[25].
β) Διαβάζει τη βαθμολογία που έλαβε η κάθε χώρα από όλες τις υπόλοιπες και τους καταχωρεί σε κατάλληλα ορισμένο δισδιάστατο πίνακα Β[25,25]. (Η κύρια διαγώνιος του πίνακα πρέπει να καταληφθεί από μηδενικά γιατί καμία χώρα δε βαθμολογεί τον εαυτό της).
γ) Εμφανίζει την χώρα που έλαβε τη μεγαλύτερη βαθμολογία στο σύνολο.
δ) Εμφανίζει τη χώρα που έδωσε τη μεγαλύτερη βαθμολογία στην Ελλάδα.
ε) Εμφανίζει (αν υπάρχουν) το πλήθος και τα ονόματα των χωρών που δεν πήραν ούτε ένα βαθμό
Σημείωση: Η αποδεκτές βαθμολογίες πρέπει να είναι ακέραιες με εύρος απο 1 μέχρι 12 (εκτός απο΄το βαθμό 8 ).

Syntax: [ Download ] [ Hide ]
!Σε ένα διεθνή διαγωνισμό τραγουδιού συμμετέχουν 25 χώρες. Να αναπτυχθεί αλγόριθμος ο οποίος:
!α) Διαβάζει τα ονόματα των συμμετεχόντων χωρών και τα καταχωρεί σε κατάλληλο πίνακα Ο[25].
!β) Διαβάζει τη βαθμολογία που έλαβε η κάθε χώρα από όλες τις υπόλοιπες και τους καταχωρεί
!σε κατάλληλα ορισμένο δισδιάστατο πίνακα Β[25,25].
!γ) Εμφανίζει την χώρα που έλαβε τη μεγαλύτερη βαθμολογία στο σύνολο.
!δ) Εμφανίζει τη χώρα που έδωσε την μεγαλύτερη βαθμολογία στην Ελλάδα.
!ε) Εμφανίζει (αν υπάρχουν) το πλήθος και τα ονόματα των χωρών που δεν πήραν ούτε έναν βαθμό.
!Σημείωση:Θεωρούμε ότι η βαθμολογίες είναι ακέραιες με έυρος από 1 μέχρι 12 (εκτός από το βαθμό 8).
!Η κύρια διαγώνιος του πίνακα Β θα καταληφθεί από 0 γιατί καμία χώρα δε βαθμολογεί τον εαυτό της.

ΠΡΟΓΡΑΜΜΑ EUROVISION
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Ο[25]
  ΑΚΕΡΑΙΕΣ: Β[25,25],ΣΧ[25],max1,maxpos1,max2,maxpos2,i,j,GRpos,plithos
  ΛΟΓΙΚΕΣ: found
ΑΡΧΗ
!Εισαγωγή δεδομένων
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25
    ΓΡΑΨΕ 'Δώσε το ονομα της',i,'ης διαγωνιζόμενης χώρας'
    ΔΙΑΒΑΣΕ Ο[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 25
      ΑΝ i=j ΤΟΤΕ
        Β[i,j] <-- 0
      ΑΛΛΙΩΣ
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΓΡΑΨΕ_ 'Δώσε τη βαθμολογία της'[i],'από την'[j]
          ΔΙΑΒΑΣΕ Β[i,j]
        ΜΕΧΡΙΣ_ΟΤΟΥ Β[i,j]>0 ΚΑΙ Β[i,j]<=12 ΚΑΙ Β[i,j]<>8
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Υπολογισμός νικήτριας χώρας
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25
    ΣΧ[i] <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 25
      ΣΧ[i] <-- ΣΧ[i]+Β[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max1 <-- ΣΧ[1]
  maxpos1 <-- 1
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 25
    ΑΝ ΣΧ[i]>max1 ΤΟΤΕ
      max1 <-- ΣΧ[i]
      maxpos1 <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η νικήτρια χώρα είναι η'[maxpos1]

!Εντοπισμός χώρας που έδωσε τη μεγαλύτερη βαθμολογία στην Ελλάδα
  i <-- 1
  found <-- ΨΕΥΔΗΣ
  ΟΣΟ i<=25 ΚΑΙ found= ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΑΝ Ο[i]='Ελλάς' ΤΟΤΕ
      found <-- ΑΛΗΘΗΣ
      GRpos <-- i             !Βρήκαμε σε ποια θέση του πίνακα είναι η Ελλάδα (GRpos)
    ΑΛΛΙΩΣ                    !Σε αυτή τη γραμμή ψάχνουμε για μέγιστο.Η αντίστοιχη
      i <-- i+1               !στήλη θα μας υποδείξει τη χώρα που έδωσε το μέγιστο βαθμό
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  max2 <-- Β[GRpos,1]
  maxpos2 <-- 1
  ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 25
    ΑΝ Β[GRpos,j]>max2 ΤΟΤΕ
      max2 <-- Β[GRpos,j]
      maxpos2 <-- j            !maxpos2 είναι η θέση της χώρας που
    ΤΕΛΟΣ_ΑΝ                   !μας έδωσε το μεγαλύτερο βαθμό
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Η χώρα που μας έδωσε τη μεγαλύτερη βαθμολογία είναι η'[maxpos2]

!Αναζήτηση χωρών που δεν πήραν ούτε έναν βαθμό
  plithos <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 25
    ΑΝ ΣΧ[i]=0 ΤΟΤΕ
      plithos <-- plithos+1
      ΓΡΑΨΕ 'Η χώρα'[i],'δεν πήρε ούτε έναν βαθμό'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ plithos>0 ΤΟΤΕ
    ΓΡΑΨΕ plithos,'συνολικά χώρες δεν πήραν ούτε έναν βαθμό'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δεν υπάρχει χώρα που να μην πήρε ούτε έναν βαθμό'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters