Τώρα είναι Παρ 29 Μάιος 2020 04:27 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Συχνότητα εμφάνισης Βαθμών
ΔημοσίευσηΔημοσιεύτηκε: Τετ 08 Μαρ 2006 05:07 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 21 Ιούλ 2005 10:34 am
Δημοσιεύσεις: 11
Τοποθεσία: ΚΑΣΤΟΡΙΑ
Να αναπτυχθεί αλγόριθμος που διαβάζει πίνακα βαθμολογιών από 30 μαθητές. Οι βαθμολογίες είναι μόνο ακέραιες με εύρος από 1 μέχρι 20.
Να βρεθεί πόσες φορές επαναλαμβάνεται η κάθε βαθμολογία,
καθώς επίσης και ο βαθμός με τη μεγαλύτερη συχνότητα εμφάνισης.

Σημείωση: Προσοχή πρέπει να δοθεί στην έμμεση διευθυνσιοδότηση τον θέσεων του πίνακα συχνοτήτων ΣΥΧ[Β[i]].

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Συχνότητα_Εμφάνισης_Βαθμών
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,max,grade,Β[30],ΣΥΧ[20]
ΑΡΧΗ

!Εισαγωγή του πίνακα βαθμολογιών
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Δώσε το βαθμό του',i,'ου μαθητή'
      ΔΙΑΒΑΣΕ Β[i]
    ΜΕΧΡΙΣ_ΟΤΟΥ Β[i]>0 ΚΑΙ (Β[i]<=20)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Μηδενισμός του πίνακα συχνοτήτων
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΣΥΧ[i] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Υπολογισμός της συχνότητας εμφάνισης του κάθε βαθμού
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΣΥΧ[Β[i]] <-- ΣΥΧ[Β[i]] + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Εντοπισμός της μέγιστης συχνότητας εμφάνισης κάποιου βαθμού
  max <-- ΣΥΧ[1]
  grade <-- 1
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΑΝ ΣΥΧ[i]>max ΤΟΤΕ
      max <-- ΣΥΧ[i]
      grade <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Παρουσίαση αποτελεσμάτων
  ΓΡΑΨΕ 'Ο βαθμός με τη μεγαλύτερη συχνότητα εμφάνισης είναι ο', grade, 'με', max, 'εμφανίσεις'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters