Τώρα είναι Παρ 29 Μάιος 2020 04:08 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΤΡΙΓΩΝΟ PASCAL
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 04 Φεβ 2006 10:53 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Φεβ 2006 01:44 pm
Δημοσιεύσεις: 2
To παρακάτω θέμα αποτέλεσε θέμα στις εξετάσεις των Ηλεκτρολόγων Μηχανικών και Μηχανικών Η/Υ του Ε.Μ.Π.:

Τριγωνο Pascal λέγεται ένα τρίγωνο με φυσικούς αριθμούς στο οποίο :
α)Η i-οστή σειρά έχει i αριθμούς .
β)Ο πρώτος και ο τελευταίος αριθμός κάθε σειράς είναι 1.
γ)Για τους υπόλοιπους αριθμούς x ισχύει: ο x ισούται με το άθροισμα του αμέσως ανώτερου του (στην ίδια στήλη) y συν τον αμέσως προηγουμενο του y
(στην ίδια σειρά με το y).

Π.χ.
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Να γράψεται ένα πρόγραμμα που
α)Ρωτάει το χρήστη για το n = αριθμός των σειρών του τριγώνου (το πολύ 15)
β) Τυπώνει στην οθόνη τις n πρώτες σειρές του τριγώνου και
γ)Επαναλαμβάνει τη διαδικασία αν ο χρήστης το επιθυμεί.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 05 Φεβ 2006 03:44 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Το προβλημα έχει αναφερθεί εδώ:

http://www.spinet.gr/glossomatheia/programs/viewtopic.php?t=162

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: επίλυση με αναδρομή
ΔημοσίευσηΔημοσιεύτηκε: Παρ 10 Φεβ 2006 01:37 am 
επίλυση με αναδρομή:
--------------------------------------------------------------------------------


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ τρίγωνο_πασκαλ
ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ: θεση, σειρα , αποτελεσμα

ΑΡΧΗ
  ΓΡΑΨΕ 'δωσε σειρα του τριγώνου πασκαλ '
  διάβασε σειρα
  ΓΡΑΨΕ ' δωσε θεση του ζητούμενου αριθμού μέσα στην σειρά '
  ΔΙΑΒΑΣΕ  θέση
  αποτέλεσμα <-- α(σειρά,θέση)
  αν αποτέλεσμα <>0 τότε
    γράψε αποτέλεσμα
  αλλιώς
    γράψε 'δεν ορίζεται αυτό το στοιχείο στο τρίγωνο πασκαλ '
  τελος_αν
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



! κάθε στοιχείο του τριγώνου ορίζεται ως το άθροισμα δυο στοιχείων
! της προηγούμενης σειράς, αυτού που αντιστοιχεί στην ίδια θέση και
! αυτού που βρίσκεται μια θέση πιο αριστερά. Αυτός ο συλλογισμός
! μπορεί πολύ εύκολα να υλοποιηθεί με αναδρομικό ορισμό της συνάρτησης
! που παράγει το κάθε στοιχείο του τριγώνου.
ΣΥΝΑΡΤΗΣΗ α(σειρα, θεση): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: θεση, σειρα

ΑΡΧΗ
  ΑΝ θεση>σειρα ΤΟΤΕ
    α <-- 0  !δεν οριζεται
  ΑΛΛΙΩΣ
    ΑΝ (θεση=1) η (σειρα=θεση) τοτε
      α <-- 1
    αλλιώς
      α <-- α(σειρα-1,θεση) + α(σειρα-1,θεση-1)
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 


-----------------------------------------------------------------------------
http://giorghatzis.tripod.com


Κορυφή
  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters