Τώρα είναι Πέμ 04 Ιουν 2020 06:33 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 31 Μάιος 2008 09:42 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 01:29 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
!ΤΑΞΙΝΟΜΗΣΗ ΔΙΣΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ ΑΚΕΡΑΙΩΝ π.χ 5x4
!ΜΕ ΚΛΕΙΔΙ ΚΑΠΟΙΑ ΑΠΟ ΤΙΣ ΣΕΙΡΕΣ ΤΟΥ

!ΕΙΜΑΙ ΑΝΑΛΥΤΗΣ ΠΡΟΓΡΑΜΜΑΤΙΣΤΗΣ ΚΑΙ ΜΗΧΑΝΙΚΟΣ ΔΙΚΤΥΩΝ-ΤΗΛΕΠΙΚΟΙΝΩΝΙΩΝ
!ΕΧΩ ΚΑΝΕΙ ΜΕΤΑΠΤΥΧΙΑΚΑ ΣΕ ΤΗΛΕΜΑΤΙΚΗ ΣΤΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΤΟΥ SURREY ΣΤΗΝ ΑΓΓΛΙΑ
!ΜΕ ΤΗΝ ΕΜΠΕΙΡΙΑ ΜΟΥ (ΠΛΕΟΝ 30 ΧΡΟΝΙΑ) ΚΑΙ ΤΙΣ ΓΝΩΣΕΙΣ ΜΟΥ ΜΠΟΡΩ ΝΑ ΒΟΗΘΗΣΩ  ΟΣΟΥΣ ΕΠΙΘΥΜΟΥΝ
!ΝΑ ΑΠΑΛΛΑΓΟΥΝ ΑΠΟ ΤΟ ΦΟΒΟ, ΤΟ ΑΓΧΟΣ ΚΑΙ ΤΟΝ ΠΑΝΙΚΟ
!ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΚΑΙ ΝΑ ΔΩΣΟΥΝ ΤΟ ΜΑΘΗΜΑ
!ΤΗΣ ΑΝΑΠΤΥΞΗΣ ΕΦΑΡΜΟΓΩΝ ΜΕ ΣΙΓΟΥΡΙΑ, ΕΛΠΙΔΑ ΚΑΙ ΑΙΣΙΟΔΟΞΙΑ
!ΟΤΙ ΘΑ ΠΕΤΥΧΟΥΝ ΕΝΑ ΠΟΛΥ ΚΑΛΟ ΒΑΘΜΟ.
!ΤΗΛ. 6983511222


ΠΡΟΓΡΑΜΜΑ TAJ_2_PIN_KLEI_SEIRA
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : P[5,4],I,J,K,L,T


ΑΡΧΗ
  ! ΓΕΜΙΣΜΑ ΤΟΥ ΠΙΝΑΚΑ
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5 ! ΣΕΙΡΕΣ
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 4 ! ΣΤΗΛΕΣ
      ΔΙΑΒΑΣΕ P[I,J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !ΑΠΕΙΚΟΝΙΣΗ ΤΟΥ ΠΙΝΑΚΑ ΚΑΤΑ ΣΕΙΡΕΣ ΚΑΙ ΣΤΗΛΕΣ
  ΓΡΑΨΕ '---------------'

  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ P[I,1],' ',P[I,2],' ',P[I,3],' ',P[I,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


  ! ΠΑΡΕ ΑΠΟ ΤΟΝ ΧΡΗΣΤΗ ΤΗΝ ΣΕΙΡΑ
  ! ΒΑΣΕΙ ΤΗΣ ΟΠΟΙΑΣ ΘΕΛΕΙΣ ΝΑ
  ! ΓΙΝΕΙ Η ΤΑΞΙΝΟΜΗΣΗ
  ΓΡΑΨΕ '--------------'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΕΝΑ ΑΡΙΘΜΟ ΑΠΟ 1 ΜΕΧΡΙ 5 ...'
    ΔΙΑΒΑΣΕ K
  ΜΕΧΡΙΣ_ΟΤΟΥ K>=1 ΚΑΙ K<=5

  ! ΤΑΞΙΝΟΜΗΣΗ ΤΟΥ ΠΙΝΑΚΑ ΒΑΣΕΙ ΤΗΣ ΣΕΙΡΑΣ Κ
  ΓΙΑ I ΑΠΟ 2 ΜΕΧΡΙ 4
    ΓΙΑ J ΑΠΟ 4 ΜΕΧΡΙ I ΜΕ ΒΗΜΑ -1
      ΑΝ P[K,J-1]> P[K,J] ΤΟΤΕ   ! ΑΥΞΟΥΣΑ ΤΑΞΙΝΟΜΗΣΗ
        ! ΘΑ ΔΙΑΤΗΡΗΣΟΥΜΕ ΤΗΝ ΣΧΕΣΗ ΜΕΤΑΞΥ
        ! ΤΩΝ ΣΤΟΙΧΕΙΩΝ ΠΟΥ ΑΝΗΚΟΥΝ ΣΕ ΔΙΑΦΟΡΕΤΙΚΕΣ
        ! ΣΕΙΡΕΣ ΑΛΛΑ ΣΤΗΝ ΙΔΙΑ ΣΤΗΛΗ
        ΓΙΑ L ΑΠΟ 1 ΜΕΧΡΙ 5 ! ΟΣΕΣ ΚΑΙ ΟΙ ΣΕΙΡΕΣ
          T <-- P[L,J-1]
          P[L,J-1] <-- P[L,J]
          P[L,J] <-- T
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !ΣΚΕΦΤΕΙΤΕ ΤΟΝ ΠΙΝΑΚΑ 5Χ4
  !ΠΑΡΤΕ ΑΣ ΠΟΥΜΕ ΤΗΝ ΠΡΩΤΗ ΣΕΙΡΑ
  !ΚΑΙ ΑΝΤΙΓΡΑΨΤΕ ΤΗΝ ΔΕΞΙΑ ΤΟΥ ΠΙΝΑΚΑ
  !ΕΣΤΩ ΟΤΙ ΘΕΛΟΥΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ ΤΟΝ
  !ΕΝ ΛΟΓΩ ΠΙΝΑΚΑ ΜΕ ΚΛΕΙΔΙ ΤΗΝ ΠΡΩΤΗ ΣΕΙΡΑ
  !ΟΥΣΙΑΣΤΙΚΑ ΤΟ ΠΡΟΒΛΗΜΑ ΕΓΚΕΙΤΑΙ ΣΤΟ ΝΑ
  !ΤΑΞΙΝΟΜΗΣΟΥΜΕ ΤΑ ΣΤΟΙΧΕΙΑ ΤΗΣ ΠΡΩΤΗΣ ΣΕΙΡΑΣ (ΑΡΑ 4)
  ! Α Λ Λ Α ΠΑΡΑΛΛΗΛΑ ΝΑ ΔΙΑΤΗΡΗΣΟΥΜΕ ΤΗΝ ΣΧΕΣΗ ΤΟΥΣ
  !ΜΕ ΤΑ ΣΤΟΙΧΕΙΑ ΤΨΝ ΑΛΛΩΝ ΣΕΙΡΩΝ ΚΑΙ ΤΗΣ ΙΔΙΑΣ
  !ΤΡΕΧΟΥΣΑΣ ΣΤΗΛΗΣ
  !ΕΥΚΟΛΟ ?

  !ΑΠΕΙΚΟΝΙΣΗ ΤΗΣ ΤΑΞΙΝΟΜΗΜΕΝΗΣ ΣΕΙΡΑΣ Κ

  ΓΡΑΨΕ 'ΑΠΕΙΚΟΝΙΣΗ ΤΑΞΙΝΟΜΗΜΕΝΗΣ ΣΕΙΡΑΣ ',K

  ΓΡΑΨΕ P[K,1],' ',P[K,2],' ',P[K,3],' ',P[K,4]

  !ΑΠΕΙΚΟΝΙΣΗ ΟΛΟΥ ΤΟΥ ΠΙΝΑΚΑ
  ΓΡΑΨΕ 'ΑΠΕΙΚΟΝΙΣΗ ΤΑΞΙΝΟΜΗΜΕΝΟΥ ΠΙΝΑΚΑ...'
  ΓΡΑΨΕ 'ΠΕΟΣΕΞΤΕ ΟΤΙ Η ΣΧΕΣΗ ΜΕΤΑΞΥ ΤΩΝ ΣΤΟΙΧΕΙΩΝ'
  ΓΡΑΨΕ 'ΤΩΝ ΣΤΗΛΩΝ ΔΕΝ ΕΣΠΑΣΕ ....'

  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ P[I,1],' ',P[I,2],' ',P[I,3],' ',P[I,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ  TAJ_2_PIN_KLEI_SEIRA


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters