Τώρα είναι Δευτ 01 Ιουν 2020 08:06 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 30 Μάιος 2008 07:15 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 30 Μάιος 2008 01:29 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
! ΓΕΜΙΖΟΥΜΕ ΕΝΑ ΠΙΝΑΚΑ ΑΚΕΡΑΙΩΝ P[5,4]
! ΚΑΙ ΣΤΗ ΣΥΝΕΧΕΙΑ TON ΤΑΞΙΝΟΜΟΥΜΕ
! ΚΑΤ' ΑΥΞΟΥΣΑ ΣΕΙΡΑ ΜΕ ΚΛΕΙΔΙ ΤΗΝ ΔΕΥΤΕΡΗ ΣΤΗΛΗ

!ΕΙΜΑΙ ΑΝΑΛΥΤΗΣ ΠΡΟΓΡΑΜΜΑΤΙΣΤΗΣ ΚΑΙ ΜΗΧΑΝΙΚΟΣ ΔΙΚΤΥΩΝ-ΤΗΛΕΠΙΚΟΙΝΩΝΙΩΝ
!ΕΧΩ ΚΑΝΕΙ ΜΕΤΑΠΤΥΧΙΑΚΑ ΣΕ ΤΗΛΕΜΑΤΙΚΗ ΣΤΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΤΟΥ SURREY ΣΤΗΝ ΑΓΓΛΙΑ
!ΜΕ ΤΗΝ ΕΜΠΕΙΡΙΑ ΜΟΥ (ΠΛΕΟΝ 30 ΧΡΟΝΙΑ) ΚΑΙ ΤΙΣ ΓΝΩΣΕΙΣ ΜΟΥ ΜΠΟΡΩ ΝΑ ΒΟΗΘΗΣΩ ΟΣΟΥΣ ΕΠΙΘΥΜΟΥΝ
!ΝΑ ΑΠΑΛΛΑΓΟΥΝ ΑΠΟ ΤΟ ΦΟΒΟ, ΤΟ ΑΓΧΟΣ ΚΑΙ ΤΟΝ ΠΑΝΙΚΟ
!ΣΤΙΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΚΑΙ ΝΑ ΔΩΣΟΥΝ ΤΟ ΜΑΘΗΜΑ
!ΤΗΣ ΑΝΑΠΤΥΞΗΣ ΕΦΑΡΜΟΓΩΝ ΜΕ ΣΙΓΟΥΡΙΑ, ΕΛΠΙΔΑ ΚΑΙ ΑΙΣΙΟΔΟΞΙΑ
!ΟΤΙ ΘΑ ΠΕΤΥΧΟΥΝ ΕΝΑ ΠΟΛΥ ΚΑΛΟ ΒΑΘΜΟ.
!ΤΗΛ. 6983511222

ΠΡΟΓΡΑΜΜΑ TAJINOMHSH
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : P[5,4],I,J,K,T

ΑΡΧΗ

! ΓΕΜΙΣΜΑ ΤΟΥ ΠΙΝΑΚΑ
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 4
      ΔΙΑΒΑΣΕ P[I,J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΤΑΞΙΝΟΜΗΣΗ ΤΟΥ ΠΙΝΑΚΑ
! ΜΕ ΚΛΕΙΔΙ ΤΗΝ ΔΕΥΤΕΡΗ ΣΤΗΛΗ
  ΓΙΑ I ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ J ΑΠΟ 5 ΜΕΧΡΙ I ΜΕ ΒΗΜΑ -1
      ΑΝ P[J-1,2]>P[J,2] ΤΟΤΕ

      ! ΑΝ ΘΕΛΑΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ ΜΕ ΚΛΕΙΔΙ
      ! ΤΗΝ ΤΡΙΤΗ ΣΤΗΛΗ ΤΟΤΕ ΘΑ ΓΡΑΦΑΜΕ
      ! ΑΝ P[J-1,3]>P[J,3] κ.ο.κ

        ΓΙΑ K ΑΠΟ 1 ΜΕΧΡΙ 4                        
          T <-- P[J-1,K]
          P[J-1,K] <-- P[J,K]
          P[J,K] <-- T
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! ΑΠΕΙΚΟΝΙΣΗ ΤΗΣ ΤΑΞΙΝΟΜΗΜΕΝΗΣ
  ! ΔΕΥΤΕΡΗΣ ΣΤΗΛΗΣ

  ΓΡΑΨΕ '---------------------'

  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ P[I,2]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters