Τώρα είναι Πέμ 04 Ιουν 2020 01:42 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 01 Ιουν 2007 01:56 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 01 Ιουν 2007 01:36 pm
Δημοσιεύσεις: 1
ΝΑ ΓΡΑΦΕΙ ΠΡΟΓΡΑΜΜΑ ΠΟΥ:
1.ΔΙΑΒΑΖΕΙ ΚΑΙ ΚΑΤΑΧΩΡΕΙ ΣΕ ΕΝΑΝ ΜΟΝΟΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ,ΤΑ ΟΝΟΜΑΤΑ 100 ΜΑΘΗΤΩΝ
2.ΔΙΑΒΑΖΕΙ ΚΑΙ ΚΑΤΑΧΩΡΕΙ ΣΕ ΕΝΑΝ ΔΙΣΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ ΤΟΥΣ ΒΑΘΜΟΥΣ ΤΩΝ 100 ΜΑΘΗΤΩΝ,ΣΤΑ ΜΑΘΗΜΑΤΑ ΚΑΤΕΥΘΥΝΣΗΣ
3.ΤΑΞΙΝΟΜΕΙ ΑΛΦΑΒΗΤΙΚΑ ΤΑ ΟΝΟΜΑΤΑ ΚΑΙ ΤΑΥΤΟΧΡΟΝΑ ΑΛΛΑΖΟΥΝ ΚΑΙ ΟΙ ΑΝΤΙΣΤΟΙΧΟΙ ΒΑΘΜΟΙ ΑΠΟ ΤΟΝ ΔΙΣΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ ΤΟΥ ΕΡΩΤΗΜΑΤΟΣ 2

_________________
jtsc21


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 07 Ιουν 2007 09:31 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 27 Ιαν 2007 02:27 pm
Δημοσιεύσεις: 4
Τοποθεσία: Κομοτηνή
Προσπάθησα να το φτιάξω! Νομίζω ότι δουλεύει μια χαρά...

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΤΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ[100], Χ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘΜΟΣ[100,4], Υ
  ΑΚΕΡΑΙΕΣ: Ι, K, J
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ'ΔΩΣΕ ΤΟ ΟΝΟΜΑ ΤΟΥ', Ι,'ΟΥ ΜΑΘΗΤΗ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
    ΓΡΑΨΕ'ΔΩΣΕ ΒΑΘΜΟ ΣΤΑ ΜΑΘΗΜΑΤΙΚΑ ΚΑΤΕΥΘΥΝΣΗΣ'
    ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ[Ι,1]
    ΓΡΑΨΕ'ΔΩΣΕ ΒΑΘΜΟ ΣΤΗΝ ΦΥΣΙΚΗ ΚΑΤΕΥΘΥΝΣΗΣ'
    ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ[Ι,2]
    ΓΡΑΨΕ'ΔΩΣΕ ΒΑΘΜΟ ΣΤΗΝ ΔΙΟΙΚΗΣΗ'
    ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ[Ι,3]
    ΓΡΑΨΕ'ΔΩΣΕ ΒΑΘΜΟ ΣΤΟΝ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟ'
    ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ[Ι,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ J ΑΠΟ 100 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
      ΑΝ ΟΝΟΜΑ[J]<ΟΝΟΜΑ[J-1] ΤΟΤΕ
        Χ <-- ΟΝΟΜΑ[J]
        ΟΝΟΜΑ[J] <-- ΟΝΟΜΑ[J-1]
        ΟΝΟΜΑ[J-1] <-- Χ
        ΓΙΑ K ΑΠΟ 1 ΜΕΧΡΙ 4
          Υ <-- ΒΑΘΜΟΣ[J,K]
          ΒΑΘΜΟΣ[J,K] <-- ΒΑΘΜΟΣ[J-1,K]
          ΒΑΘΜΟΣ[J-1,K] <-- Υ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ ΟΝΟΜΑ[Ι]
    ΓΡΑΨΕ ΒΑΘΜΟΣ[Ι,1]
    ΓΡΑΨΕ ΒΑΘΜΟΣ[Ι,2]
    ΓΡΑΨΕ ΒΑΘΜΟΣ[Ι,3]
    ΓΡΑΨΕ ΒΑΘΜΟΣ[Ι,4]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Αντωνόπουλος Αντώνης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters