Τώρα είναι Πέμ 04 Ιουν 2020 02:40 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 18 Δεκ 2006 11:43 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===========================================================================================
! 100 μαθητές της τεχνολογικής κατεύθυνσης εξετάστησαν πανελλαδικά στα 6 μαθήματα :
! Μαθηματικά - Φυσική - Γλώσσα - Υπολογιστές -_Διοίκηση Επιχειρήσεων - Μαθ. Επιλογής
! Να γραφεί πρόγραμμα το οποίο :
!  α) Να καταχωρεί σε πίνακα τα ονόματα των μαθημάτων με τη σειρά που αναφέρονται παραπάνω.
!  β) Να ζητά και να καταχωρεί σε πίνακα τους βαθμούς των 100 μαθητών.
!     Να γίνεται έλεγχος για το αν ο βαθμός είναι μεταξύ 1 και 100.(Θεωρήστε δεδομένο ότι
!     είναι ακέραιος)
!  γ) Να εμφανίζει τα αποτελέσματα ταξινομημένα από τον καλύτερο στο χειρότερο μαθητή με βάση
!     το βαθμό τους στο μάθημα των υπολογιστών. Σε περίπτωση ισοβαθμίας η ταξινόμηση να γίνει
!     με βάση το βαθμό στα μαθηματικά.
! ===========================================================================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i ,j ,k , temp1 , b[100,6]
  ΧΑΡΑΚΤΗΡΕΣ : μαθ[6],name[100], temp2
ΑΡΧΗ
  Μαθ[1] <-- 'ΜΑΘΗΜΑΤΙΚΑ'
  Μαθ[2] <-- 'ΦΥΣΙΚΗ'
  Μαθ[3] <-- 'ΓΛΩΣΣΑ'
  Μαθ[4] <-- 'ΥΠΟΛΟΓΙΣΤΕΣ'
  Μαθ[5] <-- 'ΔΙΟΙΚΗΣΗ ΕΠΙΧΕΙΡΗΣΕΩΝ'
  Μαθ[6] <-- 'ΜΑΘ. ΕΠΙΛΟΓΗΣ'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ 'Δώσε το όνομα του μαθητή',i
    ΔΙΑΒΑΣΕ name[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ 'Δώσε το βαθμό στο μάθημα',Μαθ[j]
      ΔΙΑΒΑΣΕ b[i,j]
      ΟΣΟ b[i,j] < 1 ή b[i,j] > 100 ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'Λάθος. Ο βαθμός πρέπει να είναι από 1 έως 100. Ξαναδώσε.'
        ΔΙΑΒΑΣΕ b[i,j]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ j ΑΠΟ 100 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ (b[j-1,4] < b[j,4]) ή (b[j-1,4] = b[j,4] ΚΑΙ b[j-1,1] < b[j,1]) ΤΟΤΕ
        ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 6
          temp1 <-- b[j-1,k]
          b[j-1,k] <-- b[j,k]
          b[j,k] <-- temp1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        temp2 <-- name[j-1]
        name[j-1] <-- name[j]
        name[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    ΓΡΑΨΕ '=========================='
    ΓΡΑΨΕ name[i]
    ΓΡΑΨΕ '--------------------------'
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ Μαθ[j],':',b[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters