Τώρα είναι Πέμ 04 Ιουν 2020 12:56 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 10 Μαρ 2005 05:20 am 
Χωρίς σύνδεση

Εγγραφή: Πέμ 22 Απρ 2004 11:16 am
Δημοσιεύσεις: 60
Τοποθεσία: Θεσσαλονίκη
Syntax: [ Download ] [ Hide ]
! ===================================================================================
! Να γίνει πρόγραμμα το οποίο θα δέχεται το πλήθος των γκολ
! που σημείωσε κάθε μία από τις l6 ομάδες του επαγγελματικού
! πρωταθλήματος σε κάθε αγωνιστική. θεωρήστε ότι το πρωτάθλημα
! έχει συνολικά 30 αγωνιστικές. To πρόγραμμα πρέπει:
! α)  Να διαβάζει τα ονοματα των 16 ομάδων του πρωταθλήματος,(ΚΕΦΑΛΑΙΑ ελληνικά)
! β)  Να διαβάζει τα γκολ που σημείωσε κάθε ομάδα σε κάθε αγωνιστική,
! γ)  Να υπολογίζει και να εμφανίζει τα συνολικά γκολ που σημειώθηκαν στο πρωτάθλημα,
! δ)  Να εμφανίζει την ομάδα (ή ομάδες) με τα λιγότερα συνολικα γκολ στο πρωτάθλημα,
!     καθως και πόσα ήταν αυτά (υποθέστε οτι μπορεί να είναι περισσότερες από
!    μια ομάδες)
! ε)  Να εμφανίζει πόσα γκολ σημειωθηκαν σε κάθε αγωνιστική,
! στ) Να εμφανίζει τα περισσότερα γκολ που σημειώθηκαν σε έναν αγώνα κατά
!     τη διάρκεια του πρωταθλήματος (υποθέστε ότι είναι μοναδικό αυτό το σκορ) καθώς
!     και ποια ομάδα τα πέτυχε
! ζ)  Να εμφανίζει το μέγιστο σκορ που σημείωσε κάθε ομάδα, καθώς και σε ποια
!     αγωνιστική το πέτυχε για πρώτη φορά.
! η)  Να εμφανίζει τις ομάδες που στις 6 πρώτες αγωνιστικές είχαν
!     τουλάχιστον 3 αγώνες στους οποίους σημείωσαν 2 γκολ.
! θ)  Να ζητά το όνομα μιας ομάδας, να ελέγχει και να εμφανίζει αν υπάρχει αγώνας
!     στον οποίο ή ομάδα αυτή πέτυχε περισσότερα από 5 γκολ.
!     Αν υπάρχει να εμφανίζει τον πρωτο αγώνα που αυτό συνέβη.
! ι)  Να εμφανίζει το ονομα της κάθε ομάδας κατα αλφαβητική σειρά,
!     και διπλα τα γκολ που πέτυχε σε κάθε αγωνιστική κατά φθινουσα σειρά σκορ.
! ===================================================================================


ΠΡΟΓΡΑΜΜΑ Πρωταθλημα
ΣΤΑΘΕΡΕΣ
  Ομδ=16
  Αγων=2*Ομδ-2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i,j,k,θ,min,max,ΓΚΟΛ[Ομδ,Αγων],ΓΚΟΛ2[Ομδ,Αγων],sum,Σ[Ομδ],αγ_max,αγ,match,team[Ομδ],temp2
  ΧΑΡΑΚΤΗΡΕΣ: όνομα[Ομδ],Ομ,ομδ_max,temp1
  ΛΟΓΙΚΕΣ: βρεθηκε
ΑΡΧΗ

! ----- α ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΡΑΨΕ 'Δωσε όνομα ',i,'ης ομάδας'
    ΔΙΑΒΑΣΕ ονομα[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ----- β ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      ΓΡΑΨΕ 'Ποσα γκολ σημειωθηκαν στην ',j,'η αγωνιστική από την ομάδα ',ονομα[i]
      ΔΙΑΒΑΣΕ Γκολ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- γ ερώτημα ---------------

  sum <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      sum <-- sum + Γκολ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Tα συνολικά γκολ του πρωταθλήματος είναι ',sum
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- δ ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    sum <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      sum <-- sum + Γκολ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Σ[i] <-- sum
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- Σ[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ομδ
    ΑΝ Σ[i]<min ΤΟΤΕ
      min <-- Σ[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Τα λιγοτερα συνολικά γκολ στο πρωτάθλημα από μια ομαδα είναι ',min

  ΓΡΑΨΕ 'Οι επόμενες ομάδες σημείωσαν τα λιγοτερα συνολικά γκολ:'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΑΝ Σ[i]=min ΤΟΤΕ
      ΓΡΑΨΕ ονομα[i]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- ε ερώτημα ---------------

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
    sum <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
      sum <-- sum + Γκολ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Στην ',j,'η αγωνιστική σημειώθηκαν συνολικά ',sum,' γκολ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- στ ερώτημα ---------------

  max <-- Γκολ[1,1]
  ομδ_max <-- ονομα[1]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      ΑΝ Γκολ[i,j]>max ΤΟΤΕ
        max <-- Γκολ[i,j]
        ομδ_max <-- ονομα[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Tα περισσότερα γκολ που σημειώθηκαν σε έναν αγώνα στο πρωτάθλημα είναι ',max,' από την ομάδα ', ομδ_max
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- ζ ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    max <-- Γκολ[i,1]
    αγ_max <-- 1
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ Αγων
      ΑΝ Γκολ[i,j]>max ΤΟΤΕ
        max <-- Γκολ[i,j]
        αγ_max <-- j
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'H ομάδα ',ονομα[i],' πέτυχε μεγιστο σκορ: ', max, ' στην ',αγ_max,'η αγωνιστική'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- η ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    αγ <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΑΝ Γκολ[i,j]>=2 ΤΟΤΕ
        αγ <-- αγ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ αγ>=3 ΤΟΤΕ
      ΓΡΑΨΕ 'H ομάδα ',ονομα[i],' ειχε τουλάχιστον 3 αγώνες στις 6 πρώτες αγωνιστικές στους οποίους σημείωσε 2 γκολ'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- Θ ερώτημα ---------------
  βρεθηκε <-- ψευδης
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Δωσε όνομα ομαδας για να ελεγχθεί αν έχει αγώνα με πάνω από 5 γκολ'
    ΔΙΑΒΑΣΕ Ομ
    i <-- 1
    ΟΣΟ (i<=Ομδ) ΚΑΙ (ΟΧΙ βρεθηκε) ΕΠΑΝΑΛΑΒΕ
      ΑΝ Ομ=ονομα[i] ΤΟΤΕ
        βρεθηκε <-- αληθής
        θ <-- i
      ΤΕΛΟΣ_ΑΝ
      i <-- i+1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ βρεθηκε=αληθής

  βρεθηκε <-- ψευδης
  j <-- 1
  ΟΣΟ (j<=Αγων) ΚΑΙ ΟΧΙ βρεθηκε ΕΠΑΝΑΛΑΒΕ
    ΑΝ Γκολ[θ,j]>5 ΤΟΤΕ
      match <-- j
      βρεθηκε <-- αληθής
    ΤΕΛΟΣ_ΑΝ
    j <-- j+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ βρεθηκε ΤΟΤΕ
    ΓΡΑΨΕ 'Ή ομαδα ',Ομ,' πέτυχε για πρωτη φορά 5 γκολ στην ',match,'η αγωνιστική'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Ή ομαδα ',Ομ,' δεν πέτυχε ποτε 5 γκολ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ  '====================================================='
  ΓΡΑΨΕ
! ----- ι ερώτημα ---------------

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    team[i] <-- i
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ομδ
    ΓΙΑ j ΑΠΟ Ομδ ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ονομα[j-1]>ονομα[j] ΤΟΤΕ
        temp1 <-- ονομα[j-1]
        ονομα[j-1] <-- ονομα[j]
        ονομα[j] <-- temp1
        temp2 <-- team[j-1]
        team[j-1] <-- team[j]
        team[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      Γκολ2[i,j] <-- Γκολ[team[i],j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΙΑ k ΑΠΟ 2 ΜΕΧΡΙ Αγων
      ΓΙΑ j ΑΠΟ Αγων ΜΕΧΡΙ k ΜΕ ΒΗΜΑ -1
        ΑΝ Γκολ2[i,j-1]<Γκολ2[i,j] ΤΟΤΕ
          temp2 <-- Γκολ2[i,j-1]
          Γκολ2[i,j-1]  <-- Γκολ2[i,j]
          Γκολ2[i,j] <-- temp2
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ομδ
    ΓΡΑΨΕ_ ονομα[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Αγων
      ΓΡΑΨΕ_ Γκολ2[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

_________________
Φρειδερίκος Κώστας
FreiderikosK@hotmail.com


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters