Τώρα είναι Δευτ 23 Σεπ 2019 08:29 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: PROGRAMMA YPOLOGISMOU MORIWN G LYKEIOU
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 30 Μάιος 2011 10:10 pm 
Χωρίς σύνδεση

Εγγραφή: Δευτ 02 Νοέμ 2009 08:40 pm
Δημοσιεύσεις: 5
Syntax: [ Download ] [ Hide ]
!ΤΟ ΠΑΡΑΚΑΤΩ ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΖΕΙ ΚΑΙ ΕΜΦΑΝΙΖΕΙ ΤΑ ΜΟΡΙΑ ΤΟΥ ΕΞΕΤΑΖΟΜΕΝΟΥ ΣΕ ΚΑΘΕ ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ (1ο,2ο,3ο,4ο,5ο)
!ΕΠΙΣΗΣ ΥΠΟΛΟΓΙΖΕΙ ΚΑΙ ΕΜΦΑΝΙΖΕΙ ΤΟΝ ΒΑΘΜΟ ΠΡΟΣΒΑΣΗΣ ΤΟΥ ΕΞΕΤΑΖΟΜΕΝΟΥ
ΠΡΟΓΡΑΜΜΑ ΠΡΟΓΡΑΜΜΑ_ΜΟΡΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κ,ι,j
  ΠΡΑΓΜΑΤΙΚΕΣ:Β[7],ΓΒΠ,ΜΟΡΙΑ124,ΜΟΡΙΑ3,ΜΟΡΙΑ24,ΜΟΡΙΑ5,ΠΒ[7,2],ΜΟΠΒ[7],sum[7]
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝΟΜΑ,Μ[7],ΑΠ,ΚΑΤ
ΑΡΧΗ
  ΓΡΑΨΕ '                                  _________________'
  ΓΡΑΨΕ '                                  ΑΡΧΗ ΠΡΟΓΡΑΜΜΑΤΟΣ'
  ΓΡΑΨΕ '                                  _________________'
  ΓΡΑΨΕ '             ΠΡΟΓΡΑΜΜΑΤΙΣΤΗΣ ΤΟΥ ΠΑΡΑΚΑΤΩ ΠΡΟΓΡΑΜΜΑΤΟΣ: ΓΙΑΚΟΥΜΗΣ ΑΝΤΩΝΙΟΣ'
  ΓΡΑΨΕ 'ΤΟ ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΖΕΙ ΚΑΙ ΕΜΦΑΝΙΖΕΙ ΤΟΝ ΓΕΝΙΚΟ ΒΑΘΜΟ ΠΡΟΣΒΑΣΗΣ ΤΩΝ ΠΑΝΕΛΛΗΝΙΩΝ ΤΗΣ Γ ΛΥΚΕΙΟΥ'
  ΓΡΑΨΕ '                  ΚΑΙ ΤΑ ΜΟΡΙΑ ΕΙΣΑΓΩΓΗΣ ΣΕ ΚΑΘΕ ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ'
  ΓΡΑΨΕ '----------------------------------------------------------------------------------------------'
  ΓΡΑΨΕ 'ΒΑΛΤΕ ΤΟ ΠΛΗΚΤΡΟΛΟΓΙΟ ΣΤΑ ΚΕΦΑΛΑΙΑ ΕΛΛΗΝΙΚΑ !!!'
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΟΝΟΜΑ ΚΑΙ ΤΟ ΕΠΙΘΕΤΟ ΤΟΥ ΕΞΕΤΑΖΟΜΕΝΟΥ...'
  ΔΙΑΒΑΣΕ ΟΝΟΜΑ
  ΓΡΑΨΕ 'ΤΙ ΚΑΤΕΥΘΥΝΣΗ ΕΙΣΑΙ; (ΘΕΩΡΗΤΙΚΗ,ΘΕΤΙΚΗ,ΤΕΧΝΟΛΟΓΙΚΗ)'
  ΔΙΑΒΑΣΕ ΚΑΤ
  ΟΣΟ ΚΑΤ<>'ΘΕΩΡΗΤΙΚΗ' ΚΑΙ ΚΑΤ<>'ΘΕΤΙΚΗ' ΚΑΙ ΚΑΤ<>'ΤΕΧΝΟΛΟΓΙΚΗ' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΛΑΘΟΣ ΚΑΤΕΥΘΥΝΣΗ, ΞΑΝΑΔΩΣΕ (π.χ. ΘΕΩΡΗΤΙΚΗ,ΘΕΤΙΚΗ,ΤΕΧΝΟΛΟΓΙΚΗ)'
    ΔΙΑΒΑΣΕ ΚΑΤ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Μ[1] <-- 'ΕΚΘΕΣΗ'
  Κ <-- 6
  ΑΝ ΚΑΤ='ΘΕΩΡΗΤΙΚΗ' ΤΟΤΕ
    Μ[3] <-- 'ΑΡΧΑΙΑ'
    Μ[4] <-- 'ΙΣΤΟΡΙΑ'
    Μ[5] <-- 'ΚΕΙΜΕΝΑ'                          
    Μ[6] <-- 'ΛΑΤΙΝΙΚΑ'
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ='ΘΕΤΙΚΗ' ΤΟΤΕ
    Μ[3] <-- 'ΜΑΘΗΜΑΤΙΚΑ ΚΑΤΕΥΘΥΝΣΗΣ'
    Μ[4] <-- 'ΒΙΟΛΟΓΙΑ ΚΑΤΕΥΘΥΝΣΗΣ'
    Μ[5] <-- 'ΦΥΣΙΚΗ ΚΑΤΕΥΘΥΝΣΗΣ'
    Μ[6] <-- 'ΧΗΜΕΙΑ'
  ΑΛΛΙΩΣ
    Μ[3] <-- 'ΜΑΘΗΜΑΤΙΚΑ ΚΑΤΕΥΘΥΝΣΗΣ'
    Μ[4] <-- 'ΑΟΔΕ'
    Μ[5] <-- 'ΦΥΣΙΚΗ ΚΑΤΕΥΘΥΝΣΗΣ'
    Μ[6] <-- 'ΑΕΠΠ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ (π.χ. ΜΑΘΗΜΑΤΙΚΑ,ΒΙΟΛΟΓΙΑ,ΦΥΣΙΚΗ,ΙΣΤΟΡΙΑ)'
  ΔΙΑΒΑΣΕ Μ[2]
  ΑΝ Μ[2]='ΜΑΘΗΜΑΤΙΚΑ' ΤΟΤΕ
    ΓΡΑΨΕ 'ΘΑ ΔΩΣΕΙΣ ΟΙΚΟΝΟΜΙΑ; ΑΠΑΝΤΗΣΕ ΜΕ ΝΑΙ Η ΟΧΙ'
    ΔΙΑΒΑΣΕ ΑΠ
    ΟΣΟ ΑΠ<>'ΝΑΙ' ΚΑΙ ΑΠ<>'ΟΧΙ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΑΠΑΝΤΗΣΕ ΜΕ ΝΑΙ Η ΟΧΙ'
      ΔΙΑΒΑΣΕ ΑΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΠ='ΝΑΙ' ΤΟΤΕ
      Μ[7] <-- 'ΟΙΚΟΝΟΜΙΑ'
      Κ <-- Κ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο/Η',ΟΝΟΜΑ,'ΕΔΩΣΕ',Κ,'ΜΑΘΗΜΑΤΑ'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΡΑΨΕ Ι,')'[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ




  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    sum[ι] <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 2
      ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΠΡΟΦΟΡΙΚΟ ΒΑΘΜΟ ΤΟΥ',j,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΜΑΘΗΜΑ -->'[ι],'<--'
      ΔΙΑΒΑΣΕ ΠΒ[ι,j]
      ΟΣΟ ΠΒ[ι,j]<0 Η ΠΒ[ι,j]>20 ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ'
        ΔΙΑΒΑΣΕ ΠΒ[ι,j]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      sum[ι] <-- sum[ι] + ΠΒ[ι,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟΠΒ[ι] <-- sum[ι]/2
    ΓΡΑΨΕ '----------------------------------------------------------------------------------------------------'
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΓΡΑΠΤΟ ΒΑΘΜΟ ΣΤΟ ΜΑΘΗΜΑ -->'[ι],'<--'
    ΔΙΑΒΑΣΕ Β[ι]
    ΟΣΟ Β[ι]<0 Η Β[ι]>20 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ'
      ΔΙΑΒΑΣΕ Β[ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ '----------------------------------------------------------------------------------------------------'
    ΓΡΑΨΕ ' '
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ




  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=1.9) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.6
    ΑΛΛΙΩΣ_ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=1.6) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.5
    ΑΛΛΙΩΣ_ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=1.2) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.4
    ΑΛΛΙΩΣ_ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=0.9) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.3
    ΑΛΛΙΩΣ_ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=0.6) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.2
    ΑΛΛΙΩΣ_ΑΝ (ΜΟΠΒ[ι]-Β[ι]>=0.2) ΤΟΤΕ
      Β[ι] <-- Β[ι]+0.1
    ΑΛΛΙΩΣ
      Β[ι] <-- Β[ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Ο ΒΑΘΜΟΣ ΠΡΟΣΒΑΣΗΣ ΤΟΥ ΚΑΘΕ ΜΑΘΗΜΑΤΟΣ ΠΡΟΣΑΡΜΟΣΜΕΝΟΣ ΜΕ ΤΟΝ ΠΡΟΦΟΡΙΚΟ ΒΑΘΜΟ ΤΩΝ ΤΕΤΡΑΜΗΝΩΝ ΕΙΝΑΙ:'    
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΡΑΨΕ Μ[ι],'-->'[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



  ΓΒΠ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΒΠ <-- Β[Ι]+ΓΒΠ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΒΠ <-- ΓΒΠ/Κ


  ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
  ΓΡΑΨΕ 'Ο ΓΕΝΙΚΟΣ ΒΑΘΜΟΣ ΠΡΟΣΒΑΣΗΣ ΕΙΝΑΙ:',ΓΒΠ
  ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
  ΜΟΡΙΑ124 <-- (ΓΒΠ*8+Β[3]*1.3+Β[5]*0.7)*100
  ΑΝ ΚΑΤ='ΘΕΤΙΚΗ' Η ΚΑΤ='ΤΕΧΝΟΛΟΓΙΚΗ' ΤΟΤΕ
    ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΑ ΠΕΔΙΑ ΒΑΡΗΤΗΤΑΣ (2ο ΚΑΙ 4ο ΓΙΑ ΤΗΝ',ΚΑΤ,'), ΕΙΝΑΙ:',ΜΟΡΙΑ124
    ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΟ 1ο ΠΕΔΙΟ ΒΑΡΗΤΗΤΑΣ ( ΓΙΑ ΤΗΝ ΘΕΩΡΗΤΙΚΗ) ΕΙΝΑΙ:',ΜΟΡΙΑ124
    ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Μ[4]='ΒΙΟΛΟΓΙΑ ΚΑΤΕΥΘΥΝΣΗΣ' ΤΟΤΕ
    ΜΟΡΙΑ3 <-- (ΓΒΠ*8+Β[4]*1.3+Β[6]*0.7)*100
    ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΟ 3ο ΠΕΔΙΟ (ΓΙΑ ΤΗΝ ΘΕΤΙΚΗ) ΕΙΝΑΙ:',ΜΟΡΙΑ3
    ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ='ΘΕΩΡΗΤΙΚΗ' Η ΚΑΤ='ΤΕΧΝΟΛΟΓΙΚΗ' ΤΟΤΕ
    ΑΝ Μ[2]='ΒΙΟΛΟΓΙΑ' ΤΟΤΕ
      ΜΟΡΙΑ3 <-- (ΓΒΠ*8+Β[3]*0.9+Β[1]*0.4)*100
      ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΟ 3ο ΠΕΔΙΟ ΛΟΓΩ ΒΙΟΛΟΓΙΑΣ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ (ΓΙΑ ΤΗΝ',ΚΑΤ,') ΕΙΝΑΙ:',ΜΟΡΙΑ3
      ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ='ΘΕΩΡΗΤΙΚΗ' ΤΟΤΕ
    ΑΝ Μ[2]='ΜΑΘΗΜΑΤΙΚΑ' ΤΟΤΕ
      ΜΟΡΙΑ24 <-- (ΓΒΠ*8+Β[3]*0.9+Β[1]*0.4)*100
      ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΟ 2ο ΚΑΙ 4ο ΠΕΔΙΟ ΛΟΓΩ ΤΩΝ ΜΑΘΗΜΑΤΙΚΩΝ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ (ΓΙΑ ΤΗΝ ΘΕΩΡΗΤΙΚΗ) ΕΙΝΑΙ:',ΜΟΡΙΑ24
      ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΑΝ Μ[2]='ΜΑΘΗΜΑΤΙΚΑ' ΤΟΤΕ
    ΑΝ ΑΠ='ΝΑΙ' ΤΟΤΕ
      ΜΟΡΙΑ5 <-- (ΓΒΠ*8+Β[7]*1.3+Β[2]*0.7)*100
      ΓΡΑΨΕ 'ΤΑ ΜΟΡΙΑ ΣΤΟ 5ο ΠΕΔΙΟ (ΛΟΓΩ ΟΙΚΟΝΟΜΙΑΣ) ΕΙΝΑΙ:', ΜΟΡΙΑ5
      ΓΡΑΨΕ '-----------------------------------------------------------------------------------------------------------'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '                                     __________________'
  ΓΡΑΨΕ '                                     ΤΕΛΟΣ ΠΡΟΓΡΑΜΜΑΤΟΣ'
  ΓΡΑΨΕ '                                     __________________'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters