Τώρα είναι Δευτ 13 Ιούλ 2020 01:53 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 18 Φεβ 2007 11:52 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 27 Ιαν 2007 02:27 pm
Δημοσιεύσεις: 4
Τοποθεσία: Κομοτηνή
ΝΑ ΚΑΤΑΣΚΕΥΑΣΕΤΕ ΠΡΟΓΡΑΜΜΑ, ΤΟ ΟΠΟΙΟ ΘΑ ΧΡΗΣΙΜΟΠΟΙΗΘΕΙ ΓΙΑ ΤΗΝ ΚΡΑΤΗΣΗ ΘΕΣΕΩΝ ΣΕ ΕΝΑ ΤΡΕΝΟ 10 ΘΕΣΕΩΝ.

Α) ΝΑ ΔΙΑΒΑΖΕΙ ΤΟ ΟΝΟΜΑ ΤΟΥ ΤΑΞΙΔΙΩΤΗ ΚΑΙ ΤΟ ΑΝ ΔΙΚΑΙΟΥΤΑΙ ΜΕΙΩΜΕΝΟ ΕΙΣΙΤΗΡΙΟ (Η ΤΙΜΗ 'Κ' ΔΗΛΩΝΕΙ ΤΟ ΚΑΝΟΝΙΚΟ ΕΙΣΙΤΗΡΙΟ ΚΑΙ Η ΤΙΜΗ 'Μ' ΤΟ ΜΕΙΩΜΕΝΟ) ΚΑΙ ΝΑ ΤΑ ΑΠΟΘΗΚΕΥΕΙ ΣΕ ΔΥΟ ΞΕΧΩΡΙΣΤΟΥΣ ΠΙΝΑΚΕΣ.

Β) ΝΑ ΔΙΑΒΑΖΕΙ ΤΗΝ ΘΕΣΗ ΠΟΥ ΕΠΙΘΥΜΕΙ Ο ΤΑΞΙΔΙΩΤΗΣ (ΝΑ ΓΙΝΕΤΑΙ ΕΛΕΓΧΟΣ ΩΣΤΕ Η ΘΕΣΗ ΑΥΤΗ ΝΑ ΕΙΝΑΙ ΑΚΕΡΑΙΟΣ ΜΕΤΑΞΥ 1 ΚΑΙ 10)

Γ) ΝΑ ΕΛΕΓΧΕΙ ΑΝ Η ΘΕΣΗ ΠΟΥ ΖΗΤΗΘΗΚΕ ΕΙΝΑΙ ΔΙΑΘΕΣΙΜΗ ΧΡΗΣΙΜΟΠΟΙΩΝΤΑΣ ΕΝΑΝ ΠΙΝΑΚΑ ΔΙΑΘΕΣΙΜΟΤΗΤΑ ΠΟΥ ΠΕΡΙΕΧΕΙ ΛΟΓΙΚΕΣ ΤΙΜΕΣ (Η ΤΙΜΗ ΑΛΗΘΗΣ ΔΗΛΩΝΕΙ ΟΤΙ Η ΘΕΣΗ ΕΙΝΑΙ ΚΕΝΗ ΚΑΙ Η ΤΙΜΗ ΨΕΥΔΗΣ ΟΤΙ Η ΘΕΣΗ ΕΙΝΑΙ ΗΔΗ ΔΕΣΜΕΥΜΕΝΗ). ΕΑΝ Η ΖΗΤΟΥΜΕΝΗ ΘΕΣΗ ΕΙΝΑΙ ΔΙΑΘΕΣΙΜΗ ΤΟΤΕ ΝΑ ΤΥΠΩΝΕΤΑΙ «ΕΠΙΤΥΧΗΣ ΚΡΑΤΗΣΗ», ΑΛΛΙΩΣ «ΘΕΣΗ ΚΡΑΤΗΜΕΝΗ, ΞΑΝΑΠΡΟΣΠΑΘΗΣΕ» ΚΑΙ ΝΑ ΔΙΑΒΑΖΕΤΑΙ ΝΕΟΣ ΑΡΙΘΜΟΣ ΘΕΣΗΣ ΓΙΑ ΚΡΑΤΗΣΗ, ΑΦΟΥ ΠΡΩΤΑ ΤΥΠΩΘΟΥΝ ΜΕ ΜΗΝΥΜΑΤΑ ΟΛΕΣ ΟΙ ΔΙΑΘΕΣΙΜΕΣ ΘΕΣΕΙΣ ΣΤΟ ΤΡΕΝΟ

Δ) ΝΑ ΕΜΦΑΝΙΖΕΙ ΤΑ ΟΝΟΜΑΤΑ ΚΑΙ ΤΙΣ ΘΕΣΕΙΣ ΣΤΙΣ ΟΠΟΙΕΣ ΒΡΙΣΚΟΝΤΑΙ ΑΥΤΟΙ ΠΟΥ ΔΙΚΑΙΟΥΝΤΑΙ ΜΕΙΩΜΕΝΟ ΕΙΣΙΤΗΡΙΟ
ΘΕΩΡΕΙΣΤΕ ΟΤΙ ΤΟ ΠΡΟΓΡΑΜΜΑ ΤΕΡΜΑΤΙΖΕΤΑΙ ΟΤΑΝ ΟΛΟ ΤΟ ΤΡΕΝΟ ΓΕΜΙΣΕΙ ΚΑΙ ΟΤΙ Ο ΚΑΘΕ ΕΠΙΒΑΤΗΣ ΜΠΟΡΕΙ ΝΑ ΔΕΣΜΕΥΣΕΙ ΜΟΝΟ ΜΙΑ ΘΕΣΗ.

_________________
Αντωνόπουλος Αντώνης


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 07 Ιουν 2007 09:13 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 27 Ιαν 2007 02:27 pm
Δημοσιεύσεις: 4
Τοποθεσία: Κομοτηνή
Τώρα, που τελείωσαν και οι εξετάσεις, μπορούμε να ασχοληθούμε λίγο με αυτά που είχαμε αφήσει εκκρεμή. Για ρίξτε μία ματιά στον κώδικα. Έχετε καμία άλλη ιδέα???


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΤΡΕΝΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:Ι, Θ, ΠΛ, Β, ΜΗΝΥΜΑ[10]
  ΧΑΡΑΚΤΗΡΕΣ:ΕΙΔΟΣ[30], ΟΝΟΜΑ[10]
  ΛΟΓΙΚΕΣ:ΔΙΑΘΕΣΙΜΟΤΗΤΑ[10]
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΔΙΑΘΕΣΙΜΟΤΗΤΑ[Ι] <-- ΑΛΗΘΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΟΝΟΜΑ ΤΟΥ', Ι,'ΟΥ ΤΑΞΙΔΙΩΤΗ'
    ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
    ΟΣΟ ΟΝΟΜΑ[Ι]<'Α' Η ΟΝΟΜΑ[Ι]>'Ω' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'ΛΑΘΟΣ ΟΝΟΜΑ, ΔΩΣΕ ΝΕΟ'
      ΔΙΑΒΑΣΕ ΟΝΟΜΑ[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ'ΔΩΣΕ ΕΙΔΟΣ ΕΙΣΙΤΗΡΙΟΥ, Κ ΓΙΑ ΚΑΝΟΝΙΚΟ ΚΑΙ Μ ΓΙΑ ΜΕΙΩΜΕΝΟ'
    ΔΙΑΒΑΣΕ ΕΙΔΟΣ[Ι]
    ΟΣΟ ΕΙΔΟΣ[Ι]<>'Κ' ΚΑΙ ΕΙΔΟΣ[Ι]<>'Μ' ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ' ΛΑΘΟΣ ΔΕΔΟΜΕΝΑ, ΕΙΣΑΓΕΤΕ ΝΕΑ'
      ΔΙΑΒΑΣΕ ΕΙΔΟΣ[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ'ΕΙΣΑΓΕΤΕ ΤΟΝ ΑΡΙΘΜΟ ΤΗΣ ΘΕΣΗΣ ΠΟΥ ΕΠΙΘΥΜΕΙΤΕ ΝΑ ΔΕΣΜΕΥΣΕΤΕ'
    ΔΙΑΒΑΣΕ Θ
    ΟΣΟ Θ<0 ΚΑΙ Θ>10 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ'ΛΑΘΟΣ ΔΕΔΟΜΕΝΑ, ΕΙΣΑΓΕΤΕ ΝΕΑ'
      ΔΙΑΒΑΣΕ Θ                        
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΔΙΑΘΕΣΙΜΟΤΗΤΑ[Θ]=ΑΛΗΘΗΣ ΤΟΤΕ
      ΓΡΑΨΕ'ΕΠΙΤΥΧΗΣ ΚΡΑΤΗΣΗ'
      ΔΙΑΘΕΣΙΜΟΤΗΤΑ[Θ] <-- ΨΕΥΔΗΣ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ'ΘΕΣΗ ΚΡΑΤΗΜΕΝΗ, ΞΑΝΑΠΡΟΣΠΑΘΗΣΕ'
      ΠΛ <-- 0
      ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ 10
        ΑΝ ΔΙΑΘΕΣΙΜΟΤΗΤΑ[Β]=ΑΛΗΘΗΣ ΤΟΤΕ
          ΠΛ <-- ΠΛ + 1
          ΜΗΝΥΜΑ[ΠΛ] <-- Β
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'ΔΙΑΘΕΣΙΜΕΣ ΘΕΣΕΙΣ'
      ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ ΠΛ
        ΓΡΑΨΕ ΜΗΝΥΜΑ[Β]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ'ΤΩΡΑ ΔΩΣΕ ΝΕΑ ΕΠΙΘΥΜΗΤΗ ΘΕΣΗ ΚΡΑΤΗΣΗΣ'
      ΔΙΑΒΑΣΕ Θ
      ΟΣΟ ΔΙΑΘΕΣΙΜΟΤΗΤΑ[Θ]=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ'Η ΘΕΣΗ ΑΥΤΗ ΔΕΝ ΒΡΙΣΚΕΤΑΙ ΜΕΤΑΞΥ ΑΥΤΩΝ ΠΟΥ ΕΙΝΑΙ ΔΙΑΘΕΣΙΜΕΣ'
        ΓΡΑΨΕ 'ΔΙΑΘΕΣΙΜΕΣ ΘΕΣΕΙΣ'
        ΓΙΑ Β ΑΠΟ 1 ΜΕΧΡΙ ΠΛ
          ΓΡΑΨΕ ΜΗΝΥΜΑ[Β]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΓΡΑΨΕ'ΤΩΡΑ ΔΩΣΕ ΝΕΑ ΕΠΙΘΥΜΗΤΗ ΘΕΣΗ ΚΡΑΤΗΣΗΣ'
        ΔΙΑΒΑΣΕ Θ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

_________________
Αντωνόπουλος Αντώνης


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters