Τώρα είναι Δευτ 17 Φεβ 2020 03:59 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 22 Δεκ 2006 04:27 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 22 Δεκ 2006 03:22 pm
Δημοσιεύσεις: 3
Τοποθεσία: Ξυλοκαστρο
Syntax: [ Download ] [ Hide ]
Να γραφεί πρόγραμμα που να διαβάζει τα στοιχεία δύο μονοδιάστατων πινάκων 5 θέσεων ο καθένας και:

1) Να ταξινομεί τους δύο πίνακες.
2) Να συγχωνεύει τους δύο πίνακες σε έναν τρίτο πίνακα, ο οποίος θα είναι επίσης ταξινομημένος.
 

:roll:


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 30 Ιαν 2007 01:13 am 
Χωρίς σύνδεση

Εγγραφή: Τρί 30 Ιαν 2007 01:08 am
Δημοσιεύσεις: 1
Τοποθεσία: Αθήνα
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΣΥΓΧΩΝΕΥΣΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i,j,t,k
  ΠΡΑΓΜΑΤΙΚΕΣ:Α[5][5],TEMP,Γ[10]
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΔΙΑΒΑΣΕ Α[i][i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 5 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ Α[j-1]>Α[j] ΤΟΤΕ
        TEMP <-- Α[j-1]
        Α[j-1] <-- Α[j]
        Α[j-1] <-- TEMP
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Β[j-1]>Β[j] ΤΟΤΕ
        TEMP <-- Β[j-1]
        Β[j-1] <-- Β[j]
        Β[j] <-- TEMP
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  k <-- 1
  ΟΣΟ i<=5 ΕΠΑΝΑΛΑΒΕ
    ΑΝ Α[i]<Β[i] ΤΟΤΕ
      Γ[k] <-- Α[i]
      i <-- i+1
    ΑΛΛΙΩΣ
      Γ[k] <-- Β[i]
      j <-- j+1
    ΤΕΛΟΣ_ΑΝ
    k <-- k+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ i<j ΤΟΤΕ
    ΓΙΑ t ΑΠΟ i ΜΕΧΡΙ 5
      Γ[k+t-i] <-- Α[t]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΛΛΙΩΣ
    ΓΙΑ t ΑΠΟ j ΜΕΧΡΙ 5
      Γ[k+t-1] <-- Β[t]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΓΧΩΝΕΥΣΗ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters